MEGAsquirt A place to collectively sort out this megasquirt gizmo
Sponsored by:
Sponsored by:

ms3pro stumbles/bogs after shifting...

 
Old 04-14-2019, 03:40 PM
  #1  
Newb
Thread Starter
 
Join Date: Sep 2018
Posts: 19
Total Cats: -1
Default ms3pro stumbles/bogs after shifting...

After spending a lot of time reading, asking for suggestions and general trial and error I have gotten the car to be pretty drivable. Idles well with tiny amount of fluctuation. Good cold and hot starts that I am pretty happy with. But, alas, tuning continues.

I had a stalling issue when going clutch in and decelerating and have narrowed that down to poorly tuned overrun fuel cut, so for now I have turned it off and have not had one stall issue since. I need further tuning on this point because the car is a savage gas guzzler, but that isnt my main issue right now.

My current issue that I cannot seem to figure out is when shifting quickly at partial throttle, when I let go of the clutch and reapply throttle the car seems to bog and hesitate for a brief moment and then accelerates again. You can see the couple of shifts (1st thru 3r) at the 100.300 second mark. the PW seems to spike after the shift, along with EAE and MAPdot. I would appreciate any suggestions and criticisms about my tune.

1996 Miata 1.8 running a Brain built ms3pro and some other turbo goodies.

Thanks
Attached Files
File Type: msq
TESToverrunLEAN.msq (277.1 KB, 9 views)
File Type: msl
2019-04-13_14.28.49.msl (1.42 MB, 8 views)
miatatam8 is offline  
Old 04-14-2019, 05:47 PM
  #2  
Junior Member
 
Join Date: Nov 2016
Location: Columbia, MO
Posts: 144
Total Cats: 12
Default

I'm not great at reading datalogs yet, but it seems like your ve table is what's causing it. The other settings absolutely don't help.

I cant comment on EAE as i dont use it personally. Haven't done enough research on it. As far as AE, I personally use tps only. I've read others saying it was more effective and I've had good results. It seems your afr's swing from 18 to 12 at like 2300 rpm. I'd say stop the EAE, go to tps only AE and that eliminates both of your comments on what you observed. Smooth that VE table and scale it to your general boost, unless you are hitting 20psi
thebigtuna is offline  
Old 04-14-2019, 06:05 PM
  #3  
Newb
Thread Starter
 
Join Date: Sep 2018
Posts: 19
Total Cats: -1
Default

Originally Posted by thebigtuna View Post
I'm not great at reading datalogs yet, but it seems like your ve table is what's causing it. The other settings absolutely don't help.

I cant comment on EAE as i dont use it personally. Haven't done enough research on it. As far as AE, I personally use tps only. I've read others saying it was more effective and I've had good results. It seems your afr's swing from 18 to 12 at like 2300 rpm. I'd say stop the EAE, go to tps only AE and that eliminates both of your comments on what you observed. Smooth that VE table and scale it to your general boost, unless you are hitting 20psi
The big swing of AFR you mentioned from 12 to 18 is when I let go of the gas and the engine brakes, its in overrun. During the shifts starting at around (where its a clear example of my issue) 100.300 second mark the AFR swings from 15.5 to 13.
I am only running about 8psi currently.

I will try disabling the EAE and go to TPS only AE and see if anythings comes from it. Although ms3pro tunerstudio only offers me the choice of Accel - Pump AE or Time - Based AE

Thanks
miatatam8 is offline  
Old 04-14-2019, 06:16 PM
  #4  
Junior Member
 
Join Date: Nov 2016
Location: Columbia, MO
Posts: 144
Total Cats: 12
Default

Ah couldn't tell if you were saying overrun was still on or you switched it off to test. In that case my guess os the MAP DE, it was active when it swung from 17-11. Seems like the AE or VE leaned it out and then the MAP DE in the second spike was also activated and then the afr's tanked. The huge swings are giving you the roughness. It almost seems like your AE settings and DE settings are fighting each other.

Take all of this with a grain of salt, I'm still a nub

Good luck!
thebigtuna is offline  
Old 04-14-2019, 06:22 PM
  #5  
Newb
Thread Starter
 
Join Date: Sep 2018
Posts: 19
Total Cats: -1
Default

This is where I think my stumble/bog issue lies, in those saw tooth patterns in the PW right after the shift and as Im getting back on the throttle. I am not sure what setting is causing those, for all I know it could be a misfire or some of my settings are funky.


miatatam8 is offline  
Old 04-14-2019, 06:39 PM
  #6  
Junior Member
 
Join Date: Nov 2016
Location: Columbia, MO
Posts: 144
Total Cats: 12
Default

Yeah, stop using map and EAE. That's my guess, if it fixes it then you know what to tune more. Hopefully someone more experienced will chime in to help you.
thebigtuna is offline  
Old 04-14-2019, 06:53 PM
  #7  
Tweaking Enginerd
iTrader: (2)
 
Join Date: Mar 2013
Location: Boulder, CO
Posts: 983
Total Cats: 119
Default

You ~should~ turn EAE off because it is not well tuned. EAE should pretty much be the last thing you tune.

EAE >> AE, they are on completely different levels in terms of sophistication. I personally use both, with both MAP and TPSdot based accel pump AE.
Ted75zcar is offline  
Old 04-14-2019, 07:10 PM
  #8  
Junior Member
 
Join Date: Nov 2016
Location: Columbia, MO
Posts: 144
Total Cats: 12
Default

Hmm if EAE actually is that much better I'll have to look into tuning it myself. I've only ever done tps AE and it's worked perfectly fine. Can always improve though!
thebigtuna is offline  
Old 04-14-2019, 07:16 PM
  #9  
Tweaking Enginerd
iTrader: (2)
 
Join Date: Mar 2013
Location: Boulder, CO
Posts: 983
Total Cats: 119
Default

Originally Posted by thebigtuna View Post
Hmm if EAE actually is that much better I'll have to look into tuning it myself. I've only ever done tps AE and it's worked perfectly fine. Can always improve though!
If it ain't broke...
Ted75zcar is offline  
Old 04-14-2019, 07:19 PM
  #10  
Junior Member
 
Join Date: Nov 2016
Location: Columbia, MO
Posts: 144
Total Cats: 12
Default

Originally Posted by Ted75zcar View Post
If it ain't broke...
Lol true...

OP if you want to try tuning EAE, this post took me about 10 seconds to find and hustler also describes your issues in it.

https://www.miataturbo.net/megasquir...-tuning-69466/
thebigtuna is offline  
Old 04-14-2019, 07:43 PM
  #11  
Newb
Thread Starter
 
Join Date: Sep 2018
Posts: 19
Total Cats: -1
Default

I've read through that, it doesnt exactly apply to my situation. My car is pretty stable at low throttle and not much jerky. My issue lies during semi hard acceleration and quick shifting through gears. It bogs a bit as I get back on throttle after a shift, and after a second it goes back to normal acceleration. If I let the rpm drop more before shifting theres no bogging.

Originally Posted by thebigtuna View Post
Lol true...

OP if you want to try tuning EAE, this post took me about 10 seconds to find and hustler also describes your issues in it.

https://www.miataturbo.net/megasquir...-tuning-69466/
miatatam8 is offline  
Old 04-14-2019, 07:48 PM
  #12  
Junior Member
 
Join Date: Nov 2016
Location: Columbia, MO
Posts: 144
Total Cats: 12
Default

Ah **** I'm dumb, don't know what I was thinking of. Must have been another thread on my mind, mb.
thebigtuna is offline  
Old 04-14-2019, 09:42 PM
  #13  
Newb
Thread Starter
 
Join Date: Sep 2018
Posts: 19
Total Cats: -1
Default

I seem to have resolved my issue.

I used the AE settings Brain posted in this thread:

https://www.miataturbo.net/megasquir...e-86043/page2/

And now my pulls through gears do not have the saw tooth PW happening, and it pulls much smoother and a bigger joy to drive. It seems I still need to tune the Fuel VE but its getting better.
See below:


miatatam8 is offline  
Old 04-14-2019, 09:49 PM
  #14  
Junior Member
 
Join Date: Nov 2016
Location: Columbia, MO
Posts: 144
Total Cats: 12
Default

Cool thread, I'll save that for later! Nice job, dude!
thebigtuna is offline  
Old 04-14-2019, 09:58 PM
  #15  
Newb
Thread Starter
 
Join Date: Sep 2018
Posts: 19
Total Cats: -1
Default

Originally Posted by thebigtuna View Post
Cool thread, I'll save that for later! Nice job, dude!
Just saw your sig, I too have a montego blue 96... insert obligatory pic:


miatatam8 is offline  
Old 04-14-2019, 10:10 PM
  #16  
Junior Member
 
Join Date: Nov 2016
Location: Columbia, MO
Posts: 144
Total Cats: 12
Default

Hell yeah, great looking car!


Only picture I have is from about 2 years ago
thebigtuna is offline  
Old 04-15-2019, 12:04 AM
  #17  
Senior Member
 
Join Date: May 2007
Location: Atlanta
Posts: 657
Total Cats: 104
Default

Tuning AE makes a world of difference in driveability. 10 minutes after this talk there were about 5 of us in the parking lot doing small revs.

gooflophaze is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
estephens13
DIY Turbo Discussion
8
03-06-2018 03:37 PM
hedtrip
General Miata Chat
14
11-15-2017 09:19 PM
miatauser123
Suspension, Brakes, Drivetrain
21
07-19-2011 09:40 AM
Jus_tin
General Miata Chat
31
08-23-2010 02:46 PM
jayc72
Adaptronic
8
05-17-2010 05:19 PM


Thread Tools
Search this Thread
Quick Reply: ms3pro stumbles/bogs after shifting...


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.