MS3x Issue - Programming SPK & INJ Outputs - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 02-22-2014, 09:23 AM   #1
Newb
Thread Starter
 
Join Date: Mar 2009
Posts: 4
Total Cats: 0
Default MS3x Issue - Programming SPK & INJ Outputs

I've built an MS3 for my 01 following Frank's guide and it seemed like everything was working perfectly when bench testing with a JimStim + JimStimX until I tried to configure additional outputs. I started out by loading the 99 MSPNP base tune.

The following MS3x outputs work as expected with the base tune:
  • Tacho
  • SPK A
  • SPK B
  • INJ A
  • INJ B
  • INJ C
  • INJ D
... so basically I get a little diso light show which is pretty freaking awesome (especially when seeing it work for the first time).

But ONLY the following MS3x LEDs respond to settings in the "Programmable On/Off Outputs" dialog box:
  • IDLE
  • SPK G
  • SPK H
All other LEDs simply do not light up.

To test the outputs I am using the following settings:


Interestingly, for any of the outputs which don't seem to be working, if I disable the output in the programmable output dialog and set it as the output pin in the "Fan Control" dialog and dial up the coolant temp on the JimStim, the LED does light up as expected. This indicates to me that my MS3x outputs are functioning correctly and there are no problems with my JimStimX.

What am I missing here? Why can't I set ALL spare spark and ignition outputs to light up in a "rpm > 3000" test condition? Have I misconfigured something or is this a bug with MS3x/TunerStudio?
Attached Thumbnails
MS3x Issue - Programming SPK & INJ Outputs-jfarocy.png  
jhtong is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 02:11 PM
Bizarre connection issue? nick470 MEGAsquirt 1 09-30-2015 11:32 PM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:24 PM.