MSDroid "Reading Signature" - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 03-10-2015, 10:13 PM   #1
Elite Member
Thread Starter
iTrader: (17)
 
Join Date: Aug 2007
Location: Fort Myers, FL
Posts: 2,791
Total Cats: 130
Default MSDroid "Reading Signature"

I've been using MSDroid on my Samsung S3 for a few months now. The app worked great, until last week when I installed an update. Since then when I connect to my phone the app will say, "Reading Signature" and it just flashes indefinitely and never connects.

I've tried uninstalling/reinstalling the app and I've tried loading a new project. I downloaded the app on my wife's phone and it did the same thing there as well. I looked through the app settings and project settings and nothing jumped out at me. Any one else having issues with MSDroid? Any suggestions on things to check or try? I got spoiled being able to tune from my phone, I hate to go back to hauling around my old junk laptop with a dead battery.
pdexta is offline   Reply With Quote
Old 03-10-2015, 10:20 PM   #2
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

I've been getting a bunch of issues with it too. Sometimes disconnecting then reconnecting work sometimes it doesn't. I've had better luck using a USB cable to my phone.
aidandj is offline   Reply With Quote
Old 03-10-2015, 10:52 PM   #3
Elite Member
Thread Starter
iTrader: (17)
 
Join Date: Aug 2007
Location: Fort Myers, FL
Posts: 2,791
Total Cats: 130
Default

I just hooked up the laptop and tunerstudio isn't connecting either. I guess the update was just a coincidence. Hopefully it's just the serial cable.
pdexta is offline   Reply With Quote
Old 03-10-2015, 11:11 PM   #4
Sadfab Union President
iTrader: (3)
 
Join Date: May 2014
Location: Kansas
Posts: 2,690
Total Cats: 113
Default

Have you found the signature files on your phone yet? I had to delete those after a bad update. IIRC it went ahead and downloaded the right ones for me after I cleared the folder. I might be mistaken though, and that may have been shadowdash.

MSdroid is about ten times as effective at staying connected for me than shadowdash. Ten times a 1-100 chance of it staying connected at any decent refresh rate is still not very high, but it does work. I've tried several cheap bluetooth-rs232 adapters and they all are about the same. A pox on shodowdash, worst waste of ten bucks yet. I tried reinstalling it, and on a tablet, and now I can't download it again because I only get three tries apparently. Whoever manages the piece of crap doesn't reply to messages, either.

Wish my phone had native USB-OTG support. Guess the only thing it lacks is 5V on the port, not really the end of the world. Is it really that much better than bluetooth, I assume it manages a lot faster bandwidth?
deezums is offline   Reply With Quote
Old 03-10-2015, 11:13 PM   #5
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

For me its the stability if the connection. I have had Bluetooth issues before but with OTG is instantaneous and solid connection all the time.

What phone? Might be worth just giving it a shot, some phones just don't advertise it.
aidandj is offline   Reply With Quote
Old 03-10-2015, 11:16 PM   #6
Sadfab Union President
iTrader: (3)
 
Join Date: May 2014
Location: Kansas
Posts: 2,690
Total Cats: 113
Default

Nexus 4, I know it's possible I may just need to borrow some 5v from my megasquirt. I'm seriously considering it, I'd log a lot more if I didn't have to risk getting my laptop stolen from my car.
deezums is offline   Reply With Quote
Old 03-10-2015, 11:18 PM   #7
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

What do you need 5v for? My nexus 7 works just fine, I can test my friends nexus 4 tomorrow maybe.
aidandj is offline   Reply With Quote
Old 03-10-2015, 11:21 PM   #8
Sadfab Union President
iTrader: (3)
 
Join Date: May 2014
Location: Kansas
Posts: 2,690
Total Cats: 113
Default

To power the usb/rs232 adapter, unless I'm mistaken? I have no Usb, ms2 :(

May need to finally root my phone too, maybe.

Android Advanced: USB OTG on the Nexus 4 | Android Central
deezums is offline   Reply With Quote
Old 03-10-2015, 11:25 PM   #9
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

Hmmm, i would think its powered by the megasquirt. Rs-232 has power pins. Would be pretty easy to break it out.

When I get home I'll test out OTG with my MSPNP.
aidandj is offline   Reply With Quote
Old 03-10-2015, 11:33 PM   #10
Sadfab Union President
iTrader: (3)
 
Join Date: May 2014
Location: Kansas
Posts: 2,690
Total Cats: 113
Default

I'm not sure if the adapter needs voltage on the USB side of the adapter or not, I've already brought 5V out on rs232 for powering the bluetooth adapter, so if it does it won't really be too terribly hard to get it on the USB side of the adapter.

Thanks for the testing!
deezums is offline   Reply With Quote
Old 03-10-2015, 11:40 PM   #11
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

Just tested. Detects a USB device and opens msdroid. But won't connect due to not finding an ecu definition on the server. I don't know if this is an error with my megasquirt or with the connection. Definitely worth testing though. OTG cables are like 2 bucks.
aidandj is offline   Reply With Quote
Old 03-10-2015, 11:48 PM   #12
Sadfab Union President
iTrader: (3)
 
Join Date: May 2014
Location: Kansas
Posts: 2,690
Total Cats: 113
Default

Ahhh, I remember that. I had to download 3.3.2 or whatever .ini files and put them in a directory on my phone. You should have a .ini in a tunerstudio directory somewhere in my documents, with the right .ini file.

Thanks man, I'm gonna order a cable now. I think I still need to flash a custom kernel to my phone though. I'll be on the xda forums for a while
deezums is offline   Reply With Quote
Old 03-10-2015, 11:51 PM   #13
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

God that place has gone downhill. I started there as a windows mobile user before Android was a thing. A lot smaller nicer community back then. Once I got a moto-x and xposed was released I haven't really gone back.
aidandj is offline   Reply With Quote
Old 04-19-2016, 11:26 PM   #14
Newb
 
Join Date: Jul 2013
Posts: 21
Total Cats: -1
Default

Quote:
Originally Posted by pdexta View Post
I just hooked up the laptop and tunerstudio isn't connecting either. I guess the update was just a coincidence. Hopefully it's just the serial cable.
Ever figure out what the problem was? I'm having the same issue
Ruggedcat is offline   Reply With Quote
Old 04-20-2016, 10:02 AM   #15
Elite Member
Thread Starter
iTrader: (17)
 
Join Date: Aug 2007
Location: Fort Myers, FL
Posts: 2,791
Total Cats: 130
Default

Yes, I did get it resolved. I ended up making a new thread since MSDroid wasn't the issue. Here's the link:

https://www.miataturbo.net/megasquir...connect-83436/

My issue ended up being with the firmware. Once I reloaded it everything worked fine. If you're issue is with MSDroid, try to connect with Tunerstudio and see what happens. I've had a few times that MSDroid wouldn't connect and when I connect with Tunerstudio I get an error message that I points me in the right direction.
pdexta is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:16 AM.