mspnp + stock tune popping at idle during track day - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 05-01-2009, 11:43 PM   #1
Senior Member
Thread Starter
iTrader: (22)
 
Join Date: Oct 2007
Location: bay area, ca
Posts: 551
Total Cats: 19
Default mspnp + stock tune popping at idle during track day

I installed a mspnp on my 97 a week ago. Ran it on a dyno on my stock car and got AFR readings and all looked good with the map that came with the mspnp. After about 3 sessions at Thunder Hill beating the crap out of the car with no problems I came back and heard random popping from the exhaust every 1-2 seconds. I'm stupid and didn't even try logging it before swapping in the stock ecu (didn't want to go home on a trailer), but I did notice the MAP line was slightly pinched in the engine bay. The stock ecu started, idled, and ran perfect after that. This is probably a waste of time to figure out without a log, but what could it be?

- pinched MAP line? I kind of doubt this since the car was running fine with the mspnp outside of the idle problem.
- changes due to higher than usual coolant temps and the tune needs to be adjusted?
orion4096 is offline   Reply With Quote
Old 05-02-2009, 06:43 AM   #2
Elite AbsurdFlow Member
 
Laur3ns's Avatar
 
Join Date: Mar 2008
Location: Enschede, NL
Posts: 2,058
Total Cats: 11
Default

I get this too with EGO turned on. With it off and idling richer it is perfectly stable. I dont think MSPNP will idle as good as OEM actually (without spending hilarious amounts of time to a rev range you don't want to be in at a track day).
Laur3ns is offline   Reply With Quote
Old 05-02-2009, 07:10 AM   #3
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,355
Total Cats: 1,322
Default

I get the same thing. The engine bay heatsoaks, which heatsoaks the IAT, which causes the car to pull fuel and idle lean, which then causes it to misfire. No harm in it, it's just a bit annoying.
Savington is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Brakes ???? tomiboy Race Prep 124 11-02-2015 04:55 PM
Road Atlanta: November 21-22, 2015 Feffman Local Meets, Events and Tech Days 1 10-07-2015 09:06 AM
NT01 vs RA1 in the wet... wannafbody Wheels and Tires 5 09-25-2015 09:04 PM
MS3 Basic Connection Issues EErockMiata MEGAsquirt 6 09-24-2015 10:49 AM
WTB parts for HPDE car Voltwings WTB 5 09-11-2015 09:23 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:02 PM.