mspnp9697 knock after install? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 05-26-2008, 10:47 PM   #1
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Mar 2008
Location: Largo, FL
Posts: 88
Total Cats: 0
Default mspnp9697 knock after install?

It doesn't sound like the engine its self is knocking, because I cannot hear the noise from anywhere besides the drivers seat. I haven't been able to really get down there and take a look under the steering wheel, but the weird thing is that it was making no noise at all before the install. The only thing I can think of is maybe something is banging on the inside of the firewall. I've been racking my brain for hours now to try to remember if I installed anything on that side, but to the best of my knowledge all the wiring and the hoses went down the passenger side. With that being said, I just can't for the life of me figure out where this stupid noise is coming from. It sounds a bit like a very mild rod knock, but I know thats impossible since I can't hear it from anywhere except the drivers seat. I ran the car in an autocross, drove it home, and it ran fine. I parked it, 2 weeks went by and I installed the mspnp. A week later, I get it set up, a good base tune, and its been knocking minimally the entire time. It does it the most in low RPMS, such as 1300rpm and lower.

EDIT: It retrospect now that I went out to the car again, it doesn't really sound like knocking, just like its running kind of rough. My AFR is around 14.4 average idling, and maybe I need to richen it up a bit on the idle to correct the roughness a bit. Does anyone out there with a blower have a preference on AFR for idle?

Last edited by Agent; 05-26-2008 at 11:00 PM.
Agent is offline   Reply With Quote
Old 05-26-2008, 11:03 PM   #2
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Richen it up to more like 13.8:1 and see what happens. Your IAC might be noisy if you're hearing this noise at idle.
cjernigan is offline   Reply With Quote
Old 05-26-2008, 11:06 PM   #3
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Mar 2008
Location: Largo, FL
Posts: 88
Total Cats: 0
Default

Awesome, I'll try that tomorrow when I get home.

When I do that in the VE table, how much is each number? I think its about 30ish now, do I need to go down 1 number at a time? And when I do this, I need to change the numbers around it to sort of mesh also, correct?

1 more stupid question probably, on the left side, KPA goes up, and on the bottom, RPM goes to the right. Since the most boost this car will see is around 10-12psi, should I change the KPA numbers in the grid on the left to reflect 140ish as the top most range instead of the 280 or so thats in there now? I hate to add questions, but the map is calling for 17 degrees of timing at idle, is that extreme?
Agent is offline   Reply With Quote
Old 05-27-2008, 12:42 AM   #4
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

something banging on the firewall sounds nothing like detonation...lol.
hustler is offline   Reply With Quote
Old 05-27-2008, 12:48 AM   #5
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,370
Total Cats: 1,332
Default

Knock only occurs under very high load. Loading up the motor hard enough to hear knock under 1300rpm is HORRIBLE for it.
Savington is offline   Reply With Quote
Old 05-27-2008, 01:09 AM   #6
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Quote:
Originally Posted by Agent View Post
Awesome, I'll try that tomorrow when I get home.

When I do that in the VE table, how much is each number? I think its about 30ish now, do I need to go down 1 number at a time? And when I do this, I need to change the numbers around it to sort of mesh also, correct?

1 more stupid question probably, on the left side, KPA goes up, and on the bottom, RPM goes to the right. Since the most boost this car will see is around 10-12psi, should I change the KPA numbers in the grid on the left to reflect 140ish as the top most range instead of the 280 or so thats in there now? I hate to add questions, but the map is calling for 17 degrees of timing at idle, is that extreme?
You add fuel not subtract it to richen it so add fuel to that value of 30 instead of subtracting it.

17* at idle is normal, thats what i run. You should leave the table alone scale wise if you're having trouble tuning the car, you will just have more issues if you mix things up.
cjernigan is offline   Reply With Quote
Old 05-27-2008, 08:21 PM   #7
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Mar 2008
Location: Largo, FL
Posts: 88
Total Cats: 0
Default

Well, its not a knock. The car runs actually pretty good, its just going to take me getting a new laptop battery to drive around and tune at the same time...

I do have a fan thing at the bottom of my Megatune window that says fan/s on and it flashes on and off (green and white). Anyone know what would cause it to do something like that?

I need to figure out whats causing the vibration at low RPM, and its driving me crazy because it doesn't seem to effect the engine, yet it didn't make this noise before I installed the MSPNP...
Agent is offline   Reply With Quote
Old 05-30-2008, 12:08 AM   #8
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Mar 2008
Location: Largo, FL
Posts: 88
Total Cats: 0
Default

any ideas about the flashing thing at the bottom? I think it is Fan W/Inj and it flashes green on, then white off...
Agent is offline   Reply With Quote
Old 05-31-2008, 02:10 AM   #9
Elite Member
iTrader: (5)
 
Join Date: Oct 2007
Location: Canton, Ga
Posts: 1,707
Total Cats: 19
Default

Quote:
Originally Posted by Agent View Post
any ideas about the flashing thing at the bottom? I think it is Fan W/Inj and it flashes green on, then white off...
thats for the PWM output that drives the tachometer. ignore it.
Stealth97 is offline   Reply With Quote
Old 05-31-2008, 09:38 AM   #10
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Mar 2008
Location: Largo, FL
Posts: 88
Total Cats: 0
Default

This is such a pain! I can't wait till I get good so I'll be able to change things on the fly.

Anyone have some input for settings to speed up the MSPNP's adaptation to the A/C turning on? Sometimes It will be ok, and sometimes not. I can't figure the damn thing out.
Agent is offline   Reply With Quote
Old 05-31-2008, 11:30 AM   #11
Elite Member
iTrader: (5)
 
Join Date: Oct 2007
Location: Canton, Ga
Posts: 1,707
Total Cats: 19
Default

There was some good info on the A/C stalling that Joe posted recently.
Stealth97 is offline   Reply With Quote
Old 05-31-2008, 12:43 PM   #12
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Mar 2008
Location: Largo, FL
Posts: 88
Total Cats: 0
Default

Sorry to be an idiot, but who is Joe? Do you know where he posted it at?
Agent is offline   Reply With Quote
Old 05-31-2008, 12:51 PM   #13
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Mar 2008
Location: Largo, FL
Posts: 88
Total Cats: 0
Default

Never mind, just saw the post. When I finish the oil change I'll give it a shot.
Agent is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:49 PM.