no fuel, pulse width 0 while cranking - Miata Turbo Forum - Boost cars, acquire cats.

MEGAsquirt A place to collectively sort out this megasquirt gizmo
Sponsored by:
Sponsored by:

no fuel, pulse width 0 while cranking

Old 04-11-2010, 03:30 PM
  #1  
N3v
Junior Member
Thread Starter
 
Join Date: May 2008
Location: Nashville/Knoxville, TN
Posts: 314
Total Cats: 1
Default no fuel, pulse width 0 while cranking

ok heres the deal:
-dsm 450cc injectors on honda resistor box
-95 1.8L with 99 head
-ms1 v3.0
- toyota cops, checked spark on all cylinders, sparks great

attached is ths msq. tested the fuel injectors with a spare injector plugged in and held to my ear. it clicks once when you flick the car to 'on' then it seems like it clicks a few times on cranking and then stops clicking. megatune shows a pulse width of 5.0ms when you turn the key to the on position, then drops to 0 and does not do anything when cranked. i checked all the connections in the engine bay, and this car did run badly for a little while, but now won't start. does this indicate a ground issue?
Attached Files
File Type: msq
chris turbo miata.msq (34.5 KB, 87 views)
N3v is offline  
Old 04-11-2010, 06:30 PM
  #2  
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,651
Total Cats: 111
Default

If you have spark but no fuel when cranking, then you very likely have your flood clear settings set too aggressively and/or have not calibrated your TPS correctly.
__________________
DIYAutoTune.com Tech Support
10AE-T|BEGi S4|MSPNP-Pro EMS|Enthuza Duals|6UL|Etc
Track Rat|2001|VVT|MS3-Pro EMS|Enthuza|Exocet in Progress

Originally Posted by concealer404 View Post
Buy an MSPNP Pro, you'll feel better.
Ben is offline  
Old 04-11-2010, 11:58 PM
  #3  
N3v
Junior Member
Thread Starter
 
Join Date: May 2008
Location: Nashville/Knoxville, TN
Posts: 314
Total Cats: 1
Default

exactly right, ben. I fixed it earlier today; after we unplugged the tps it started right up, and that was very confusing at first. I've never ran into that issue before!

thanks!
N3v is offline  
Old 04-19-2010, 05:21 PM
  #4  
N3v
Junior Member
Thread Starter
 
Join Date: May 2008
Location: Nashville/Knoxville, TN
Posts: 314
Total Cats: 1
Default

now i've got this problem.
Name:  log.jpg
Views: 35
Size:  60.1 KB
happens most of the time, sometimes it doesn't though.

cas noise? calling joe perez. :P
N3v is offline  
Old 04-19-2010, 07:36 PM
  #5  
N3v
Junior Member
Thread Starter
 
Join Date: May 2008
Location: Nashville/Knoxville, TN
Posts: 314
Total Cats: 1
Default

I thought it was a noisy cas signal so I re-wired the signal wires in their own separate shielded wire, away from the other harness wires. confusingly, this helped the rpm signal only slightly. At first, when you'd go over about 50% throttle the signal would start to act up. Now, it's more like 75%. However, I also noticed that all the values on the log would occasionally peak, seemingly unrelated to the cas issue:
Name:  graph-1.jpg
Views: 35
Size:  45.9 KB
as you can see, all the values go nutty, then the unit resets once. Looking back throgh previous logs, I noticed these where I hadn't before becase I was only looking at the cooky rpm signal. What can cause this? Now that I rewired the cas, I'm beginning to think it's bad grounds. But why would the cas act up by itself, then all the sensors act up, then the megasquirt reset? The car runs great and starts every time, jst takes a **** when you gank it.

And randomly, one or two datalogging runs, the cas did not mess up (or messed up about 1/10th as much) and we were able to floor it, hit max boost, then redline, several times with no incident. We had actually thought that somehow we had unwittingly solved the problem. This datalog is similar to the post-cas-wiring log, it does have a couple of rpm spikes here and there, but they werent that noticable while driving the car.

Enclosed are two more logs and the msq that I have modified since the first post.

btw, we plugged this ms into my car and I loaded my msq on it, and it ran 100% fine. I never did a datalog though.
Attached Files
File Type: msq
chris turbo miata.msq (34.4 KB, 93 views)
File Type: xls
new cas wiring.xls (566.0 KB, 63 views)
File Type: xls
before cas rewire.xls (437.6 KB, 59 views)
N3v is offline  
Old 04-20-2010, 08:03 PM
  #6  
N3v
Junior Member
Thread Starter
 
Join Date: May 2008
Location: Nashville/Knoxville, TN
Posts: 314
Total Cats: 1
Default

bump
N3v is offline  
Old 04-20-2010, 08:16 PM
  #7  
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,651
Total Cats: 111
Default

Wiring related some how. Probably bad grounds. Misfiring can do the same thing sometimes, as can injector flyback--those things tend to happen more under load though.
__________________
DIYAutoTune.com Tech Support
10AE-T|BEGi S4|MSPNP-Pro EMS|Enthuza Duals|6UL|Etc
Track Rat|2001|VVT|MS3-Pro EMS|Enthuza|Exocet in Progress

Originally Posted by concealer404 View Post
Buy an MSPNP Pro, you'll feel better.
Ben is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Full_Tilt_Boogie
Build Threads
63
08-09-2018 07:54 PM
Frank_and_Beans
Supercharger Discussion
13
09-12-2016 09:17 PM
jpreston
Miata parts for sale/trade
2
05-17-2016 01:51 AM
lsc224
Miata parts for sale/trade
2
10-01-2015 10:17 AM
Greasyman
General Miata Chat
2
09-28-2015 11:44 AM


Thread Tools
Search this Thread
Quick Reply: no fuel, pulse width 0 while cranking


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.