Odd NB Idle Valve Behavior - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 09-15-2018, 06:58 PM   #1  
Newb
Thread Starter
 
Join Date: Feb 2018
Posts: 7
Total Cats: 0
Default Odd NB Idle Valve Behavior

Hello everyone,

I have a member built MS3X for my 2004 Miata running Firmware 1.5.1 and TunerStudio v3.0.28. The original form of the issue has the idle valve fully open, at startup, when the car almost dies (so it's like trying to overcompensate), and when given any amount of gas pedal. It will soon then quickly close the valve and depending on my settings start open again. The data logs will make what I'm describing much more apparent. Something to note: when the MS tells the valve to be 100% the rpms don't rise as quickly as expected. I can avoid this whole issue by forcing the idle valve at a certain percentage in open loop. This is only a temporary solution. I will attach data logs of the issue with stock injectors and my current ID1050x injectors as well as a tune file.

What have I done already? Calibrated Idle Valve, Idle control settings: Frequency and valve modes, various Closed Loop settings including CL sensitivity slider (increase made it worse, decrease had little change), VVT on/off, and possibly some other stuff I don't remember.

Attachment Notes: Hopefully the compressed ZIP will work okay. That is a full warmup with stock injectors. Gas pedal is never touched. On the EV14 log, I have to induce the issue towards the end by touching the throttle. Everything before that I was tuning fuel to get somewhat of an idle.

I'm hoping there is an easy solution to this that I am just overlooking. Thanks for reading and if you have any input I would be super thankful. I'm still pretty new at this and can't find any similar issues online.
Saber008 is offline   Reply With Quote
Old 09-18-2018, 10:00 PM   #2  
Newb
Thread Starter
 
Join Date: Feb 2018
Posts: 7
Total Cats: 0
Default

Issue Solved. Simple fix for anyone that runs into a similar issue. Fix/tune Idle Cranking Duty/Steps and Closed-Loop Idle Initial Values. These had to be lowered.
Saber008 is offline   Reply With Quote
Old 09-20-2018, 01:19 PM   #3  
Junior Member
 
Join Date: Feb 2017
Location: Dallas, Texas
Posts: 87
Total Cats: 2
Default

Quote:
Originally Posted by Saber008 View Post
Issue Solved. Simple fix for anyone that runs into a similar issue. Fix/tune Idle Cranking Duty/Steps and Closed-Loop Idle Initial Values. These had to be lowered.
Think you might be able to post your new tune? I'd like to compare my idle settings.
ungluedflyer is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Odd VEAL behavior, consistently wants to go rich at low load. TorqueZombie MEGAsquirt 2 06-04-2017 11:51 AM
Strange IAC Valve/PWM Idle duty behavior jko MEGAsquirt 8 11-16-2016 06:11 PM
The Odd Behavior Thread pusha Insert BS here 42 08-18-2012 12:28 PM
Odd behavior when I adjusted boost Der_Idiot General Miata Chat 8 07-18-2010 11:44 PM
ms-pnp weird inj behavior dc2696 MEGAsquirt 2 08-12-2008 02:25 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:08 AM.




We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.