People with kingof1337 setup - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 01-29-2008, 08:33 PM   #1
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default People with kingof1337 setup

I tried searching around but I couldn't get his name to work. Anyway,

I'm almost ready to put it in the car and I'm looking for someone who has already done it. I just have a few questions and would like to be able to PM someone with them. I know they are answered on the forum, I just don't understand them.

Thanks.
miataspeed1point6 is offline   Reply With Quote
Old 01-29-2008, 10:06 PM   #2
Senior Member
iTrader: (3)
 
Join Date: Apr 2006
Location: Northern Michigan
Posts: 898
Total Cats: 0
Default

I installed it like he said, but I couldn't connect to it and he disappeared so I gave up.

https://www.miataturbo.net/forum/sho...ght=kingof1337

Basically just AIT and fuel pump wires (I just wired it to the diagnostic connector).
rotaryjunky is offline   Reply With Quote
Old 01-29-2008, 10:09 PM   #3
Senior Member
iTrader: (3)
 
Join Date: Apr 2006
Location: Northern Michigan
Posts: 898
Total Cats: 0
Default

More of my ignorance, to think I know even less now!
https://www.miataturbo.net/forum/sho...ght=kingof1337
rotaryjunky is offline   Reply With Quote
Old 01-29-2008, 10:16 PM   #4
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

What do you want out of your megasquirt. You're better off following the link my in sig on how to build your own. If you want to have switchable connections that is easy as well with DPDT switches. It would actually be cleaner, cheaper, and more productive to install your MS. Make sure it reads everything correctly, then go to fuel, then to spark.
cjernigan is offline   Reply With Quote
Old 01-29-2008, 10:45 PM   #5
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

Well I already have the kingof1337 setup. I'm just looking for someone that I can work with to answer my stupid questions. I have the wiring diagrams on my other computer and I have compared them and I think I get it. I just need confirmation.

EDIT: In brains FAQ in your sig, the only thing I don't understand is the fuel pump. I just need to run the wire to it, I don't actually cut it?
miataspeed1point6 is offline   Reply With Quote
Old 01-29-2008, 11:01 PM   #6
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

You cut the stock wire and connect the MS wire. I don't see why you don't just let the stock ecu turn on the fuel pump though.
cjernigan is offline   Reply With Quote
Old 01-29-2008, 11:18 PM   #7
Elite Member
iTrader: (4)
 
Join Date: Sep 2006
Location: Charlotte, NC
Posts: 3,051
Total Cats: 7
Default

I have a kingofl337 set-up however, I've never been able to get it to work. The megasquirt is not receiving tach input for some reason.

Adam (kingofl337) hasn't been very helpful and is hard to get a hold of. The best way to contact him is to call him at work. I don't have that number off the top of my head though.
Efini~FC3S is offline   Reply With Quote
Old 01-30-2008, 12:39 AM   #8
Senior Member
iTrader: (3)
 
Join Date: Apr 2006
Location: Northern Michigan
Posts: 898
Total Cats: 0
Default

I don't know if I understand correctly, but you need to run a wire to the fuel pump so that it doesn't turn off. You can splice it into the lt green fuel pump wire on the diagnostic port inside the engine compartment.

Or "Remove the kickpanel under the steering column and find the circuit opening relay. It has 5 wires coming out of it; blue/black, white/red, violet, black, and light green. Connect MS pin 37 to the light green wire and you're done. This is the same wire as the lt green wire at the MAF and diagnostic port, check for continuity if you're unsure."
rotaryjunky is offline   Reply With Quote
Old 01-30-2008, 12:48 AM   #9
Senior Member
iTrader: (2)
 
Join Date: Nov 2007
Location: orlando, FL
Posts: 558
Total Cats: 0
Default

guys... if you PM brain, and thank him a lot, he will be glad to help you... when i recieved my MS.... no offense to you kingofl337....

i couldn't get my MS to work for ****, it wouldn't light up or anything.... so i sent it out to brain for re-wiring and he made it work like a charm
XxGoKoUxX is offline   Reply With Quote
Old 01-30-2008, 12:51 AM   #10
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

Quote:
Originally Posted by cjernigan View Post
You cut the stock wire and connect the MS wire. I don't see why you don't just let the stock ecu turn on the fuel pump though.
It sounds like you know something I don't. How would you connect it? I'm all for making this easy as possible, thats why I want parallel.

The thing is I am so confused about this because no one seems to have the same setup as me. I can't look at pictures and copy because everything I have seems to be different. Is there a set of instructions for this thing online somewhere?

Honestly I'm thinking of selling this and buying one from scott or a PNP just so I can follow along with everyone else here.
miataspeed1point6 is offline   Reply With Quote
Old 01-30-2008, 12:59 AM   #11
Senior Member
iTrader: (3)
 
Join Date: Apr 2006
Location: Northern Michigan
Posts: 898
Total Cats: 0
Default

Name:  DSC00877.jpg
Views: 0
Size:  171.4 KB
rotaryjunky is offline   Reply With Quote
Old 01-30-2008, 01:00 AM   #12
Senior Member
iTrader: (3)
 
Join Date: Apr 2006
Location: Northern Michigan
Posts: 898
Total Cats: 0
Default

Is it connected to the ecu like this with switches or is it connected with a harness?
rotaryjunky is offline   Reply With Quote
Old 01-30-2008, 02:24 AM   #13
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

It has the 2 switches like that one. Would you happen to have a picture or something showing which wires are IAT, FP etc? Thats what I need to compare.

But it sounds like cjernigan might have a better way to wire it up than what I put together.
miataspeed1point6 is offline   Reply With Quote
Old 01-30-2008, 02:38 AM   #14
Senior Member
iTrader: (2)
 
Join Date: Nov 2007
Location: orlando, FL
Posts: 558
Total Cats: 0
Default

i have the same setup as you.... SEND IT OFF TO BRAINEACK, pay the shipping there and back.......... or set something up with him.... your megasquirt is the culprit, not the ECU >=P
XxGoKoUxX is offline   Reply With Quote
Old 01-30-2008, 03:06 AM   #15
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

I haven't put it in the car yet. I'm still working on how to put it there.

For example, what does the loose blue wire go to? On the ECU pinout in post one of the FAQ it says "injector 2&4". Do I run this to the signal wire of the actual injectors? It seems weird to me because that should be done inside the case of the stock ECU. I just don't get what these extra wires go to.

The extra wires I have are:
Orange: This is the IAT wire
Purple
Blue
Blue with white stripe
Green
Green with white stripe
Grey
Brownish Grey
Red
Black
miataspeed1point6 is offline   Reply With Quote
Old 01-30-2008, 04:12 AM   #16
Senior Member
iTrader: (2)
 
Join Date: Nov 2007
Location: orlando, FL
Posts: 558
Total Cats: 0
Default

you're suppose to be running parallel with the ECU.... and all that **** is suppose to be hooked up to a DB37 connection.... i believe male for the ECU and female for the megasquirt
XxGoKoUxX is offline   Reply With Quote
Old 01-30-2008, 09:58 AM   #17
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

Quote:
Originally Posted by xXxGoKoUxXx View Post
guys... if you PM brain, and thank him a lot, he will be glad to help you... when i recieved my MS.... no offense to you kingofl337....

i couldn't get my MS to work for ****, it wouldn't light up or anything.... so i sent it out to brain for re-wiring and he made it work like a charm

yeah i rewired two of l337s units. He built them correctly, but the mods didn't always seem to be done right.


from this:


to this:



and from this:


to this:
Braineack is offline   Reply With Quote
Old 01-30-2008, 11:11 AM   #18
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

There is no way to know what is what just by the colors wires. Even between Scott and I we use different colors for different things. l337 was even more off the wall that the differences between scott and I. If you want someone to just fix it up you can send it to Scott or I and we can redo it.
cjernigan is offline   Reply With Quote
Old 01-30-2008, 03:45 PM   #19
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

I just compared mine to the ones you just posted, there are several things wrong. There is no wire to the IGN hole, and none of the resistors under the LEDs are there.

If I send it out to one of you, how much will it cost to run this stand alone?
(93 with no A/C)

I will also need the AIT sensor, bung and pigtail, and I would like to add the EBC.

So,
IAT $30
EBC $50
Fan $10
Idle $10
Harness $40

So $140 plus shipping and whatever the cost is to fix the board?

I am dissapointed because I actually like doing these sorts of things. This damn l337 setup is just confusing the hell out of me.

Thanks.
miataspeed1point6 is offline   Reply With Quote
Old 01-30-2008, 03:49 PM   #20
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

I'm PM you. ill do it for less.
Braineack is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 58 12-13-2017 10:04 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
SimExperience fiberglass race seat in Chicago area chris101 Miata parts for sale/trade 2 10-09-2015 10:08 AM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:37 AM.