Return to stock ECU and runs on two cylinders? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 12-15-2009, 12:28 PM   #1
Junior Member
Thread Starter
 
Join Date: Oct 2008
Location: Manchester, UK
Posts: 274
Total Cats: 0
Default Return to stock ECU and runs on two cylinders?

I've recently handed over IGN and FUEL back to the stock ecu and after doing so, the cars idles really poorly as if it's running on two cylinders. When warm it's fine and after a few cold starts (it's about 2degC here!) it's all fine now. It's almost as if the stock ECU needs to learn again how to run in sequential IGN?

I was running batch IGN with my MS1 using a cam-sensor, stock ECU is sequnetial.

It's not just a one off either. I did this a few months back and the same thing happened for about a day and then the engine runs flawlessly after that in all conditions.

Has anyone any ideas why this occurs?

http://www.ingenieure-reichel.de/upl...g_nb1.6_ms.pdf is the scematic I used when MS1 was controlling things.
CRAIGO is offline   Reply With Quote
Old 12-16-2009, 10:19 AM   #2
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

Which two cylinders is it running on?
Matt Cramer is offline   Reply With Quote
Old 12-16-2009, 12:32 PM   #3
Junior Member
Thread Starter
 
Join Date: Oct 2008
Location: Manchester, UK
Posts: 274
Total Cats: 0
Default

Impossible to say really as it only occurs for a few minutes during warm-up on the stock ECU. If I shut off and restart the engine again, it starts and runs fine. It's just the first start on the stock ECU after changing from MS1 that it occurs.
CRAIGO is offline   Reply With Quote
Old 12-16-2009, 01:38 PM   #4
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,107
Total Cats: 518
Default

Not at all impossible to say. Start it, run to the engine bay, and start pulling plugs. I'm guessing they'll be no idle change on either 2&3 or 1&4. Which ever set doesn't change idle will kill the engine.
curly is offline   Reply With Quote
Old 12-16-2009, 01:41 PM   #5
Senior Member
iTrader: (1)
 
Join Date: Sep 2007
Location: Trenton, NJ
Posts: 1,125
Total Cats: 0
Default

Stock injectors?
ArtieParty is offline   Reply With Quote
Old 12-16-2009, 01:51 PM   #6
Junior Member
Thread Starter
 
Join Date: Oct 2008
Location: Manchester, UK
Posts: 274
Total Cats: 0
Default

Yeah stock injectors.
I'll be able to recreate the issue if I give the MS1 Fuel and IGN again and then hand back to the stock ECU.

Fair point on pulling the plugs, but it was a pain in the **** to keep the engine from stalling so it'd be impossible for me to keep it running long enough to investigate the issue.
CRAIGO is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
In what world... curly MEGAsquirt 11 09-22-2015 12:54 PM
Digital display into stock gauge cluster ihiryu General Miata Chat 2 09-17-2015 08:56 AM
Bp5a swap NA8 Will_da_beast Engine Performance 1 09-14-2015 08:06 PM
Sold fail wagon Miata parts for sale/trade 2 09-07-2015 09:51 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:33 AM.