sequential fuel and the Jimstim - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 02-06-2010, 03:44 PM   #1
Senior Member
Thread Starter
 
Join Date: Nov 2007
Location: Belgium
Posts: 939
Total Cats: 59
Default sequential fuel and the Jimstim

I built a new MS2 running 3.0.3r with sequential fuel.
Before plugging it in the car, I'm playing a bit with it on the Jimstim.
When I select untimed injection (thus, no sequential), everything works as advertised. That is, my 2 injection leds on the jimstim are blinking and the 2 pulse width dials in TS are moving.
However, when I select sequential injection, the 2 leds on the jimstim go dead and the pulse width dials in TS stop moving.
Is this normal operation?
Everything else seems to be working fine.
WestfieldMX5 is offline   Reply With Quote
Old 02-06-2010, 04:00 PM   #2
Junior Member
iTrader: (1)
 
Join Date: Apr 2008
Location: Bristol
Posts: 442
Total Cats: 0
Default

For sequential injection to work you need 2 timing inputs. 1 to show the crank position in degrees and one to indicate which cylinder is at tdc (cam sensor). You will need to emulate a cam position sensor on the jim stim, a simple divide by 2 t-flip flop circuit should do.
Duckie_uk is offline   Reply With Quote
Old 02-06-2010, 11:26 PM   #3
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Delicious and Moist.
Posts: 26,327
Total Cats: 1,926
Default

The JimStim includes a second trigger output by default. It is capable of accurately simulating both the NA and NB signals.

Sorry I can't help with the sequential problem. I probably should play with that on Albert's MS2 that we've got here at the house.
Joe Perez is offline   Reply With Quote
Old 02-06-2010, 11:35 PM   #4
Junior Member
iTrader: (1)
 
Join Date: Jul 2006
Location: Colorado
Posts: 403
Total Cats: 2
Default

Quote:
Originally Posted by Joe Perez View Post
The JimStim includes a second trigger output by default. It is capable of accurately simulating both the NA and NB signals.

Sorry I can't help with the sequential problem. I probably should play with that on Albert's MS2 that we've got here at the house.
I agree, you should figure out MS2 sequential injection. Preferably using the '92 model year stock sensors. Then build me some additional injector driver circuits.

I know where there is good beer. And I will be coming to San Diego and El Toro this year, with lots of trailer room.
Chris Swearingen is offline   Reply With Quote
Old 02-06-2010, 11:59 PM   #5
Newb
 
Join Date: Feb 2010
Posts: 35
Total Cats: 0
Default

Quote:
Originally Posted by f_devocht View Post
I built a new MS2 running 3.0.3r with sequential fuel.
Before plugging it in the car, I'm playing a bit with it on the Jimstim.
When I select untimed injection (thus, no sequential), everything works as advertised. That is, my 2 injection leds on the jimstim are blinking and the 2 pulse width dials in TS are moving.
However, when I select sequential injection, the 2 leds on the jimstim go dead and the pulse width dials in TS stop moving.
Is this normal operation?
Everything else seems to be working fine.
First, you need to cycle power after changing to sequential injection. Second, if you have selected the additional drivers, the JimStim injector LEDs won't light up until you reach 50% duty cycle. That's because the additional drivers are using the same 4 CPU pins but for 4 drivers instead of 2 with pins NANDed. (look at the schematics for clarifications)

So you need to use 4 of the ignition LEDs and connect them to the 4 injector drivers if you want to see the 4 injection drivers and their sequence.

Jean
jbelanger is offline   Reply With Quote
Old 02-07-2010, 03:35 PM   #6
Senior Member
Thread Starter
 
Join Date: Nov 2007
Location: Belgium
Posts: 939
Total Cats: 59
Default

thx Jean, I forgot to power cycle.
WestfieldMX5 is offline   Reply With Quote
Old 02-07-2010, 03:44 PM   #7
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

Any settings highlighted in red require a power cycle to take effect
Ben is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM
"Chimney Ethanol" E100 MiataGarage Engine Performance 5 09-30-2015 12:04 AM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:24 AM.