Sync loss while cranking. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 12-14-2015, 05:01 PM   #1
Junior Member
Thread Starter
 
Join Date: Jul 2013
Location: Norway
Posts: 50
Total Cats: 5
Default Sync loss while cranking.

Hi,

I am having some issues where the engine stops turning while cranking.

I can see from the attached log that I am getting an sync error 31 quickly followed by a error 32 while cranking. Rpm jumps to around 2500 while cranking and ignition spikes to around 30. Seems like this is causing a backfire and it stops the engine from cranking.

I have attached a log from the startup, as well as the tune. I going getting a composite log tomorrow morning when the car has cooled down as I am not having issues on hot starts..

Battery voltage is dropping a lot just before the errors. Could this be due to a faulty starter? The battery is brand new!

BR,
Truls
Attached Files
File Type: msl 2015-12-14_18.46.28.msl (688.9 KB, 63 views)
File Type: msq CurrentTune.msq (111.1 KB, 40 views)
Teejay187 is offline   Reply With Quote
Old 12-14-2015, 07:23 PM   #2
Junior Member
 
Join Date: Jan 2014
Location: Port Saint Lucie,FL
Posts: 418
Total Cats: 3
Default

https://www.miataturbo.net/megasquir...e-crank-80800/

Long story short, switch your rising/falling edge...
Mech5700 is offline   Reply With Quote
Old 12-14-2015, 09:05 PM   #3
Junior Member
Thread Starter
 
Join Date: Jul 2013
Location: Norway
Posts: 50
Total Cats: 5
Default

Quote:
Originally Posted by Mech5700 View Post
https://www.miataturbo.net/megasquir...e-crank-80800/

Long story short, switch your rising/falling edge...
Will give it a try. Read that whole thread before posting, but read elsewhere that the MS2 should have Rising Edge.

Essential info: Stock 99 Miata, MS2E.
Teejay187 is offline   Reply With Quote
Old 12-15-2015, 12:01 AM   #4
Junior Member
 
Join Date: Jan 2014
Location: Port Saint Lucie,FL
Posts: 418
Total Cats: 3
Default

I don't think it is what the ecu "should have", but how the ecu reads the crank signal. Give it a shot and see, let us know!
Mech5700 is offline   Reply With Quote
Old 12-15-2015, 08:15 AM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

Quote:
Originally Posted by Teejay187 View Post
Will give it a try. Read that whole thread before posting, but read elsewhere that the MS2 should have Rising Edge.
It depends on the input circuit and decoder.

what exact MS model/variant do you have?
Braineack is offline   Reply With Quote
Old 12-15-2015, 08:50 AM   #6
Junior Member
Thread Starter
 
Join Date: Jul 2013
Location: Norway
Posts: 50
Total Cats: 5
Default

Quote:
Originally Posted by Braineack View Post
It depends on the input circuit and decoder.

what exact MS model/variant do you have?
Reverant built MS2E. I haven't changed crank settings other than setting the offset.
Teejay187 is offline   Reply With Quote
Old 12-15-2015, 08:51 AM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

you should ask him what's best for his unit. I'm assuming youll wanna keep it how it was setup to begin with.
Braineack is offline   Reply With Quote
Old 12-15-2015, 12:27 PM   #8
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Opto circuits. 90-97 = falling edge, 99-05 = rising edge.
Reverant is offline   Reply With Quote
Old 12-17-2015, 10:03 AM   #9
Junior Member
Thread Starter
 
Join Date: Jul 2013
Location: Norway
Posts: 50
Total Cats: 5
Default

Tried making some composite logs, seems like it stops logging sometimes while cranking. Anyway, I have made some progress. If I turn the key to the "on" position and let it sit for about 30-45 seconds before cranking, the chance of kickback is much lower.. Replacing the head this weekend, so I am going to clean the connectors at the same time, as well as checking grounds.
Teejay187 is offline   Reply With Quote
Old 03-10-2016, 04:55 AM   #10
Junior Member
Thread Starter
 
Join Date: Jul 2013
Location: Norway
Posts: 50
Total Cats: 5
Default

So back to this. Head replaced and removed A LOT of build up. Seemed a little better. Redid the cranking and pulse tables. All good now.
Teejay187 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
PRICE DROP 200hp miata, charleston sc, fresh build, 7,500$$ mxkite24 Cars for sale/trade 5 05-05-2016 09:38 AM
FS: FM Log Manifold, FM Bellmouth, FM 2.5" Downpipe, Enthuza 2.5 Exhaust Kinavo Miata parts for sale/trade 13 01-19-2016 10:27 PM
FS: Brand new Flex Hone tool leatherface24 Miata parts for sale/trade 6 01-18-2016 10:33 PM
Help request: Crank pulley bolts sheared at speed. Now she won't start. zoomy DIY Turbo Discussion 16 12-18-2015 10:22 AM
Brand New Franken-Churbo cordycord Miata parts for sale/trade 0 12-13-2015 07:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:09 PM.