TunerStudio Dash design - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 11-18-2010, 02:11 AM   #1
Junior Member
Thread Starter
 
Join Date: Aug 2006
Location: Cedar City, UT
Posts: 228
Total Cats: 4
Default TunerStudio Dash design



I'm setting this up so I can get info I need ASAP without having to search for it on the screen

Starting in top left corner, the water temp gauge is about four layers

You only see a small bit of green on this image, but there is a full 360* gauge that goes from 0 to 170 degrees (unmarked), then vanishes after 170, I've set up its warning colors to be green, both below 45* and from 100 up, simply as a display for "warm-up" mode

after it reaches 170, you then have the main gauge that the numbers mark the arch from 170 to 230... will probably adjust my warning colors and the temps they activate next summer

in the center, it has a number readout made somewhat large so its easy to read at a glance, will probably add a second in Celsius later on.

above the number is a small indicator that tells if the fans are running or not.

Second gauge is the Tachometer, it is just two gauges, one the bar gauge, with a 3 second "peak" ticker, and the other is the standard needle with the numbers inside. Both go to 8k, but the 8 is hidden behind the other gauge, so would work for 99.9% of the Miata engines out there.

The gauge set into this is the "Boost" gauge, this is 4 separate layers.

Two "Engine Vac Boost" gauges, one going from -30 to 0 psi, and then the other going from 0 to 10 psi to give a higher resolution for boost (I've lowered it to what i am running right now, expecting snow here in Salt Lake City soonish) this can be rescaled to whatever is needed. Also the boost has a 30 sec "peak" ticker, so it can be seen easily if you notice something odd going on.

The two displays inside this is the "Engine Vac Boost" number display as well as the MAP in kPa. Since kPa is a more definite measure of air pressure, I have set it to be bigger (14 psi at sea level (100kPa) is like 16-18 psi at 4400 ft (88 kPa) for example, but both "boost" psi are 200 kPa)

The largest number display I have is the AFR ratio, directly above the Tach, so its easy to find (may change this position later)

The two graph displays i have to the right show RPM and the AFR one above the other... overlaid over both is the throttle position. This has helped me fix lean spots due to accelerator enrichments.


I have it set up in the black/dark grey/ blue color scheme simply because I can see the blue bars and grey text easily during the day with sunglasses on, at night, its not overly bright as it sits in my passenger floorboard, and the warning colors, when they do go off, for caution will light up the bar a bright yellow, but when it goes critical, will light up the entire gauge red to get your attention. I will modify the peak tickers to be red later on for visibility.

I'm not done with this right now, as I will be adding more to it later on, and will update as I go. I can put the .dash file itself on here if people are interested then.

If anyone has suggestions on what other things should be added, removed or changed, please do
Dlaitini is offline   Reply With Quote
Old 11-18-2010, 02:17 AM   #2
Elite Member
iTrader: (17)
 
Join Date: Apr 2009
Location: Atlanta, GA
Posts: 2,831
Total Cats: 0
Default

a warning light for when detination happens would be cool (for those who are running det cans, or the like) it would save some time for those who dont feel like running wire to a light some where in the cabin of the car...
WonTon is offline   Reply With Quote
Old 11-18-2010, 02:56 AM   #3
Junior Member
Thread Starter
 
Join Date: Aug 2006
Location: Cedar City, UT
Posts: 228
Total Cats: 4
Default

Ok, i can add that, it would probably be two things, if it can be assigned a value, i can try to add it as an over lay on the graph, so you will see a vertical line for every time it triggers over the AFR, RPM and Throttle graphs, as well as a very large box that will be invisible all the time until the Det can goes off, causing a BIG red flash that is sure to get anyone's attention. This will need to be changed to what ever the MS input for it is.

I am also going to be tossing the .dash file back and forth from my laptop to my main PC.
Due to differences in screen size, I will try to make it so it will be ok for all sizes, though currently if you try to do full screen, (removing all the tunerstudio buttons at the top) the bar gauges turn into ovals, so for right now, I will probably not be making a full screen version, that may change if there is a big need for it though
Dlaitini is offline   Reply With Quote
Old 11-18-2010, 03:00 AM   #4
Elite Member
iTrader: (17)
 
Join Date: Apr 2009
Location: Atlanta, GA
Posts: 2,831
Total Cats: 0
Default

due to some peoples screen sizes i would say a invisble box would be best, and for when det happens have the light flash to help with grabbing attention (if possible)
WonTon is offline   Reply With Quote
Old 11-18-2010, 05:24 AM   #5
Junior Member
 
Join Date: Oct 2008
Location: Manchester, UK
Posts: 274
Total Cats: 0
Default

Here's mine shamelessly cribbed from someone's hard work over at the MSExtra forum. With a few personal tweaks of my own.

I tried to run it on MS1 but it wouldn't run right. It runs great on my MS2.

Name:  TSscreengrab.png
Views: 151
Size:  126.8 KB

It serves me for VEAL. I let that run on the other tab and can monitor the AFRs live on this screen. What is cool about traces over dials is that I can do a 7krpm boosted run and watch the road. After the run you still have the trace on the timeline and can quickly glance at how close those AFRs actually are to the target. Much better than running live dials imo.

Imo, you NEED a closed loop idle light if your idle isn't tuned. The bulb goes on/off as enters/leaves closed loop.

WUE at the bottom of screen goes out once it's not in use as does the indicator at the top. No point in having gauges that display "off" values and also keeps the info easy to glance at.

Presets for MAT, CLT, Batt Voltage etc turn yellow/red at my pre-determined ranges which show up nicely on the black background. As does redline.

I've added Gammae enrich and duplicated MAT under it for tuning the MAT correction curve.
CRAIGO is offline   Reply With Quote
Old 11-18-2010, 09:23 AM   #6
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

I spend all my effort acutally tuning the car...so I still use the default LED dash design.
Braineack is offline   Reply With Quote
Old 11-18-2010, 09:32 AM   #7
I'm a terrible person
iTrader: (19)
 
FRT_Fun's Avatar
 
Join Date: Apr 2009
Location: Arizona
Posts: 7,293
Total Cats: 180
Default

Quote:
Originally Posted by Braineack View Post
I spend all my effort acutally tuning the car...so I still use the default LED dash design.
In soviet russia, cars tune you.
FRT_Fun is offline   Reply With Quote
Old 11-18-2010, 09:54 AM   #8
I haz no trubo
iTrader: (2)
 
Oscar's Avatar
 
Join Date: Jan 2007
Location: Bolton, UK
Posts: 3,021
Total Cats: 114
Default

How do you get the indicator to go on when fans switch on? Chose output channel Port 6, which should be my fans, yet it switches colours randomly?
Oscar is offline   Reply With Quote
Old 11-18-2010, 10:30 AM   #9
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

I've tried twice to make these dashboards and both times I've saved them, and lost them upon reopening. Good thing I paid $40 for this ****. I also can't get it to save the damn communication settings either.
hustler is offline   Reply With Quote
Old 11-18-2010, 10:42 AM   #10
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

Where is your main project folder and what OS? it should be in My Docs so you dont have any accessibility issues.
Braineack is offline   Reply With Quote
Old 11-18-2010, 10:52 AM   #11
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by Braineack View Post
Where is your main project folder and what OS? it should be in My Docs so you dont have any accessibility issues.
I don't use mydocs, I have a subdirectory in Megatune for Tuner Studio. Must I change my ways?
hustler is offline   Reply With Quote
Old 11-18-2010, 10:58 AM   #12
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

That might be the issue, if you have vista or win7, it doesn't like when you add/edit files into main program directories.

You might wanna point your projects back to the default location.

C:\Documents and Settings\USERNAME\My Documents\TunerStudioProjects
Braineack is offline   Reply With Quote
Old 11-19-2010, 05:59 PM   #13
Junior Member
 
Join Date: Jan 2010
Location: Atlanta GA
Posts: 167
Total Cats: 0
Default

Looking at Dlaitini's dash I have a quick suggestion. Right click your tach in designer mode and goto order and push it to the back.

Then you could set the angles to make the face a full 360 degrees and it would get rid of that 3/4 yellow circle in the middle of the gauge and fill in those edges where it meets the bottom of the boost gauge.

Now a question: What gauges are you using for your analogs? How are you making the high markers just lines like that?
D.dutton9512 is offline   Reply With Quote
Old 11-19-2010, 06:24 PM   #14
Elite Member
iTrader: (30)
 
Join Date: Aug 2007
Location: Va Beach
Posts: 7,282
Total Cats: 0
Default

I can't find vac/boost now that I have MSII. I had it with MSI.
__________________
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
levnubhin is offline   Reply With Quote
Old 11-19-2010, 06:43 PM   #15
Senior Member
 
Join Date: Nov 2007
Location: Belgium
Posts: 939
Total Cats: 59
Default

Quote:
Originally Posted by Oscar View Post
How do you get the indicator to go on when fans switch on? Chose output channel Port 6, which should be my fans, yet it switches colours randomly?
On MS2Extra, the output channels for PT6-IAC1 (fans) and PT7-IAC2 (vics) are port 4 and port 5. Not port 6 and 7 as one would expect ...
Mine's also the Slimfull theme with a couple of modifications.
Orange indicator on the tach is CL Idle.
Big red indicator on the tach is sync (cranking)
Green indicator next to coolant temp is fan-on.


Last edited by WestfieldMX5; 11-19-2010 at 07:35 PM.
WestfieldMX5 is offline   Reply With Quote
Old 11-19-2010, 07:06 PM   #16
Junior Member
Thread Starter
 
Join Date: Aug 2006
Location: Cedar City, UT
Posts: 228
Total Cats: 4
Default

Quote:
Now a question: What gauges are you using for your analogs? How are you making the high markers just lines like that?
I'm using the "Analog Moving Bar Guage (High CPU)" for the main Five guages (temp 0-170, temp 170 to 230, RPM, vac -30 to 0 and boost 0 to 10) and the "Analog Guage" for the RPM part with the needle.

I think later on, i will drop the ticks from the current guages, and layer in more under the current ones, except red, and have those display the tick mark. That way the high point will be able to display as a brighter color to be able to see at a glance.

for the multilayer guages, to make sure they all match, once i set up the one guage, ive simply copy and paste it to make the different layers and make the sizes match but then change its limits.

the RPM guage, it is the bar guage, then copied, and that copy turned into a standard analog guage, then that re sized and recolored to fit inside the bar guage. This part just takes a little bit of time and tweeking. The arrow keys also allow you to bump the guage pixel by pixel for fine tuning

Quote:
How do you get the indicator to go on when fans switch on? Chose output channel Port 6, which should be my fans, yet it switches colours randomly?
for the MSPNP its output 2, that would have to change depending on how you have it connected
Dlaitini is offline   Reply With Quote
Old 11-19-2010, 07:17 PM   #17
Junior Member
 
Join Date: May 2007
Location: Columbia, MD
Posts: 248
Total Cats: 0
Default

Here is what I created for ms3 in upgrade mode. I'm going to create another one for sequential fuel/spark users that includes individual injector PW to handle trim.



Ken
Attached Thumbnails
TunerStudio Dash design-ts.jpg  
muythaibxr is offline   Reply With Quote
Old 11-19-2010, 08:58 PM   #18
Junior Member
 
Join Date: Jan 2010
Location: Atlanta GA
Posts: 167
Total Cats: 0
Default

Is the closed loop idle indicator not available for an MS1 (pnp) board? It doesn't seem to exist under the pre-defined indicator settings.


This is my "basic" dashboard. It works pretty good when I don't want to search for whatever I'm looking for but it's still a bit crowded.



The far left is boost/vaccum. Imbedded in the tach is the AFR and Spark. Then on the right is the CLT temp with the Manifold temp in the middle.

Last edited by D.dutton9512; 11-20-2010 at 01:14 AM.
D.dutton9512 is offline   Reply With Quote
Old 11-22-2010, 11:36 AM   #19
Junior Member
 
Join Date: May 2007
Location: Columbia, MD
Posts: 248
Total Cats: 0
Default

I don't know, I didn't write that and have never used it.

Ken
muythaibxr is offline   Reply With Quote
Old 11-23-2010, 03:56 PM   #20
Elite Member
iTrader: (30)
 
Join Date: Aug 2007
Location: Va Beach
Posts: 7,282
Total Cats: 0
Default

Anyone have any indicators for water injection?
__________________
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
levnubhin is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
Another Cast Manifold Corky Bell Prefabbed Turbo Kits 18 11-22-2016 10:01 PM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Is my swirl pot design okay? FrankB Race Prep 10 10-02-2015 10:00 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:44 PM.