weird knock system problem - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 02-29-2008, 06:46 PM   #1
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default weird knock system problem

Hey guys,

I just drove my car for the first time in 2 weeks!!! (yay). I decided to go for a 30 minute drive or so and on the trip back i did a short log. I noticed the knock LED went off a few times at high rpms.. my engine wasnt running great in this cold ****. When i reviewed the datalog i saw that after one of the knock events it continued to log it as -1 (knocking) for probably 30 seconds or longer... then went back to 0 . Most anoying part is because i have the knock system on it chose to retard my timing that whole time...Whats up with this, why would it stay showing knock when the led indicator isnt showing anything? ... here is the file:

http://filemonster.net/en/file/9591/feb29-xls.html
240_to_miata is offline   Reply With Quote
Old 02-29-2008, 07:17 PM   #2
Senior Member
iTrader: (3)
 
Join Date: Feb 2006
Location: Centennial, CO
Posts: 672
Total Cats: 20
Default

Have you even tuned the knock sensor yet?
karter74 is offline   Reply With Quote
Old 02-29-2008, 07:28 PM   #3
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

yeah my knock sensor is pretty well tuned. Normaly it wont come on even at high rpms.. when the engine is cold or if its running a little rough it will flicker once or MAYBE twice at high rpms. i was getting a decent amount of knock but like i said the engine was running a little cold today (160*F coolant)... 25 minute drive

BTW i forgot to mention... this is with KnocksenseMS and i have the led hooked up
240_to_miata is offline   Reply With Quote
Old 02-29-2008, 07:28 PM   #4
Elite Member
iTrader: (24)
 
Join Date: Jun 2007
Location: Sherman Oaks, CA
Posts: 4,481
Total Cats: 3
Default

adjust sensitivity of knock sensor
UrbanSoot is offline   Reply With Quote
Old 02-29-2008, 07:29 PM   #5
Elite Member
iTrader: (24)
 
Join Date: Jun 2007
Location: Sherman Oaks, CA
Posts: 4,481
Total Cats: 3
Default

also... if knock appears at the same rpm level every time, tune that **** out with more fuel or less spark
UrbanSoot is offline   Reply With Quote
Old 03-01-2008, 03:26 AM   #6
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

u guys .... ur missing my question....

It is reading -1 ... meaning there is a knock event.... when the LED isnt even on
240_to_miata is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 58 12-13-2017 10:04 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
Bizarre connection issue? nick470 MEGAsquirt 1 09-30-2015 11:32 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:29 AM.