MSPNP MSPNP specific Megasquirt related discussion.
Sponsored by:
Sponsored by:

Another Idle Issue Thread

 
Old 05-16-2019, 08:19 PM
  #1  
Newb
Thread Starter
 
Join Date: Mar 2018
Location: San Miguel, Ca
Posts: 31
Total Cats: 0
Default Another Idle Issue Thread

I had my ecu tuned by a reputable tuner and the idle works well most of the time. However, it seems like after it gets heated up and I'm guessing goes into CL it can sometimes stumble at idle even to the point of dying. Sometimes it catches itself and climbs back up. It's only occasionally. I thought from another thread it was the PID setting which was at 1, so I've turned it up to 3 and it seems to be helping because it hasn't died and seems to catch quicker. Still not sure why it's happening at all though. I logged it happening, any ideas?
Attached Files
File Type: msl
2019-05-16_16.19.08.msl (469.2 KB, 4 views)
File Type: msq
CurrentTune.msq (275.2 KB, 7 views)

Last edited by nnowa07; 05-16-2019 at 08:35 PM.
nnowa07 is offline  
Old 05-16-2019, 08:34 PM
  #2  
Junior Member
 
Mudflap's Avatar
 
Join Date: May 2017
Location: Louisville, Co
Posts: 289
Total Cats: 72
Default

sigh... man why don't people post their tune?

It would be like reading an ekg without any patient available to answer questions. Why bother?
Mudflap is offline  
Old 05-16-2019, 08:37 PM
  #3  
Newb
Thread Starter
 
Join Date: Mar 2018
Location: San Miguel, Ca
Posts: 31
Total Cats: 0
Default

haha went back and posted it right when you posted.
nnowa07 is offline  
Old 05-17-2019, 04:35 PM
  #4  
Junior Member
 
Mudflap's Avatar
 
Join Date: May 2017
Location: Louisville, Co
Posts: 289
Total Cats: 72
Default

Your fueling is way off. You are super lean at idle. Even when you got it idling, you can see your EGO take off to 116% to try and solve the problem. But then when you blip the throttle you go into an instability.

Basics of getting good idle. Step one. Use more fuel than you want. Like AFR of 13.5. Step 2, idle higher than you want. Like 1200rpm.

That should get your running. Then from there you do tweaks to timing, idle advance timing and other settings in order to pull the rpm down and AFR to (eventually) 14.7.

p.s. You are (and should) use the RPM timing correction curve, but you don't have it filled out from low RPM to high RPM error.
Mudflap is offline  
Old 05-19-2019, 06:44 PM
  #5  
Newb
Thread Starter
 
Join Date: Mar 2018
Location: San Miguel, Ca
Posts: 31
Total Cats: 0
Default

Turns out there's an exhaust leak where the DP connects to the turbo. I'm guessing this is contributing and explains the lean mixture and the trouble the tuner had. Hopefully this will allow us to narrow down the issue if it even persists after the leak is fixed.
nnowa07 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rrjwilson
MEGAsquirt
3
Today 05:18 AM
trizvi96
DIY Turbo Discussion
2
05-13-2019 02:43 PM
salamons
MSPNP
8
05-12-2019 10:00 PM
WigglingWaffles
MEGAsquirt
2
05-08-2019 10:39 PM


Thread Tools
Search this Thread
Quick Reply: Another Idle Issue Thread


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.