MSPNP MSPNP specific Megasquirt related discussion.
Sponsored by:
Sponsored by:

MSPNP2 - Starter kickback/Cold start issues

 
Old 11-21-2016, 10:03 AM
  #1  
Newb
Thread Starter
 
Join Date: Jun 2016
Posts: 4
Total Cats: 0
Default MSPNP2 - Starter kickback/Cold start issues

1992 1.6, MSPNP2, non turbo:

Now that it's getting colder out, I've been having more and more trouble cold starting my car. I've been getting what seems to be starter kickback and the occasional coughing noise coming from the intake as well as the exhaust. Feathering the gas gives mixed results and is much more helpful when the car is hot. I've tried bringing cranking advance down from 10 degrees to 0 without anything changing. Is it worth bringing the cranking advance down even further to -5 degrees or so? I'm not really sure what I should try to fix that. I've done a good amount of research and most of it points to cranking advance. I've attached a log of the kickback from this morning along with the current tune on the car. I just realized that my wideband was still in warmup mode so its reading isn't useful.

Any help or even a direction to go in would be extremely appreciated.
Attached Files
File Type: msq
CurrentTune.msq (119.2 KB, 76 views)
File Type: msl
jwg101x is offline  
Old 11-21-2016, 11:52 AM
  #2  
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,329
Total Cats: 62
Default

Try increasing "skip pulses" - this will let the engine turn a little longer before the ECU tries to fire the spark. This can help with kick-back issues.
__________________
Matt Cramer
www.diyautotune.com
Matt Cramer is offline  
Old 11-21-2016, 03:53 PM
  #3  
Newb
Thread Starter
 
Join Date: Jun 2016
Posts: 4
Total Cats: 0
Default

Originally Posted by Matt Cramer View Post
Try increasing "skip pulses" - this will let the engine turn a little longer before the ECU tries to fire the spark. This can help with kick-back issues.
I'm pretty sure this helped the problem. I was able to start the car about 4 or 5 times in a row with no kickback or coughing at all after changing the skipped pulses. I set it to 6 skipped pulses at first but that might've been a bit too much. I set it at 5 and the car seems to start much better now. I'll really know tomorrow morning when I cold start again. Thanks!
jwg101x is offline  

Thread Tools
Search this Thread

Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.