MSPNP2 - Updated to 3.3.0 open the basemap .msq - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MSPNP MSPNP specific Megasquirt related discussion.

Reply
 
 
 
LinkBack Thread Tools
Old 12-02-2013, 02:11 PM   #1
Junior Member
Thread Starter
 
Join Date: Aug 2013
Location: Madison, In
Posts: 74
Total Cats: 1
Default MSPNP2 - Updated to 3.3.0 open the basemap .msq

First off I would like to say Finally i got around to installing my Mega in the miata.

My issue is that I updated to the latest firmware using the instruction posted on Megasquirt MS2/Extra Loading firmware and Upgrade Notes but the basemap will not load.

I followed the instructions for upgrading and I was successful in upgrading to 3.3.0.

I created a project, gave it a name etc. I go to open the basemap MS2E v3.3.0 MSPNP2-MM9093 and i get a couple of errors.

the first one is : Signatures do not match!
Tune File signature: null
Configuration Signature: MS2Extra comms330MP

do I want to load anyways? I say "Yes" then i get a prompt stating that it will load settings from the 1 1992 Miata.msq and current tune.msq will be updated with the new setting. Click "Yes" to proceed

I then get this message: Error opening Saved tune.
Reported Error:
Problem parsing tune settings file (.msq):
The markup in the document following the root element must be well-formed.
Root problem: The markup in the document following the root element must be well-formed.





So, has anyone had this issue, is there a known good basemap that I can download from an alternate location?

When i get home, im going to re-flash frimware 3.3.0 on my MS and try to load the tune again.
zero415 is offline   Reply With Quote
Old 12-02-2013, 02:17 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,854
Total Cats: 1,788
Default

Quote:
Tune File signature: null
sounds like you still have the boot jumper in place or you didn't flash succesfully.
Braineack is online now   Reply With Quote
Old 12-02-2013, 03:07 PM   #3
Junior Member
Thread Starter
 
Join Date: Aug 2013
Location: Madison, In
Posts: 74
Total Cats: 1
Default

It was my first time updating, and I never opened the case to see if the jumper was on or not.

When I launched tuner studio afterwards, it detected my mega. it had it listed as 330d from the ini file.

im also using a usb to serial adapter for the MS, but i dont think this is an issue.


I forgot to mention that I used the default debug when flashing the update. However, the firmware flash didnt fail, or didnt notify me that it did. Should I try to flash without the Boot Jumper?

Last edited by zero415; 12-02-2013 at 05:22 PM.
zero415 is offline   Reply With Quote
Old 12-02-2013, 08:53 PM   #4
Junior Member
Thread Starter
 
Join Date: Aug 2013
Location: Madison, In
Posts: 74
Total Cats: 1
Default

Update:

I downloaded the 3.3.0 flash and I used the boot jumper and followed all the on screen instructions from the command prompt. it seems to flash normal and doesnt give any other messages.

When I go to open the 3.3.0 base file the window says unrecognized file. and still gives the null error.



My next question is does anyone have the MS2/Extra pre-3.3 beta 16.20130822 firmware that I could have?
Update 2:

nevermind I got a copy of the firmware that came on my MS. I'm going to try to flash back tomorrow.

Last edited by zero415; 12-02-2013 at 10:29 PM.
zero415 is offline   Reply With Quote
Old 12-03-2013, 12:35 PM   #5
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

Can you post a screen shot of the error message?
Matt Cramer is offline   Reply With Quote
Old 12-03-2013, 12:47 PM   #6
Junior Member
Thread Starter
 
Join Date: Aug 2013
Location: Madison, In
Posts: 74
Total Cats: 1
Default





the base file is for the 1.6 miata 3.3.0 and this is after reflashed lastnight using the jumper pin and following the console commands.



Also, can somebody be clear with me on flashing the MSPNP2?

Do I need to have the boot jumper on when flashing to new or older firmware?

also in the command prompt, it gives 4 options the 4th being Microsquirt Case, microsquirt module and MSPNP I selected MSPNP when flashing 3.3.0, should i have used the Microsquirt module instead?

at this point, i have the beta firmware that came on my MSPNP and I can reflash back to that tonight.
Attached Thumbnails
MSPNP2 - Updated to 3.3.0  open the basemap .msq-ms1_zps658eb3b9.jpg  
zero415 is offline   Reply With Quote
Old 12-03-2013, 12:53 PM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,854
Total Cats: 1,788
Default

and what happens when you hit yes?
Braineack is online now   Reply With Quote
Old 12-03-2013, 12:58 PM   #8
Junior Member
Thread Starter
 
Join Date: Aug 2013
Location: Madison, In
Posts: 74
Total Cats: 1
Default

clicking yes gives a second error. I dont have a picture but this is the text that it gives.


Reported Error:
Problem parsing tune settings file (.msq):
The markup in the document following the root element must be well-formed.
Root problem: The markup in the document following the root element must be well-formed.


I downloaded the 3.3.0 firmware and selected other and put the MSPNP2.ini in there and tried to open the 3.3.0 basemap. below is the error





Update:

Phil from DIY responded by my e-mail stating that they had an issue with the website where the base maps are. Hopefully this is the issue with the 3.3.0 map. so I would watch downloading from megasquirtpnp.com for now.
Attached Thumbnails
MSPNP2 - Updated to 3.3.0  open the basemap .msq-ms1_zps658eb3b9.jpg   MSPNP2 - Updated to 3.3.0  open the basemap .msq-ms2_zpsc247196a.jpg  

Last edited by zero415; 12-03-2013 at 06:19 PM.
zero415 is offline   Reply With Quote
Old 12-03-2013, 06:37 PM   #9
Junior Member
iTrader: (1)
 
Join Date: Sep 2011
Posts: 114
Total Cats: 0
Default

I just went through this with Matt over at DIYAUTOTUNE - he sent me my basemap here: (This is for a 96' NA)

Hopefully the site will be uploaded soon.

https://www.dropbox.com/sh/jtf4vy54ezt2wwb/YWN6ThC7Xv
chitty chitty bang bang is offline   Reply With Quote
Old 12-03-2013, 08:52 PM   #10
Junior Member
Thread Starter
 
Join Date: Aug 2013
Location: Madison, In
Posts: 74
Total Cats: 1
Default

Even tho this is for a 96, at least I can test around with it and make sure my mS is good.

the DIY guys will probably send me a 3.3.0 map tomorrow via e-mail. But thanks for sharing your map!
zero415 is offline   Reply With Quote
Old 12-04-2013, 10:38 AM   #11
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

We're fixing the website now. A couple of the tunes hadn't been uploaded for 3.3.0, and trying to download them would get an error message. Unfortunately, the error message would get saved as an MSQ file.
Matt Cramer is offline   Reply With Quote
Old 12-04-2013, 12:29 PM   #12
Junior Member
Thread Starter
 
Join Date: Aug 2013
Location: Madison, In
Posts: 74
Total Cats: 1
Default

That would make sense.

Could you elaborate on flashing firmware?

Do I always have to place the jumper on the boot pins before flashing? And when prompted to select firmware do I use the microsquirt module or MSPNP?


Thanks

Jerad
zero415 is offline   Reply With Quote
Old 12-04-2013, 12:35 PM   #13
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,854
Total Cats: 1,788
Default

your unit is flashed, what you need is a tune file you can load.
Braineack is online now   Reply With Quote
Old 12-04-2013, 02:58 PM   #14
Junior Member
Thread Starter
 
Join Date: Aug 2013
Location: Madison, In
Posts: 74
Total Cats: 1
Default

I know I flashed but i m trying to make sure that I selected the right option when I did flash.
zero415 is offline   Reply With Quote
Old 12-05-2013, 07:58 AM   #15
Junior Member
Thread Starter
 
Join Date: Aug 2013
Location: Madison, In
Posts: 74
Total Cats: 1
Default

Well the .msq file I got from Phil at DIYautotune didn't work either. I'm using tuner studio 2.5.0 and I get the same errors as posted earlier.
zero415 is offline   Reply With Quote
Old 12-05-2013, 08:56 AM   #16
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,854
Total Cats: 1,788
Default

what happens if you connect your MS to TS, click save tune as, then try open that same tune you just saved?
Braineack is online now   Reply With Quote
Old 12-05-2013, 01:55 PM   #17
Junior Member
Thread Starter
 
Join Date: Aug 2013
Location: Madison, In
Posts: 74
Total Cats: 1
Default

Quote:
Originally Posted by Braineack View Post
what happens if you connect your MS to TS, click save tune as, then try open that same tune you just saved?
The issue still lies within their downloads on the website.

Phil sent me another version of the 3.3.0 .msq for the 1.6 miata and i was able to open that msq file up in tuner studio.

Im in the process of uploading it to my dropbox and will update with the link when complete.

Update:

I have attached the file, but if you cant get it here is the alternate link to dropbox:

https://www.dropbox.com/s/yqj5cl9yeu...93%20Miata.msq
Attached Files
File Type: msq MM9093 Miata.msq (107.4 KB, 78 views)
zero415 is offline   Reply With Quote
Old 12-28-2013, 06:35 PM   #18
Junior Member
 
Join Date: Dec 2012
Posts: 48
Total Cats: 0
Default

****, I just started a new thread an I am having the same errors. I will try the drop box file here and update.
Dagger is offline   Reply With Quote
Old 12-28-2013, 07:00 PM   #19
Junior Member
 
Join Date: Dec 2012
Posts: 48
Total Cats: 0
Default

I managed to load the file attached in the above message no error warnings for me but my car won't start still - however I do now have spark on all 4 cyls again.
Dagger is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
LucaCarMods's Boosted Dutch Miata Build! LucaCarMods Build Threads 11 02-14-2016 07:13 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM
WTB; na6 Miata things (Canada) Jared Rowe WTB 0 09-23-2015 12:57 PM
Innovate LC-2 Wideband O2 Sensor w8lifter21 Miata parts for sale/trade 0 09-14-2015 12:30 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:34 PM.