Stall or Hesitation on first touch of the Throttle - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MSPNP MSPNP specific Megasquirt related discussion.

Reply
 
 
 
LinkBack Thread Tools
Old 04-08-2014, 09:24 AM   #1
Junior Member
Thread Starter
 
Join Date: Nov 2011
Location: Helsinki, Finland
Posts: 45
Total Cats: 7
Default Stall or Hesitation on first touch of the Throttle

Got all new plugs in, and have trawled through here and tried to set up my target tables as best i can based on the fun facts and figures in the encyclopedia that is this forum.

I still get a hesitation when you first touch the throttle, occasionally even a stall?

I have attached a log if it can be of use to someone to redirect me.

This has been somewhat of a steep learning curve this build. and it just keeps on giving
Attached Files
File Type: msl 2014-04-08_14.53.35.msl (432.7 KB, 35 views)
Turbo Banana is offline   Reply With Quote
Old 04-08-2014, 09:32 AM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,813
Total Cats: 1,780
Default

TUNEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE.


you need to tune your aftermarket ECU that requires tuning in order to run correctly.



specifically you need to tune your acceleration enrichments. You know, they ones that prevent the car from going lean based on rapid throttle/map changes to prevent the car from stalling or hesitation on first touch of the throttle...
Braineack is online now   Reply With Quote
Old 04-08-2014, 09:47 AM   #3
Junior Member
Thread Starter
 
Join Date: Nov 2011
Location: Helsinki, Finland
Posts: 45
Total Cats: 7
Default

OK back out on the road with auto tune we go, called Megasquirt dyno place yesterday and was quoted 6-8 weeks before has a spot =( hence muchos trawling through the forum and trying to learn something of it myself first.

Just being a tad paranoid before i take it out on the road again. Thanks.
Turbo Banana is offline   Reply With Quote
Old 04-08-2014, 10:09 AM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,813
Total Cats: 1,780
Default

autotune wont fix your acceleration enrichments.
Braineack is online now   Reply With Quote
Old 04-08-2014, 12:16 PM   #5
Junior Member
Thread Starter
 
Join Date: Nov 2011
Location: Helsinki, Finland
Posts: 45
Total Cats: 7
Default

back to the reading mode it is then
Turbo Banana is offline   Reply With Quote
Old 04-08-2014, 08:35 PM   #6
Junior Member
Thread Starter
 
Join Date: Nov 2011
Location: Helsinki, Finland
Posts: 45
Total Cats: 7
Default

Well it seems i have made things better and worse with my fiddling

Now at least i am getting some proper boost and the car pulls like a train, which is nice.

However previously it would barely scrape to .5bar boost now its overboosting past 1bar (200kpa)

I have followed or tried to as best as i can so far the instructions set out by Lord Braineack regarding setting up P I and D values, even with P at max value of 200 it over boosts?
Should i reduce my boost table values to a lower number ?

I now also have lost the ability to pull away, without massive clutch slippage to keep the revs above 2500.

I have some major Kangaroo effect happening between 2000rpm and 3000rpm.

Have to say while it is on boost, holy crap this thing takes off like a mustarded Cat.

Please bare with me guys i am kinda stuck out here in a town where nobody seems to use megasquirt and i get messages like "you see we dont use it because it blows up engines" i jest ye not!
and the language barrier has been an issue as well. The original plan was for this to be built in the UK before i left, alas life threw a curve ball as it likes to
Turbo Banana is offline   Reply With Quote
Old 04-09-2014, 04:52 AM   #7
Junior Member
 
Join Date: Dec 2011
Posts: 75
Total Cats: 3
Default

Quote:
Originally Posted by Turbo Banana View Post
Well it seems i have made things better and worse with my fiddling

Now at least i am getting some proper boost and the car pulls like a train, which is nice.

However previously it would barely scrape to .5bar boost now its overboosting past 1bar (200kpa)

I have followed or tried to as best as i can so far the instructions set out by Lord Braineack regarding setting up P I and D values, even with P at max value of 200 it over boosts?
Should i reduce my boost table values to a lower number ?

I now also have lost the ability to pull away, without massive clutch slippage to keep the revs above 2500.

I have some major Kangaroo effect happening between 2000rpm and 3000rpm.
I'm assuming you're using an EBC like the Diyautotune for example.
If you're over boosting try setting all your numbers in the boost table to 100. If it still over boosts it's not your boost map as it's now working from your wastgate only. Try that and then re post.
HeresJohnny is offline   Reply With Quote
Old 04-09-2014, 08:34 AM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,813
Total Cats: 1,780
Default

Quote:
Originally Posted by Turbo Banana View Post
However previously it would barely scrape to .5bar boost now its overboosting past 1bar (200kpa)

that's some hell of a job you did tuning your acceleration enrichments!
Braineack is online now   Reply With Quote
Old 04-09-2014, 02:26 PM   #9
Junior Member
Thread Starter
 
Join Date: Nov 2011
Location: Helsinki, Finland
Posts: 45
Total Cats: 7
Default

Do i detect sarcasm sir =)

In some ways yes it is a lot better, alas it stalls all the time now and is almost undriveable till 2.5k rpm. slightest touch of the throttle and it dies, needs real careful feathering to lift revs then clutch destruction to pull away =(

I think it might be the spark table causing this as its the only other one changed?

Will try the boost table suggestion tonight, but i had first 3 rows at 100 already =/

Last edited by Turbo Banana; 04-09-2014 at 07:06 PM.
Turbo Banana is offline   Reply With Quote
Old 04-09-2014, 07:29 PM   #10
Junior Member
Thread Starter
 
Join Date: Nov 2011
Location: Helsinki, Finland
Posts: 45
Total Cats: 7
Smile

Huzzah, back to driveable, still not perfect but all in due course.
I can now pull away infact i can now rev it again, before a dab of the throttle just killed it.
The problem lay in Accell Wizard, i had turned on the enrichment tab to include "Lag Compensation" took me a while by starting with a working map and changing details one by one from the last one i updated several things on at once but i found it. Now one happy camper.

Next up is the over boost issue but i didnt have time to go out on the road tonight and play with that.

should any adults care to peruse my tables i have attached them









Attached Thumbnails
Stall or Hesitation on first touch of the Throttle-vetable.png   Stall or Hesitation on first touch of the Throttle-afrtable.png   Stall or Hesitation on first touch of the Throttle-boostmap.png   Stall or Hesitation on first touch of the Throttle-sparx.png   Stall or Hesitation on first touch of the Throttle-accelwizard.png  

Turbo Banana is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Another Alternator thread ihiryu General Miata Chat 9 09-28-2015 11:22 AM
VE analyze and Autotune seems funny (noob) TorqueZombie MEGAsquirt 64 09-18-2015 06:03 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:33 AM.