Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Aerocharger Turbo No Boost?

 
Old 11-28-2008, 07:25 PM
  #1  
Newb
Thread Starter
 
Join Date: Nov 2008
Location: ca
Posts: 10
Total Cats: 0
Default Aerocharger Turbo No Boost?

Hey guys im a noob and was wondering if i can get some help. I have 90 miata equipped Aerocharger turbo. The car drives normally but isnt getting any boost. I do have vacuum pressure but barely hits zero. Anyone familiar with this turbo? Thanks

wil,

heres a link on what kind of turbo it is-http://aerocharger.com/
b00stedmiata is offline  
Old 11-28-2008, 07:29 PM
  #2  
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,824
Total Cats: 269
Default

Post some pictures. And more info. What type of engine management are you using?
patsmx5 is offline  
Old 11-28-2008, 07:47 PM
  #3  
Newb
Thread Starter
 
Join Date: Nov 2008
Location: ca
Posts: 10
Total Cats: 0
Default

i think a stock engine management system. i bought the car with this problem.i dont have pics at this moment.but heres a link to how it exactly looks like. Aerodyne.
b00stedmiata is offline  
Old 11-28-2008, 07:53 PM
  #4  
Senior Member
iTrader: (14)
 
Join Date: Aug 2008
Location: Tinley Park, IL
Posts: 1,482
Total Cats: 0
Default

Is the turbo seized up? Is the waste gate stuck open?

Post some pics, we can't see much in the pic on the link. Yours may be slightly different.
lordrigamus is offline  
Old 11-28-2008, 07:56 PM
  #5  
Newb
Thread Starter
 
Join Date: Nov 2008
Location: ca
Posts: 10
Total Cats: 0
Default

sorry for pic. I was told the waste gate was stuck open but this turbo doesn't use a waste gate. it uses a VATN (variable area turbine nozzles).

Wilson,
b00stedmiata is offline  
Old 11-28-2008, 07:57 PM
  #6  
Newb
Thread Starter
 
Join Date: Nov 2008
Location: ca
Posts: 10
Total Cats: 0
Default

i doubt the turbo has seized bcz i still here the turbo spin when give it a little bit of gas.
b00stedmiata is offline  
Old 11-28-2008, 08:03 PM
  #7  
Newb
Thread Starter
 
Join Date: Nov 2008
Location: ca
Posts: 10
Total Cats: 0
Default

sorry i wish i could post better pics but the car isnt with me right now. I could post some pics in a couple of days. uhm I dont know what else to say about the car. It runs great but just isn't getting any boost. anything i could look into to see what the problem is??thanks
b00stedmiata is offline  
Old 11-28-2008, 08:05 PM
  #8  
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,824
Total Cats: 269
Default

Read the FAQs and stickies on this forum. It will give you an idea of what's required to turbo a miata. Then look and see if you have all the parts required installed.
patsmx5 is offline  
Old 11-28-2008, 08:16 PM
  #9  
Newb
Thread Starter
 
Join Date: Nov 2008
Location: ca
Posts: 10
Total Cats: 0
Default

thanks. appreciate it
b00stedmiata is offline  
Old 11-28-2008, 08:24 PM
  #10  
I'm Miserable!
iTrader: (1)
 
Join Date: Oct 2005
Location: Columbia, SC
Posts: 853
Total Cats: 0
Default

your username lies.

never used/seen an aerocharger turbo in person. I would think twice...no ten times before buying an untraditional turbo.
SloS13 is offline  
Old 11-28-2008, 08:28 PM
  #11  
Elite Member
iTrader: (7)
 
samnavy's Avatar
 
Join Date: Apr 2006
Location: Kauai, HI
Posts: 6,267
Total Cats: 220
Default

No boost could be as easy as a coupler leak. Have you gone through the whole charge system and checked all the piping, couplers, clamps?

Also, put your location in your user profile... maybe there's somebody local to you who can come over and take a look.
samnavy is offline  
Old 11-28-2008, 08:34 PM
  #12  
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,765
Total Cats: 676
Default

+1 on blown pipes, although he said it "runs fine". Assuming it actually does, it'd run very poorly with a blown pipe, although give the exactly symptom's he's describing. I had that happen at the track, and I barely made it up to 60mph, and I was a sitting duck until I limped back to the pits.
curly is online now  
Old 11-28-2008, 08:38 PM
  #13  
Elite Member
iTrader: (7)
 
samnavy's Avatar
 
Join Date: Apr 2006
Location: Kauai, HI
Posts: 6,267
Total Cats: 220
Default

Those kits ran on really low boost. He might have a loose coupler that only leaks when pressureized, but seals fine in vaccum.
samnavy is offline  
Old 11-28-2008, 08:42 PM
  #14  
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,824
Total Cats: 269
Default

I heard Yugo was going to use those turbos on their production cars, but they found it didn't meet their reliability standards.
patsmx5 is offline  
Old 11-28-2008, 09:11 PM
  #15  
Boost Czar
iTrader: (62)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 76,398
Total Cats: 2,296
Default

Every Aerocharger fails; yours is no exception.

Call Corky Bell at Bell Engineering and see what he suggests.
Braineack is offline  
Old 11-28-2008, 10:43 PM
  #16  
Elite Member
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,710
Total Cats: 2
Default

I have never heard of Aerocharger.

Is that weird?
Saml01 is offline  
Old 11-28-2008, 11:07 PM
  #17  
Elite Member
iTrader: (3)
 
Mach929's Avatar
 
Join Date: Oct 2004
Location: lansdale PA
Posts: 2,494
Total Cats: 0
Default

aerochargers were self-contained variable vane turbos, cool ****, not the pinnacle of reliablility
Mach929 is offline  
Old 11-28-2008, 11:16 PM
  #18  
Elite Member
iTrader: (8)
 
Join Date: Oct 2007
Location: Dallas
Posts: 1,830
Total Cats: 0
Default

Check your couplers for leaks.
Toddcod is offline  
Old 11-29-2008, 12:10 AM
  #19  
Elite Member
iTrader: (10)
 
rccote's Avatar
 
Join Date: Jan 2008
Posts: 1,582
Total Cats: 18
Default

5.5k for the polaris RZR kit, you've gotta be ******* kidding me. This **** is real shady.
rccote is offline  
Old 11-29-2008, 02:43 PM
  #20  
Newb
Thread Starter
 
Join Date: Nov 2008
Location: ca
Posts: 10
Total Cats: 0
Default

Thanks you guys i really appreciate the quick responses.ill go ahead and check it out.
b00stedmiata is offline  

Thread Tools
Search this Thread
Quick Reply: Aerocharger Turbo No Boost?


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.