BEGI downpipe hitting stuff... - Page 3 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 09-23-2009, 03:34 PM   #41
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,868
Total Cats: 1,790
Default

looooooooosen the wastegate rod.
Braineack is online now   Reply With Quote
Old 09-23-2009, 03:38 PM   #42
Senior Member
iTrader: (6)
 
tyson87's Avatar
 
Join Date: Aug 2008
Location: West Palm Beach, FL
Posts: 1,023
Total Cats: 1
Default

no way... im used to 14lbs....
tyson87 is offline   Reply With Quote
Old 09-23-2009, 03:42 PM   #43
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,868
Total Cats: 1,790
Default

haha. you can still make 14psi, just without creeeep. I was dealing with some major creep and ported my turbine housing myself which helped slightly. then one day i decided to go move the boost source to the coldside of the IC and then lengthen the wastegate rod slightly, like 4-5 turns. made all the difference.
Braineack is online now   Reply With Quote
Old 09-23-2009, 05:52 PM   #44
Junior Member
 
Join Date: Apr 2008
Location: Dallas metroplex
Posts: 142
Total Cats: -1
Default

hustler was at my house trying to help me get a tune in. My newbself did not notice that the wastgate rod was not opening because it was hitting against the dp flange. It took maybe 20 minutes overall of grinding the flange down a bi, but now it's free.
popopopop is offline   Reply With Quote
Old 09-23-2009, 07:00 PM   #45
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by popopopop View Post
hustler was at my house trying to help me get a tune in. My newbself did not notice that the wastgate rod was not opening because it was hitting against the dp flange. It took maybe 20 minutes overall of grinding the flange down a bi, but now it's free.
That should be on failblog. How is your car running? You never email anymore. I'm going to Alamo on Saturday if I need to swing by.
hustler is offline   Reply With Quote
Old 09-24-2009, 04:11 AM   #46
Junior Member
 
Join Date: Apr 2008
Location: Dallas metroplex
Posts: 142
Total Cats: -1
Default

Quote:
Originally Posted by hustler View Post
That should be on failblog. How is your car running? You never email anymore. I'm going to Alamo on Saturday if I need to swing by.
School is killing me, I aim you sometimes but never get any replies so I always felt like a bother. The car did not make it pass 2 psi with the third msq we did, ran fine with the second one. I fixed some minor stuff, going to put the car back together and start reading/messing with the tune some more. I'll be in class all day tomorrow, so oh well. Good luck at Alamo!
popopopop is offline   Reply With Quote
Old 09-30-2009, 12:37 AM   #47
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Location: Seven Valleys, PA
Posts: 639
Total Cats: 11
Default

The spacer plate still has not arrived from BEGi. i hope they sent it.

since the actuator rod was loosened to the point where it was only holding on by two threads, i had my welder guy extend it by about 2/5 of an inch. i can get the car to hold 165kpa now but spool is late. BEGi says this shanghi turbo is roughly the equivalent of a journal bearing 2854. it may not be a 2554, but i was expecting better than 130 kpa @ 4000 rpm in a 6th gear pull.

side note: i would post a datalog if i could clear my attachments. Any idea how to get rid of things that i attached 2 years ago?
swimming108 is offline   Reply With Quote
Old 09-30-2009, 12:40 AM   #48
Elite Member
iTrader: (1)
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 4,682
Total Cats: 216
Default

Quote:
Originally Posted by swimming108 View Post
The spacer plate still has not arrived from BEGi. i hope they sent it.

since the actuator rod was loosened to the point where it was only holding on by two threads, i had my welder guy extend it by about 2/5 of an inch. i can get the car to hold 165kpa now but spool is late. BEGi says this shanghi turbo is roughly the equivalent of a journal bearing 2854. it may not be a 2554, but i was expecting better than 130 kpa @ 4000 rpm in a 6th gear pull.

side note: i would post a datalog if i could clear my attachments. Any idea how to get rid of things that i attached 2 years ago?
Thats basically where Im at, I have my wastegate rod completely disconnected, and I can still build like 10 psi, which is way above where i need to be, not to mention spool is terrible...
Full_Tilt_Boogie is offline   Reply With Quote
Old 09-30-2009, 12:54 AM   #49
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

this is what you get for running an internal gate. TiAL MV-S is the way.
hustler is offline   Reply With Quote
Old 09-30-2009, 01:01 AM   #50
Elite Member
iTrader: (1)
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 4,682
Total Cats: 216
Default

i know, i know
every turbo setup ive ever done has had an external wastegate, and ive never, ever had any boost creep ever.
this is the first time ive ever had an internal wastegate, and its the first time ive bought a kit.
never again....
Full_Tilt_Boogie is offline   Reply With Quote
Old 09-30-2009, 09:08 AM   #51
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Location: Seven Valleys, PA
Posts: 639
Total Cats: 11
Default

Quote:
Originally Posted by hustler View Post
this is what you get for running an internal gate. TiAL MV-S is the way.
Didn't you have an internal wg setup about 6 months ago?

Also, i am a poor college student. surely you can sympathies with that.

The day that i am out of school and have a real job, i will be giving Tim @ Absurdflow a call!!!
swimming108 is offline   Reply With Quote
Old 09-30-2009, 02:29 PM   #52
Former Vendor
 
Join Date: Jun 2006
Location: Bell Tuning & Performance
Posts: 1,338
Total Cats: -78
Default

Quote:
Originally Posted by swimming108 View Post
The spacer plate still has not arrived from BEGi. i hope they sent it.
Shoot me a PM or e-mail with your name and I can check. We have sent out several lately.
Stephanie
Stephanie Turner is offline   Reply With Quote
Old 09-30-2009, 02:30 PM   #53
Former Vendor
 
Join Date: Jun 2006
Location: Bell Tuning & Performance
Posts: 1,338
Total Cats: -78
Default

Quote:
Originally Posted by Full_Tilt_Boogie View Post
i know, i know
every turbo setup ive ever done has had an external wastegate, and ive never, ever had any boost creep ever.
this is the first time ive ever had an internal wastegate, and its the first time ive bought a kit.
never again....
Shoot me an e-mail. We have tested another actuator that worked perfectly. I can swap out yours for a modified one.
Stephanie
Stephanie Turner is offline   Reply With Quote
Old 09-30-2009, 02:55 PM   #54
Senior Member
iTrader: (6)
 
tyson87's Avatar
 
Join Date: Aug 2008
Location: West Palm Beach, FL
Posts: 1,023
Total Cats: 1
Default

Quote:
Originally Posted by Stephanie Turner View Post
Shoot me an e-mail. We have tested another actuator that worked perfectly. I can swap out yours for a modified one.
Stephanie
can i have that acuator too?
tyson87 is offline   Reply With Quote
Old 09-30-2009, 03:16 PM   #55
Former Vendor
 
Join Date: Jun 2006
Location: Bell Tuning & Performance
Posts: 1,338
Total Cats: -78
Default

Sure. I know who you are, so I will get Corky to modify one for you.
Stephanie
Stephanie Turner is offline   Reply With Quote
Old 09-30-2009, 03:28 PM   #56
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,131
Total Cats: 598
Default

Changing an actuator will not help if its still over boosting even at 10psi with the actuator completely disconnected. How far does the gate open with the actuator disconnected? If its hitting, what is hitting will need to be removed/cut, a different actuator wont make the difference. If its not hitting anything but over boosting with the actuator disconnected then the wastegate hole will need to be ported.
triple88a is offline   Reply With Quote
Old 09-30-2009, 03:48 PM   #57
Elite Member
iTrader: (1)
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 4,682
Total Cats: 216
Default

I posted a picture on mnet of how much mine opens. I think it was titled "is my at opening enough". I would go find it now but I'm on my iPod at the moment and I'm lazy.
Full_Tilt_Boogie is offline   Reply With Quote
Old 10-01-2009, 01:18 PM   #58
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Location: Seven Valleys, PA
Posts: 639
Total Cats: 11
Default

pm'd you Stephanie
swimming108 is offline   Reply With Quote
Old 10-02-2009, 03:30 AM   #59
Elite Member
iTrader: (1)
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 4,682
Total Cats: 216
Default

IMGP3493_sm.jpg
yes, I know I need a SS feed line
Full_Tilt_Boogie is offline   Reply With Quote
Old 10-02-2009, 08:07 AM   #60
Senior Member
iTrader: (6)
 
tyson87's Avatar
 
Join Date: Aug 2008
Location: West Palm Beach, FL
Posts: 1,023
Total Cats: 1
Default

Looks to about 60-75% open.
tyson87 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 58 Yesterday 10:04 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
1996 Turbo Build Goldwar DIY Turbo Discussion 2 09-29-2015 10:20 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:22 PM.