Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

car wont start after greddy install...

 
Old 07-07-2012, 11:49 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Apr 2012
Posts: 182
Total Cats: -3
Default car wont start after greddy install...

So I just installed a greddy kit on my 90 1.6... went to start it and it sounds like no spark.. I can smell fuel, so that leads me to spark as well... I haven't pulled the plug wires to see if they arc yet though..

Here's the other reason why I think spark... the other night I was a dumb ***.. working on the car while pissed off, I tapped into the ignitor signal (wht/ylw) on the ecu for the o2 clamp and wideband instead of the +12v(wht/red).. could I have fried my ecu or ignitor? Or am I overlooking something stupid?
nperkins is offline  
Old 07-07-2012, 01:34 PM
  #2  
Junior Member
 
Join Date: Aug 2011
Posts: 172
Total Cats: 0
Default

start by removing the plugs and check if they spark... Is there any friend close to you who has a 1.6l miata?? You could swap ignitors/ecu to troubleshoot. If the injectors are pulsing, you ecu is functional. Double check your wiring or soldering job you've done on your ECU wiring...

Work with your head cooled down, you'll be more focused at your tasks. Like racing, anger will send you into the wall or grass...
mr.na is offline  
Old 07-07-2012, 02:23 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Apr 2012
Posts: 182
Total Cats: -3
Default

Yeah I'm getting a spare ignitor and ecu from a buddy tomorrow night but I was hoping to have it running today..

My ecu wiring is good now. It was just me not paying attention and grabbing the wrong wire to splice like an idiot. I should have realized it when it was smaller gauge than what I was expecting for a power wire, but too late now.

The check engine light comes on w key on, so I know ecu has power..
nperkins is offline  
Old 07-07-2012, 02:30 PM
  #4  
Newb
 
Join Date: Jan 2012
Posts: 16
Total Cats: -1
Default

Damn, well good luck man! Electric issues are horrible..
hahajoey is offline  
Old 07-07-2012, 02:52 PM
  #5  
Junior Member
Thread Starter
 
Join Date: Apr 2012
Posts: 182
Total Cats: -3
Default

Yeah it just frustrates me. Electrical is my specialty.. I've built full engine harnesses from scratch and had zero issues first time, people come to me for their wiring.. I go to hook up simple power and ground in my own car and screw it up lol
nperkins is offline  
Old 07-07-2012, 06:53 PM
  #6  
Newb
 
Join Date: Jan 2012
Posts: 16
Total Cats: -1
Default

One of my buddies didn't clip in the ecu plug all the way in after days of torture.. It's just one of those things.
hahajoey is offline  
Old 07-07-2012, 07:15 PM
  #7  
Junior Member
Thread Starter
 
Join Date: Apr 2012
Posts: 182
Total Cats: -3
Default

Never mind. Apparently it was just grumpy. Checked spark had spark put it back feathered the gas while cranking and she runs.

God I missed boost..
nperkins is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
elesjuan
Build Threads
9
11-14-2018 12:18 PM
ReallyRottenTurbo
MEGAsquirt
4
09-22-2015 12:49 PM
Dobzeh
ECUs and Tuning
5
09-17-2015 02:56 PM
JesseTheNoob
WTB
4
09-11-2015 01:25 PM
shanesauce
General Miata Chat
1
09-06-2015 08:47 PM


Thread Tools
Search this Thread
Quick Reply: car wont start after greddy install...


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.