cruise control - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 07-23-2006, 09:13 PM   #1
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2006
Location: Nashville, TN
Posts: 406
Total Cats: 0
Default cruise control

well i put my kit on yesterday and I hit a snag, my cruise control is in the way of my intake piping that goes to the MAF, do i have to remove the cruise control for this kit to work? I dont see any other way around it, need an answer quick so i can go drive
BrokeEnthusiast is offline   Reply With Quote
Old 07-23-2006, 09:18 PM   #2
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2006
Location: Nashville, TN
Posts: 406
Total Cats: 0
Default

by the way my enthuza exhaust will be here wed. so Im going to be driving open DP hahaha
BrokeEnthusiast is offline   Reply With Quote
Old 07-23-2006, 09:33 PM   #3
Junior Member
 
Join Date: Jan 2005
Location: MO
Posts: 60
Total Cats: 0
Default

Is the cruise kit just a stock one from another Miata? I have cruise on my car and I had to take off one of the bolts that hold it on and twist it out of the way of the pipes. I think I have some underhood pics in the members rides part of the forum. Might help.
flashlegs is offline   Reply With Quote
Old 07-23-2006, 09:37 PM   #4
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2006
Location: Nashville, TN
Posts: 406
Total Cats: 0
Default

please post the pictures, its the cruise control that came on the car stock
BrokeEnthusiast is offline   Reply With Quote
Old 07-23-2006, 09:41 PM   #5
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2006
Location: Nashville, TN
Posts: 406
Total Cats: 0
Default

well it looks like you got it to fit right behind the headlight very well, im gonna give it another shot
BrokeEnthusiast is offline   Reply With Quote
Old 07-23-2006, 10:19 PM   #6
Junior Member
iTrader: (1)
 
that7guy's Avatar
 
Join Date: Apr 2005
Location: Bethesda, MD
Posts: 428
Total Cats: 7
Default

Mine fit with the stock cc fine. Since then i have taken it out. Do you really need it? heres an old picture if you still need help:

Last edited by that7guy; 10-08-2006 at 03:16 PM.
that7guy is offline   Reply With Quote
Old 07-23-2006, 11:28 PM   #7
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2006
Location: Nashville, TN
Posts: 406
Total Cats: 0
Default

I dont really need it, I got it to go into place but its line runs right past the exhaust manifold, so If it doesnt melt then I guess its gonna be okay. I guess I will take it out when I get my IC only because I will be moving some more things around and all I want to do right now is break the turbo in
BrokeEnthusiast is offline   Reply With Quote
Old 07-23-2006, 11:59 PM   #8
Junior Member
 
Join Date: Jun 2006
Posts: 166
Total Cats: 0
Default

I didn't have problems getting my greddy kit to fit w/ the cruise on my 92 miata, however when I tried to run the cruise the car would just keep on accelerating. It worked fine before I installed the turbo, but I was on the interstate a few days after I put my turbo in and I tried the cruise. It accelarated as normal to get back to the speed I was going when I first activated it, but then it kept accelerating. I put the clutch in and of course it just kept bouncing off the rev limiter. I think that it has something to do with there being boost where ther is normally vacuum and it tripped something in the cruise. I had to disconnect the vacuum line from the cruise control unit in order for it to stop accelerating. Otherwise it just keeps bouncing off the rev limiter everytime I start my car after I have tried to use the cruise
92mazdarati is offline   Reply With Quote
Old 07-24-2006, 01:46 AM   #9
Elite Member
iTrader: (14)
 
Join Date: Mar 2006
Location: Edmonton, AB
Posts: 4,921
Total Cats: 0
Default

Putting a check valve in the vacuum line to the CC actuator might help. Also the cruise should kick off when you put in the clutch. Replace the clutch switch, if you are having trouble with idle dip or stalling this will also help.

You should never be able to enter boost with the CC on, so it should work normally (with out the check valve).

Sounds like your actuator is FUBAR, or something is stuck.
jayc72 is offline   Reply With Quote
Old 07-25-2006, 03:12 AM   #10
ruger988
Guest
 
Posts: n/a
Total Cats: 0
Default

Quick notes on removing CC? instaled my greddy kit today andit's just kinda layng there outta the way for now until i rip it out tomorrow!!!
  Reply With Quote
Old 07-25-2006, 02:20 PM   #11
Senior Member
iTrader: (7)
 
Join Date: Mar 2005
Location: VT
Posts: 939
Total Cats: 0
Default

Quote:
Originally Posted by jayc72
You should never be able to enter boost with the CC on, so it should work normally (with out the check valve).
W/ the CC on, the car should still enter boost.
Jefe is offline   Reply With Quote
Old 07-25-2006, 02:36 PM   #12
Elite Member
iTrader: (14)
 
Join Date: Mar 2006
Location: Edmonton, AB
Posts: 4,921
Total Cats: 0
Default

Maybe I wasn't clear what I meant. While USING the CC you wouldn't likely get into boost since the throttle wouldn't open enough. Since I don't have mine on the car any more I can't confirm that, but that was my understanding.

I know on my cruise using the accelerate toggle on the steering column it would accelerate VERY slowly.
jayc72 is offline   Reply With Quote
Old 07-25-2006, 03:16 PM   #13
Elite Member
 
Philip's Avatar
 
Join Date: Dec 2004
Posts: 3,270
Total Cats: -4
Default

Quote:
Originally Posted by Jefe
W/ the CC on, the car should still enter boost.
Mine never would, even with a check valve it would pull it right up to 0 PSI and then stop.
Philip is offline   Reply With Quote
Old 07-27-2006, 06:45 PM   #14
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2006
Location: Nashville, TN
Posts: 406
Total Cats: 0
Default

ok well i am going to remove it this weekend, do i just cut the cable and pull it out, and plug the vaccume line or what?
BrokeEnthusiast is offline   Reply With Quote
Old 07-27-2006, 06:46 PM   #15
Elite Member
 
Philip's Avatar
 
Join Date: Dec 2004
Posts: 3,270
Total Cats: -4
Default

you can take the cable out in tact, it just unclips from the gas pedal and pulls through the firewall. Probably worth a few bucks to someone with a melted cable
Philip is offline   Reply With Quote
Old 07-27-2006, 07:28 PM   #16
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2006
Location: Nashville, TN
Posts: 406
Total Cats: 0
Default

i heard that you need to swap pedals after you do this is that true?
BrokeEnthusiast is offline   Reply With Quote
Old 07-27-2006, 08:02 PM   #17
Junior Member
 
Join Date: Nov 2005
Location: PA/DC
Posts: 468
Total Cats: 0
Default

I still have my CC and everything fits and works fine. It still enters boost with CC on. Goodluck.
Snowsurfer03 is offline   Reply With Quote
Old 07-27-2006, 08:12 PM   #18
Senior Member
iTrader: (14)
 
brgracer's Avatar
 
Join Date: Nov 2004
Location: Ambler, PA
Posts: 1,275
Total Cats: 1
Default

Quote:
Originally Posted by BrokeEnthusiast
i heard that you need to swap pedals after you do this is that true?
Not true. I removed my CC intact and sold it on fleabay for ~$100 so I'd listen to Phillip about removing it whole instead of just cutting and removing. Never switched pedals and never had any issues, even with bending the pedal toward the brake for better heel/toe access. YMMV.
brgracer is offline   Reply With Quote
Old 07-28-2006, 02:07 PM   #19
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2006
Location: Nashville, TN
Posts: 406
Total Cats: 0
Default

sweet, i need cash so I am going to sell it on ebay when i take it out
BrokeEnthusiast is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Another Cast Manifold Corky Bell Prefabbed Turbo Kits 18 11-22-2016 10:01 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
1991 special edition with hard top full part out JC, NJ russian Miata parts for sale/trade 6 10-08-2015 04:01 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 11:44 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:24 AM.