Geddy is installed - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 10-23-2006, 04:11 AM   #1
Senior Member
Thread Starter
 
boostinsteve's Avatar
 
Join Date: Oct 2006
Location: Honolulu, HI
Posts: 563
Total Cats: 0
Default Geddy is installed

I got the greddy installed today, now just have to try to find all of the leaks. It seems like it is extremely laggy. I will try it again later tommorrow. I have the ISC that is bad and waiting for parts to come in, so that may be part of the problem, but I will wait and see. I will keep you guys updated. The highest boost that I saw was 3psi on my autometer gage. Can't wait to get the emanage fully tuned and be ready to kick it into high gear.
boostinsteve is offline   Reply With Quote
Old 10-23-2006, 04:12 AM   #2
Senior Member
Thread Starter
 
boostinsteve's Avatar
 
Join Date: Oct 2006
Location: Honolulu, HI
Posts: 563
Total Cats: 0
Default

I would just like to say that it is extremely hard to type when you have been drinking all day.
boostinsteve is offline   Reply With Quote
Old 10-23-2006, 09:53 AM   #3
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,787
Default

you did a pretty good job of it!
Braineack is online now   Reply With Quote
Old 10-23-2006, 10:03 AM   #4
Senior Member
iTrader: (14)
 
brgracer's Avatar
 
Join Date: Nov 2004
Location: Ambler, PA
Posts: 1,275
Total Cats: 1
Default

You might need to tighten up that wastegate arm a bit as it might loose and causing both the low boost and laggy feel.
brgracer is offline   Reply With Quote
Old 10-23-2006, 11:07 AM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,787
Default

just go back in and tighten everything in general. turbo/manifold/dp, couplers, etc. Double check the vacuum lines.
Braineack is online now   Reply With Quote
Old 10-23-2006, 01:12 PM   #6
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

just sober up i bit before you taker out though. and check a retighten everything.
magnamx-5 is offline   Reply With Quote
Old 10-23-2006, 01:57 PM   #7
Senior Member
Thread Starter
 
boostinsteve's Avatar
 
Join Date: Oct 2006
Location: Honolulu, HI
Posts: 563
Total Cats: 0
Default

Yeah, I need to go get some new hose clamps. Broke a few of them. Also I tightened down the wastegate arm. The computer threw code 34 still, just windering if you guys think that the ISC system can cause a slight hesitation at the lower rpms when I floor it. The emanage is being a bastard still. I think I will write greddy and see what they say the reason could be for both lights being on at once. Took olderguy's advice, and took the switches to 0, and the lights are both still on. Only the active light is supposed to be on when the laptop is not hooked up. Thanks for all the support guys, once I get all of the little things taken care of, I feel more power is on its way.
boostinsteve is offline   Reply With Quote
Old 10-23-2006, 09:04 PM   #8
Junior Member
 
Join Date: Jan 2005
Location: MO
Posts: 60
Total Cats: 0
Default

I had the dreaded 3psi when I got my Greddy on too. I looked for a leak for a couple months before I added a check valve on the line going to the charcoal canister. And I would recammend some tbolt clamps cause I have a real bad problem with breaking the cheap clamps too.
flashlegs is offline   Reply With Quote
Old 10-23-2006, 09:07 PM   #9
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

yeah recheck the install
magnamx-5 is offline   Reply With Quote
Old 10-23-2006, 09:08 PM   #10
Senior Member
 
Join Date: May 2005
Location: San Francisco
Posts: 547
Total Cats: 0
Default

Quote:
Originally Posted by flashlegs View Post
I had the dreaded 3psi when I got my Greddy on too. I looked for a leak for a couple months before I added a check valve on the line going to the charcoal canister. And I would recammend some tbolt clamps cause I have a real bad problem with breaking the cheap clamps too.
so what was the problem in your case?
turbored is offline   Reply With Quote
Old 10-24-2006, 08:40 PM   #11
Junior Member
 
Join Date: Jan 2005
Location: MO
Posts: 60
Total Cats: 0
Default

Boost leak at the Charcaol canister. The check valve I added at the vacuum line going to it got my boost up to where it was suppost to be(6psi at the time).
flashlegs is offline   Reply With Quote
Old 10-24-2006, 09:16 PM   #12
Senior Member
Thread Starter
 
boostinsteve's Avatar
 
Join Date: Oct 2006
Location: Honolulu, HI
Posts: 563
Total Cats: 0
Default

Did you pick that check valve up at home depot?
boostinsteve is offline   Reply With Quote
Old 10-24-2006, 10:02 PM   #13
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,438
Total Cats: 84
Default

Any auto parts store will have them. If no auto parts stores around, try a fish aquarium place.
olderguy is offline   Reply With Quote
Old 10-24-2006, 10:29 PM   #14
Junior Member
 
Join Date: Jan 2005
Location: MO
Posts: 60
Total Cats: 0
Default

I got it at a autoparts store. You should be able to find one locally. If you can't, let me know and I could go get you one locally here. You'll have to pay for it, but I won't charge you extra or anything.
flashlegs is offline   Reply With Quote
Old 10-25-2006, 02:18 AM   #15
Senior Member
Thread Starter
 
boostinsteve's Avatar
 
Join Date: Oct 2006
Location: Honolulu, HI
Posts: 563
Total Cats: 0
Default

I'll go and try to find one tommorrow. Thanks for the input man. I am sure that even if that is not the problem, it is cheap and will give some insurance later on, even though it makes sense. Thanks guys.
boostinsteve is offline   Reply With Quote
Old 10-25-2006, 02:25 AM   #16
Senior Member
 
Join Date: Mar 2006
Location: Ireland
Posts: 534
Total Cats: 0
Default

Got any pic of that valve in place ?
I'm down a little on boost for a while now and can't find any leaks in the piping etc.
Actually, it feels as if it's down at 3psi......AGH!
Fergus is offline   Reply With Quote
Old 10-25-2006, 02:49 AM   #17
Senior Member
Thread Starter
 
boostinsteve's Avatar
 
Join Date: Oct 2006
Location: Honolulu, HI
Posts: 563
Total Cats: 0
Default

This seems to be a pretty common problem, we should try to get an article written and archived after we get that pic. 3psi for a lot of people hmmm. I will try to get mine in tommorrow, and then I will reply back about the results. Also, has anyone ever used those ebay turbo rebuild kits. I want to find an extra turbo, rebuild it, and have an extra turbo around.

Last edited by boostinsteve; 10-25-2006 at 03:10 AM.
boostinsteve is offline   Reply With Quote
Old 10-25-2006, 07:07 AM   #18
Junior Member
 
Join Date: Nov 2005
Location: PA/DC
Posts: 468
Total Cats: 0
Default

What did you set your timing at? Tightening the wastegate helps a lot but the biggest fix for "lag" is to up your timing via bipes and/or water injection!
Taking care of the lag increases fun factor X100!!! Goodluck!
Snowsurfer03 is offline   Reply With Quote
Old 10-25-2006, 09:59 AM   #19
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,787
Default

you can by a check valve in the automotive "help" section of any auto parts store. (those red packages with HELP! on them)

here:



I'll add it to the faq.
Braineack is online now   Reply With Quote
Old 10-25-2006, 05:59 PM   #20
Junior Member
 
Join Date: Jan 2005
Location: MO
Posts: 60
Total Cats: 0
Default

https://www.miataturbo.net/forums/sh...heck+valve+pic

Here's a old thread with another pic of the valve. I think down about half way.
flashlegs is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:15 PM.