Glowing turbo and 3psi? - Page 2 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 06-14-2007, 11:25 AM   #21
Elite Member
iTrader: (14)
 
Join Date: Mar 2006
Location: Edmonton, AB
Posts: 4,921
Total Cats: 0
Default

I thought that the link was pulling piles of timing because of knock?
jayc72 is offline   Reply With Quote
Old 06-14-2007, 06:31 PM   #22
Ole
Junior Member
Thread Starter
 
Join Date: Apr 2007
Location: Bergen, Norway
Posts: 110
Total Cats: 0
Default

today i sat the timing to 8 deg. slacked the wg as much i could without getting any slack and rattle.. now my pressure shows almost 3 psi. and my nb a/f meter stays stable at stoich at wot (about 2 leds from the green rich leds). however it glows when i pull over after draging through 1,2 and 3rd and if i stay wot up a hill in 4 or 5th with full boost.. I don't know what else to do.. :(
Ole is offline   Reply With Quote
Old 06-14-2007, 06:39 PM   #23
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,809
Total Cats: 1,780
Default

so one line under the 10° mark, correct.

if timing is good, then fuel is lean.

2 LED rich is like 13.8:1 AFR....you need more fuel.

Braineack is offline   Reply With Quote
Old 06-14-2007, 07:20 PM   #24
Ole
Junior Member
Thread Starter
 
Join Date: Apr 2007
Location: Bergen, Norway
Posts: 110
Total Cats: 0
Default

so 2 leds from the green field is lean.. :( what can i do? do you think it will help to get some 1.8 injectors? what else do i need? I am thinkin of getting the aem wide band kit that they sell at flyinmiata for 305 USD.. is that any good? sorry for all the questions.. just total noob in miata boosting and i want to keep my pistons in one piece..
Ole is offline   Reply With Quote
Old 06-14-2007, 07:23 PM   #25
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,809
Total Cats: 1,780
Default

what are you doing for fuel? stock greddy kit with FMU? or that silly black box?

and yeah, I fi converted the numbers correctly based off a stock o2 sensor, the output on a 20 LED narrowband gauge should be something like that; .8v to .20v is 14.7:1, which as tyou can tell is nowhere near linear, which is why narrowband gauges are very hard to tune off.
Braineack is offline   Reply With Quote
Old 06-14-2007, 07:44 PM   #26
Ole
Junior Member
Thread Starter
 
Join Date: Apr 2007
Location: Bergen, Norway
Posts: 110
Total Cats: 0
Default

I have the vortec.. not the black box..
Ole is offline   Reply With Quote
Old 06-14-2007, 08:23 PM   #27
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

Well something is wrong check the fuel pressure pull the plugs and inspect them. If you are truly at 8 btdc it should not glow significantly at 3 psi. Also you should make better than 3 psi as well you might also still have a leak that is blowing off with pressure kinda like a whoopy cushion this would over work your turbo and cause the glowing and low pressure. Did you clock the turbo i had compressor leak that acted like that.
magnamx-5 is offline   Reply With Quote
Old 06-14-2007, 09:20 PM   #28
Elite Member
iTrader: (1)
 
Join Date: Jun 2005
Location: Charleston, SC
Posts: 2,980
Total Cats: 14
Default

Quote:
Originally Posted by jayc72 View Post
I thought that the link was pulling piles of timing because of knock?
Yes, lots of stuff:

too much psi
not enough fuel
small turbo
tons of knock
rmcelwee is offline   Reply With Quote
Old 06-14-2007, 10:19 PM   #29
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,809
Total Cats: 1,780
Default

Quote:
Originally Posted by Ole View Post
I have the vortec.. not the black box..

if anything you should be rich at wastegate pressures....maybe you hooked it up wrong?
Braineack is offline   Reply With Quote
Old 06-15-2007, 01:55 AM   #30
Ole
Junior Member
Thread Starter
 
Join Date: Apr 2007
Location: Bergen, Norway
Posts: 110
Total Cats: 0
Default

I checked the vortec, and it's mounted right.. what do you mean by clock the turbo? how can i easily check for boost leak?
Ole is offline   Reply With Quote
Old 06-15-2007, 02:02 AM   #31
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Quote:
Originally Posted by Ole View Post
so 2 leds from the green field is lean.. :( what can i do? do you think it will help to get some 1.8 injectors? what else do i need? I am thinkin of getting the aem wide band kit that they sell at flyinmiata for 305 USD.. is that any good? sorry for all the questions.. just total noob in miata boosting and i want to keep my pistons in one piece..
You can get the Innovate or AEM for less than $300 shipped on this board via a couple members. Wideopentuning sells them cheaper than FM and offers great service. I personally have the AEM, it works great and is very easy to install. I recommend it. You can find his information in member discount area of the For sale section.
cjernigan is offline   Reply With Quote
Old 06-15-2007, 04:04 AM   #32
Elite Member
iTrader: (1)
 
Join Date: Jun 2005
Location: Charleston, SC
Posts: 2,980
Total Cats: 14
Default

I paid $175 for my LC-1.
rmcelwee is offline   Reply With Quote
Old 06-15-2007, 04:56 AM   #33
Ole
Junior Member
Thread Starter
 
Join Date: Apr 2007
Location: Bergen, Norway
Posts: 110
Total Cats: 0
Default

Quote:
Originally Posted by rmcelwee View Post
I paid $175 for my LC-1.
But I also nead a gauge? I only have a Jacson Racing narrow band now.... :(
Ole is offline   Reply With Quote
Old 06-15-2007, 09:22 AM   #34
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,809
Total Cats: 1,780
Default

you can use that gauge. Since the LC-1 has programable outputs, instead of the gauge displaying results like above.

You can display your AFR like this:
Braineack is offline   Reply With Quote
Old 06-15-2007, 04:53 PM   #35
Junior Member
 
Join Date: Oct 2004
Location: Windsor, Canada
Posts: 191
Total Cats: -2
Default

Quote:
Originally Posted by Ole View Post
But I also nead a gauge? I only have a Jacson Racing narrow band now.... :(
Use the narrowband...you can just program the output for 0-1v
MiataNuTca is offline   Reply With Quote
Old 06-15-2007, 09:28 PM   #36
Elite Member
iTrader: (1)
 
Join Date: Jun 2005
Location: Charleston, SC
Posts: 2,980
Total Cats: 14
Default

Quote:
Originally Posted by Ole View Post
But I also nead a gauge? I only have a Jacson Racing narrow band now.... :(
A digital gauge is only $7 (look at my site)...
rmcelwee is offline   Reply With Quote
Old 06-15-2007, 09:39 PM   #37
Junior Member
 
Join Date: May 2007
Location: NC
Posts: 246
Total Cats: 0
Default

FYI: I had glowing turbo and good A/F numbers, running 12.5 under boost and stoic in normal driving and turned out timing belt had slipped by 8-10 degrees retard!! Make sure your timing is happy and don't run stoic under boost :-) I also run the AEM UEGO wideband (a good wideband is critical not to mention cheaper than a new engine).
mtncrvr is offline   Reply With Quote
Old 06-18-2007, 12:15 PM   #38
Ole
Junior Member
Thread Starter
 
Join Date: Apr 2007
Location: Bergen, Norway
Posts: 110
Total Cats: 0
Default

I just ordered 1.8 injectors from E-bay. Maybe that will do it?
Ole is offline   Reply With Quote
Old 06-18-2007, 01:41 PM   #39
Senior Member
 
Join Date: Dec 2004
Posts: 1,450
Total Cats: -1
Default

No, that likely won't fix your problem, although it might help mask it...you should be able to run 5-6 PSI with the stock 1.6L injectors.

You have a problem that needs to be diagnosed and fixed before you just start randomly throwing parts at it.
bripab007 is offline   Reply With Quote
Old 06-18-2007, 01:48 PM   #40
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,809
Total Cats: 1,780
Default

BUT....having the 1.8L injectors isn't a bad idea. But like Brian said, you still need to find the cause.
Braineack is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
ISO 1.6 turbo cast iron manifold cale saurage DIY Turbo Discussion 16 10-01-2015 12:25 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:05 AM.