Greddy installed, few issues - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 11-14-2008, 09:09 PM   #1
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Nov 2008
Posts: 227
Total Cats: -14
Default Greddy installed, few issues

I had my mechanic install the greddy kit. I got home and checked the timing, it looks like its already retarded 5 or 6 degrees from 10. (Toward the "T")

I haven't gone over 4000rpm since it needs the break in period, but I've gone full throttle and shifted at 4000- it makes a noise that almost sounds like change in a tin can. I've heard thats what pinging sounds like - but its already retarded. Could the mark on my pulley be incorrect? I am sure it says its at 4 or 5 btdc. If anyone can help I'd greatly appreciate it.
linuxbox is offline   Reply With Quote
Old 11-14-2008, 09:25 PM   #2
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Lexington, SC
Posts: 2,084
Total Cats: 0
Default

it could be that or I believe the wastegate arm rattles on greddy kits as well
mazda/nissan is offline   Reply With Quote
Old 11-14-2008, 09:54 PM   #3
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Nov 2008
Posts: 227
Total Cats: -14
Default

It does sound like a rattle more than anything, how can I fix this? How can I be sure that is what this is?
linuxbox is offline   Reply With Quote
Old 11-14-2008, 10:17 PM   #4
Senior Member
iTrader: (14)
 
Join Date: Aug 2008
Location: Tinley Park, IL
Posts: 1,488
Total Cats: 0
Default

How much boost?

Did you use an adjustable timing light? If so, was it zeroed?

Does it do it only in deceleration between 3500-2000 rpm? Could be the infamous trans rattle.
lordrigamus is offline   Reply With Quote
Old 11-14-2008, 10:21 PM   #5
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Nov 2008
Posts: 227
Total Cats: -14
Default

No, only when I hit 4000rpm, haven't gone past it. I'm thinking it could be my afm since its kind of floating on the fender - I'll try throwing some foam under it and see if the noise continues. I know what you mean with the trans whine, its not that. Thanks for the help so far guys.
linuxbox is offline   Reply With Quote
Old 11-14-2008, 10:31 PM   #6
Senior Member
iTrader: (14)
 
Join Date: Aug 2008
Location: Tinley Park, IL
Posts: 1,488
Total Cats: 0
Default

It could be anything. Some noises are hard to diagnose.
lordrigamus is offline   Reply With Quote
Old 11-14-2008, 11:16 PM   #7
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Nov 2008
Posts: 227
Total Cats: -14
Default

Does the turbo sound loud after 4000rpm normally or at least when its breaking in? Is it supposed to sound not at smooth once you get over 4k? It sounds like the car normally sounds when you get above 4000rpm but its more noticeable now. Its hard to describe.
linuxbox is offline   Reply With Quote
Old 11-14-2008, 11:29 PM   #8
Senior Member
iTrader: (14)
 
Join Date: Aug 2008
Location: Tinley Park, IL
Posts: 1,488
Total Cats: 0
Default

You might hear a slight whine from it spinning, but it shouldn't be real noisy. Not a rattling noise anyway. Does it boost up smooth to the wasegate psi and hold it?
lordrigamus is offline   Reply With Quote
Old 11-14-2008, 11:39 PM   #9
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Nov 2008
Posts: 227
Total Cats: -14
Default

There is no boost gauge installed yet, so I don't know. But its fine up till 4k then it makes the noise, but it doesn't do it when i accelerate very slowly up to 4k. I can't find any other rattles under the hood - only seems to do it when its under load.
linuxbox is offline   Reply With Quote
Old 11-15-2008, 02:05 AM   #10
Senior Member
iTrader: (8)
 
turbobluemiata's Avatar
 
Join Date: Aug 2006
Location: Springfield, IL
Posts: 1,019
Total Cats: 0
Default

just tighten the wastegate rod a few turns....
turbobluemiata is offline   Reply With Quote
Old 11-15-2008, 02:17 AM   #11
Elite Member
iTrader: (9)
 
Join Date: Aug 2006
Location: Concord, North Carolina
Posts: 4,173
Total Cats: 5
Default

Quote:
Originally Posted by turbobluemiata View Post
just tighten the wastegate rod a few turns....
Generally solves a majority of the problems.
miatamania is offline   Reply With Quote
Old 11-15-2008, 02:32 AM   #12
Elite Member
iTrader: (24)
 
Join Date: Jul 2007
Location: Cypress, TX
Posts: 3,778
Total Cats: 35
Default

Tighten the wastegate actuator rod just until it's tight and doesn't rattle.

Also, there is no reason for a break-in period. I boosted out of my driveway when I installed my Greddy kit.
Bryce is offline   Reply With Quote
Old 11-15-2008, 08:13 AM   #13
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Nov 2008
Posts: 227
Total Cats: -14
Default

The rod does move on the arm that has the pin - though it moves side to side and I don't see a way to stop that... I'll try tightening it a little bit - maybe if its tighter it won't move side to side.
linuxbox is offline   Reply With Quote
Old 11-15-2008, 09:27 AM   #14
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Nov 2008
Posts: 227
Total Cats: -14
Default

Ah it was the wastegate actuator! Thanks for your help guys! Too bad I can't even really feel the turbo since as soon as I get over 4500rpm the tires just slide. (Its been raining here for like two days)
linuxbox is offline   Reply With Quote
Old 11-15-2008, 12:37 PM   #15
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

Quote:
Originally Posted by linuxbox View Post
as soon as I get over 4500rpm the tires just slide. (Its been raining here for like two days)

I was about to throw out the BS flag.
Braineack is offline   Reply With Quote
Old 11-15-2008, 02:21 PM   #16
Senior Member
iTrader: (8)
 
turbobluemiata's Avatar
 
Join Date: Aug 2006
Location: Springfield, IL
Posts: 1,019
Total Cats: 0
Default

maybe if hes running bald 185's
turbobluemiata is offline   Reply With Quote
Old 11-15-2008, 02:27 PM   #17
Supporting Vendor
iTrader: (3)
 
Join Date: Jul 2006
Location: San Diego
Posts: 2,863
Total Cats: 485
Default

haha I was about to call BS too but the wet can do that! My greddy setup at 6 psi isn't enough to break the traction from a roll (I don't launch).
ThePass is online now   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:07 PM.