Guys I Really need your help - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 10-04-2006, 11:44 PM   #1
Guest
Thread Starter
 
Join Date: Mar 2006
Location: So Cal
Posts: 407
Total Cats: 0
Default Guys I Really need your help

I tried searching and was unsuccessful. I cant get my MBC to work. I have a 90 miata with a greddy kit with a starion FMIC and greddy downpipe with a test pipe and a catback. I cant even boost 5 psi on the stock waste gate. The most i've ever boosted is 3-4 psi. So i figured I should add a manual boost controller to boost a consistent 5 psi atleast. Anyways, I have it mounted just like this picture

http://www.geocities.com/chmwatson/F...cschematic.jpg

My question is, I have the wastegate actuators line coming to the MBC and I need to know, what happens with the spot the other end of it used to be at. by the turbo area. I tried it and my car boosts about 3 psi with the MBC tightened all the way and open all the way. Any help ?
krayzrac3r is offline   Reply With Quote
Old 10-04-2006, 11:52 PM   #2
Junior Member
 
Join Date: Nov 2005
Location: PA/DC
Posts: 468
Total Cats: 0
Default

you sure your boost gauge is reading correctly? I've never heard of the greddy kit only getting 3psi!
Did you tighten your wastegate arm?
What type of MBC is it?
Snowsurfer03 is offline   Reply With Quote
Old 10-04-2006, 11:53 PM   #3
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,438
Total Cats: 84
Default

What did you do with the nipple on the compressor that would normally feed the wastegate actuator?
olderguy is offline   Reply With Quote
Old 10-05-2006, 12:01 AM   #4
Guest
Thread Starter
 
Join Date: Mar 2006
Location: So Cal
Posts: 407
Total Cats: 0
Default

olderguy i didnt have a nipple on the compressor, its still left open and the mbc is some no name brand that a friend gave to me. The gold looking ones. Waste gate arm is tightened all the way. Its tightened towards the wastegate actuator.
krayzrac3r is offline   Reply With Quote
Old 10-05-2006, 12:07 AM   #5
Elite Member
iTrader: (3)
 
Mach929's Avatar
 
Join Date: Oct 2004
Location: lansdale PA
Posts: 2,500
Total Cats: 0
Default

ok take a regular hose and connect it between the compressor housing and the wastegate actuator with no MBC
Mach929 is offline   Reply With Quote
Old 10-05-2006, 12:12 AM   #6
Guest
Thread Starter
 
Join Date: Mar 2006
Location: So Cal
Posts: 407
Total Cats: 0
Default

it was already like that before and i couldnt get more than 3 psi.
krayzrac3r is offline   Reply With Quote
Old 10-05-2006, 12:13 AM   #7
Elite Member
iTrader: (3)
 
Mach929's Avatar
 
Join Date: Oct 2004
Location: lansdale PA
Posts: 2,500
Total Cats: 0
Default

then something else is the problem, at this point you shouldn't be messing with a boost controller
Mach929 is offline   Reply With Quote
Old 10-05-2006, 12:16 AM   #8
Elite Member
iTrader: (3)
 
Mach929's Avatar
 
Join Date: Oct 2004
Location: lansdale PA
Posts: 2,500
Total Cats: 0
Default

make sure you have no vacuum leaks
make sure your boost/vac gauge is working properly with no kinks in the line
no exhaust leaks
wastegate closing completely, not obstructed
wastegate actuator possibly damaged(unsure how to test this)
Mach929 is offline   Reply With Quote
Old 10-05-2006, 12:20 AM   #9
Junior Member
 
Join Date: Nov 2005
Location: PA/DC
Posts: 468
Total Cats: 0
Default

I 2nd Mach929.

Only 3psi? Something isn't gravy?
Snowsurfer03 is offline   Reply With Quote
Old 10-05-2006, 12:20 AM   #10
Guest
Thread Starter
 
Join Date: Mar 2006
Location: So Cal
Posts: 407
Total Cats: 0
Default

as far as a vacuum leak goes im pretty sure there is none because my boost gauge shows about 19-20 in vacuum at idle
krayzrac3r is offline   Reply With Quote
Old 10-05-2006, 12:23 AM   #11
Elite Member
iTrader: (3)
 
Mach929's Avatar
 
Join Date: Oct 2004
Location: lansdale PA
Posts: 2,500
Total Cats: 0
Default

it is still possbile to get a boost leak when you don't have a vacuum leak.
Mach929 is offline   Reply With Quote
Old 10-05-2006, 12:25 AM   #12
Elite Member
iTrader: (3)
 
Mach929's Avatar
 
Join Date: Oct 2004
Location: lansdale PA
Posts: 2,500
Total Cats: 0
Default

do yourself a favor and try a new gauge, maybe borrow one from someone. you don't want to drive yourself nuts over a gauge issue
Mach929 is offline   Reply With Quote
Old 10-05-2006, 04:09 AM   #13
Guest
Thread Starter
 
Join Date: Mar 2006
Location: So Cal
Posts: 407
Total Cats: 0
Default

well im sure its not the gauge because if my boost gauge is open all the way it means i should be boosting well over 10 psi. And im not going over 3psi. And im sure I'd be able to tell the difference in pull between 10 psi and 3psi. And on a side note, right now i went on the freeway and in 3rd and 4th gear i was hitting 5 psi holding till redline. But i wouldnt hit 5 psi until over 5K rpms. Its like an insane LAG. I boost 1-2 psi up until 4k then after that on the freeway 3rd-5th gears boost 5 psi.
krayzrac3r is offline   Reply With Quote
Old 10-05-2006, 05:22 AM   #14
Junior Member
iTrader: (1)
 
that7guy's Avatar
 
Join Date: Apr 2005
Location: Bethesda, MD
Posts: 428
Total Cats: 7
Default

I had the same problem. When I installed the kit it was maxing at 3.5- 4 psi. I got a voodoo MBC and hooked it between the nipple on wastegate actuator and the vacume on the intake manifold. The diagram you showed will work but might cause some boost spike. Other then that i would try another gauge.
that7guy is offline   Reply With Quote
Old 10-05-2006, 11:54 AM   #15
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

Quote:
Originally Posted by krayzrac3r View Post
i didnt have a nipple on the compressor, its still left open....
This statment confuses me. Are you saying there isn't a bung or fitting on the compressor? Or are you saying there isn't a fitting on the bung and there is a open hole?
Braineack is offline   Reply With Quote
Old 10-05-2006, 04:05 PM   #16
Junior Member
 
Join Date: Jul 2006
Posts: 124
Total Cats: 0
Default

hmm i have a hallman mbc and it doesnt say anything about teeing into the bov vacuum line. just the lines from the compressor and the wastegate.
penpen989 is offline   Reply With Quote
Old 10-05-2006, 04:14 PM   #17
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

you can tee off of any boost source.
Braineack is offline   Reply With Quote
Old 10-05-2006, 05:00 PM   #18
Elite Member
iTrader: (3)
 
Mach929's Avatar
 
Join Date: Oct 2004
Location: lansdale PA
Posts: 2,500
Total Cats: 0
Default

i'm thinking it's normal not to get full boost till after 4k rpm
Mach929 is offline   Reply With Quote
Old 10-05-2006, 05:48 PM   #19
Guest
Thread Starter
 
Join Date: Mar 2006
Location: So Cal
Posts: 407
Total Cats: 0
Default

Quote:
Originally Posted by braineack View Post
This statment confuses me. Are you saying there isn't a bung or fitting on the compressor? Or are you saying there isn't a fitting on the bung and there is a open hole?
Sorry about the misunderstanding what I meant was that the hole is OPEN. There is a fitting its just left open now that I have the MBC. I closed it today and now my cars still the same with the difference being that it doesnt blow off any noise once i let go of the throttle in boost.
krayzrac3r is offline   Reply With Quote
Old 10-05-2006, 06:00 PM   #20
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

ok.

Do this.

Connect the MBC to the Compressor fitting. So the bottom leg of MBC goes towards the compressor and the side legs goes towards the wastgate.

Keep the BOV vacuum line out of the equation, make sure it's leak free and connected straight to your source.

MBC is on the lowest boost setting when turned fully counterclockwise. The tighter you tighten down the MBC the higher the boost will go.

Also verify that your wastgate actuator rod is fairly tight.


see attached:

Last edited by Braineack; 10-02-2007 at 04:01 PM.
Braineack is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Noob to Miataturbo from MA JxPhan Meet and Greet 3 10-02-2015 03:17 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
WTB HPDE miata - Texas Voltwings Cars for sale/trade 0 09-27-2015 07:40 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:45 PM.