Installation of one of the first BEGi NC Turbo Kits - Page 2 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 06-01-2009, 07:27 PM   #21
Elite Member
iTrader: (13)
 
Join Date: Dec 2006
Location: Taos, New mexico
Posts: 5,703
Total Cats: 237
Default

Awesome. Looks clean, cant wait for more pics/vids!
Fireindc is offline   Reply With Quote
Old 06-02-2009, 12:37 AM   #22
Former Vendor
 
Join Date: Jun 2006
Location: Bell Tuning & Performance
Posts: 1,338
Total Cats: -78
Default

Quote:
Originally Posted by dustinb View Post
Looks great. Has anyone blown up a NC motor yet to give an idea of how much power they can handle?
Apparently it has been done in the UK. I believe three cars with Cosworth systems and Sniper tuning are now DOA. One bent rods and caught on fire at 13 psi. After doing some reading and tuning an Xede on a Cosworth kit last weekend - I believe it is a Sniper tuning issues. I saw the previous dyno sheet on the car I tuned, it was running 15:1 AFR at WOT!!!! I kid you not - verified on two different dynos! And Sniper claims it was the "richest" map he has made. It made 220 whp, but it would not have running for much longer.

Sorry for the thread jack.
Stephanie
p.s. thanks for the photos!
Stephanie Turner is offline   Reply With Quote
Old 06-02-2009, 02:32 AM   #23
Elite Member
iTrader: (17)
 
Join Date: Aug 2007
Location: Fort Myers, FL
Posts: 2,791
Total Cats: 130
Default

Quote:
Originally Posted by Stephanie Turner View Post
Apparently it has been done in the UK. I believe three cars with Cosworth systems and Sniper tuning are now DOA. One bent rods and caught on fire at 13 psi. After doing some reading and tuning an Xede on a Cosworth kit last weekend - I believe it is a Sniper tuning issues. I saw the previous dyno sheet on the car I tuned, it was running 15:1 AFR at WOT!!!! I kid you not - verified on two different dynos! And Sniper claims it was the "richest" map he has made. It made 220 whp, but it would not have running for much longer.

Sorry for the thread jack.
Stephanie
p.s. thanks for the photos!
Wow, well I don't think we should count those 3, haha. Makes you wonder how some people manage to get enough credibility that people will let them tune their cars.

The kit looks great. I can't wait to see more numbers out of the NC.
pdexta is offline   Reply With Quote
Old 06-05-2009, 01:14 PM   #24
Elite Member
 
Join Date: Feb 2008
Location: Victoria, BC
Posts: 2,322
Total Cats: 12
Default

Quote:
Originally Posted by Stephanie Turner View Post
Apparently it has been done in the UK. I believe three cars with Cosworth systems and Sniper tuning are now DOA. One bent rods and caught on fire at 13 psi. After doing some reading and tuning an Xede on a Cosworth kit last weekend - I believe it is a Sniper tuning issues. I saw the previous dyno sheet on the car I tuned, it was running 15:1 AFR at WOT!!!! I kid you not - verified on two different dynos! And Sniper claims it was the "richest" map he has made. It made 220 whp, but it would not have running for much longer.

Sorry for the thread jack.
Stephanie
p.s. thanks for the photos!
Wow, 15:1 at wot... That's awesome
dustinb is offline   Reply With Quote
Old 06-06-2009, 07:06 PM   #25
Former Vendor
 
Join Date: Jun 2006
Location: Bell Tuning & Performance
Posts: 1,338
Total Cats: -78
Default

Car is finally running! We have an inlet tube to fix, but otherwise going well.
Stephanie
Stephanie Turner is offline   Reply With Quote
Old 06-06-2009, 07:35 PM   #26
Elite Member
iTrader: (22)
 
Join Date: Dec 2006
Location: Sunny Spanish speaking Non US Caribbean
Posts: 3,257
Total Cats: 3
Default

Quote:
Originally Posted by MXGeorge View Post
The 09 motors use a forged crank and con rods as well as floating wrist pins, which Mazda thinks is good for another 500rpm. I am hoping to pick up a whole motor and cpu from an 09 when I find a wrecked one. After that happens, I will get MAP and MAF sensors from an MS3 and see if we can hit 12psi. BEGi tried for 10psi, but the stock MAP can't read past 9psi so the cpu shut the ignition off.
If the motor blows, I will have one with the forged internals waiting to go.
I'm going to assume this is then your car. If so; congrats!

A quick question; I don't understand what EMS you're planning on using with that 09 engine when you get it.
Rafa is offline   Reply With Quote
Old 06-07-2009, 05:49 PM   #27
Newb
 
Join Date: Aug 2008
Posts: 6
Total Cats: 0
Default

were the tabs already on the intercooler?
zxc4 is offline   Reply With Quote
Old 06-07-2009, 08:37 PM   #28
Newb
 
Join Date: Apr 2009
Posts: 22
Total Cats: 1
Default

Quote:
Originally Posted by Rafa View Post
I'm going to assume this is then your car. If so; congrats!

A quick question; I don't understand what EMS you're planning on using with that 09 engine when you get it.
I figured that if I got a junkyard 09 motor, that there will be the EMC to go with it.
MXGeorge is offline   Reply With Quote
Old 06-07-2009, 08:38 PM   #29
Newb
 
Join Date: Apr 2009
Posts: 22
Total Cats: 1
Default

Quote:
Originally Posted by zxc4 View Post
were the tabs already on the intercooler?
Yes, everything was ready to install.
MXGeorge is offline   Reply With Quote
Old 06-07-2009, 11:01 PM   #30
Newb
iTrader: (1)
 
Join Date: Oct 2007
Location: St. Louis, MO
Posts: 17
Total Cats: 0
Default

Very Niceee!
stlxsr is offline   Reply With Quote
Old 06-08-2009, 12:54 AM   #31
Elite Member
Thread Starter
iTrader: (33)
 
RotorNutFD3S's Avatar
 
Join Date: Jan 2007
Location: Newnan, GA
Posts: 2,539
Total Cats: 29
Default

Just a few quick "buttoned up" pictures. Bumper, wheel wells, and wheels still optional at this point.




Plenty of shielding:

RotorNutFD3S is offline   Reply With Quote
Old 06-08-2009, 10:32 AM   #32
Junior Member
iTrader: (4)
 
Join Date: Feb 2008
Location: North NJ
Posts: 271
Total Cats: -1
Default

Thats a BUSY engine bay. congrats and nice job!
1stproject is offline   Reply With Quote
Old 06-08-2009, 12:10 PM   #33
Senior Member
 
Join Date: Nov 2005
Location: Austin, TX yall
Posts: 849
Total Cats: 0
Default

That's a pretty nice clean install.

The exhaust is sweet.

Where do they get the oil feed for the turbo from?

Chris
Miatamaniac92 is offline   Reply With Quote
Old 06-08-2009, 01:02 PM   #34
Elite Member
Thread Starter
iTrader: (33)
 
RotorNutFD3S's Avatar
 
Join Date: Jan 2007
Location: Newnan, GA
Posts: 2,539
Total Cats: 29
Default

Quote:
Originally Posted by Miatamaniac92 View Post
Where do they get the oil feed for the turbo from?
From the other side of the engine, near the oil filter. There is a port that feeds the OEM oil pressure sender, it comes from that with a straight tee that BEGi supplied. Interesting little piece when you first see it, not the typical tee, I didn't take a picture of it though.
RotorNutFD3S is offline   Reply With Quote
Old 06-08-2009, 05:12 PM   #35
Former Vendor
 
Join Date: Jun 2006
Location: Bell Tuning & Performance
Posts: 1,338
Total Cats: -78
Default

Here is a photo of the tee off of the pressure sender.

BTW - for anyone looking at install photos - the MAF is installed backwards. BUT George found it and fixed it before I could think of it.
Stephanie
Stephanie Turner is offline   Reply With Quote
Old 06-08-2009, 05:14 PM   #36
Former Vendor
 
Join Date: Jun 2006
Location: Bell Tuning & Performance
Posts: 1,338
Total Cats: -78
Default

Photos, duh.... I have such blonde moments, sorry.
Attached Images
File Type: jpg P2055627.JPG (357.3 KB, 156 views)
File Type: jpg P5196332.JPG (502.4 KB, 140 views)
Stephanie Turner is offline   Reply With Quote
Old 06-16-2009, 11:59 AM   #37
Hear me Meow
iTrader: (3)
 
skidude's Avatar
 
Join Date: Apr 2008
Location: Outside Portland Maine
Posts: 1,994
Total Cats: 13
Default

Looks like a good build. I'm interested to see how this thing will handle boost.
skidude is offline   Reply With Quote
Old 06-16-2009, 12:28 PM   #38
Elite Member
Thread Starter
iTrader: (33)
 
RotorNutFD3S's Avatar
 
Join Date: Jan 2007
Location: Newnan, GA
Posts: 2,539
Total Cats: 29
Default

From what I was told, the clutch didn't appreciate boost and promptly started slipping, so an ACT unit was ordered and is being installed soon.
RotorNutFD3S is offline   Reply With Quote
Old 06-16-2009, 12:30 PM   #39
Hear me Meow
iTrader: (3)
 
skidude's Avatar
 
Join Date: Apr 2008
Location: Outside Portland Maine
Posts: 1,994
Total Cats: 13
Default

Angry clutches are the worst.
skidude is offline   Reply With Quote
Old 06-18-2009, 01:31 PM   #40
Newb
 
Join Date: Apr 2009
Posts: 22
Total Cats: 1
Default

Ok the clutch is in and the leaks are fixed. Car is running very well considering I haven't touched on any tuning yet. It is currently running 10 psi and with no hickups.
Dyno tuning on an eddy current is tentatively planned for next week.
The main problem I see with the tune at this point is that the injectors shut off on coast, so when I crack the throttle, I am greeted with a very loud POP.
MXGeorge is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Complete BEGI S3 NB Kit, Full Enthuza 3" Exhaust, ACT HD Clutch, MS2 PNP, Wideband kronikker Miata parts for sale/trade 17 10-06-2015 11:18 PM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM
wiring wideband ground to battery terminal btabor ECUs and Tuning 10 09-28-2015 06:33 PM
WTB 90-97 miata low profile headlight kit DonPlatt WTB 0 09-25-2015 03:57 AM
Partial Turbo kit for a 1.6 and dual headlight kit. Andifer Miata parts for sale/trade 8 09-23-2015 06:43 PM


Tags
begi, nc turbo

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:19 AM.