Go Back  Miata Turbo Forum - Boost cars, acquire cats. > Performance & Tuning > Prefabbed Turbo Kits
Reload this Page >

?Lowered Boost pressure-Shitty MPG's-Decreased Vac?

Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

?Lowered Boost pressure-Shitty MPG's-Decreased Vac?

 
Old 07-08-2007, 08:20 PM
  #1  
Senior Member
Thread Starter
 
LOLA - 92's Avatar
 
Join Date: Oct 2004
Location: SWAMPS OF FLORIDA !!!
Posts: 1,161
Total Cats: 0
Default ?Lowered Boost pressure-Shitty MPG's-Decreased Vac?

Hey Dudes!
Lola is a little sick.
About a month ago I noticed that the vac was sitting at 18 instead of the usual 20. My gas mileage has been steadily decreasing the past two months. I'm getting about 18 MPG around town. She is running rich when I go to simple boost. I have dropped boost by at least 3 PSI.
Do you think it is a vacumm leak, or that my PCV valve sucks, or that the turbo is failing?
I run stoich up to around 2500, and then it goes to rich when I go over 3000 RPM and stays rich.
I have no odd sounds from the turbo and the greddy kit has not been a problem for nearly three years. I had it set for 6psi by the way.
Should I look at the waste gate linkage and see if it is fucked up?
I'll go over the whole thing hopefully this week, but maybe someone could come up with an instant answer (magically).
Timing set at 12 if I remember correctly, with 2 point increment decreases with the Bipes to drop to 6 under full boost - So, I don't think it has anything to do with timing. Fuel system is clean, it's not the cat, no restrictions, air filter is clean, piggyback FPR vortech with stock greddy disk.
1)runs rich after 2500 rpm
2)loss of boost (3 psi)
3)decrease in vacumm (from 20 to 18)
4 shitty gas mileage (18 to 16 MPG)
5)doesn't burn oil
6)no smoke (black,grey,white) from exhaust
P.S. Maybe the water thermosensor sucks?
Maybe the waste gate is a little stuck?
LOLA - 92 is offline  
Old 07-08-2007, 10:31 PM
  #2  
Elite Member
iTrader: (11)
 
Trent's Avatar
 
Join Date: Feb 2006
Location: Louisiana
Posts: 1,616
Total Cats: 5
Default

sounds like a good ol' fashioned vacuum leak, albeit a very slight one.

how is your idle?
any CEL's?
Trent is offline  
Old 07-09-2007, 05:16 AM
  #3  
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,254
Total Cats: 2
Default

yeah i vote on vac leak somewhere. Do you run any management? I cant remember. Just to be safe check compression and FP, as well while you are at it nothing like a complete check up for lola she probably just wants some attention.
magnamx-5 is offline  
Old 07-09-2007, 08:37 AM
  #4  
Boost Czar
iTrader: (62)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 76,366
Total Cats: 2,294
Default

o2 clamp? maybe the switch failed open?

otherwise vacuum leak or something.
Braineack is offline  
Old 07-15-2007, 08:12 PM
  #5  
Senior Member
Thread Starter
 
LOLA - 92's Avatar
 
Join Date: Oct 2004
Location: SWAMPS OF FLORIDA !!!
Posts: 1,161
Total Cats: 0
Default

I think it is all fixed (temporarily).
Bad prong (broken) on the CAS (possible fuel consumption problem).
Then when I was re-timing LOLA, low and behold - I noticed that I blew a hole in the pipe. My boost was shot from the hole in the pipe.
I read through Braineacks fix it threads and found that I should use either zip-ties or ductape.. I opted for Ductape as the temporary Braineack fix it. :gay:
Thanks Braineack!
Love,
LOLA
LOLA - 92 is offline  
Old 07-15-2007, 11:11 PM
  #6  
Junior Member
 
Join Date: May 2006
Location: Houston Area-Baytown, TX
Posts: 118
Total Cats: 0
Default

Originally Posted by LOLA - 92 View Post
I think it is all fixed (temporarily).
Bad prong (broken) on the CAS (possible fuel consumption problem).
Then when I was re-timing LOLA, low and behold - I noticed that I blew a hole in the pipe. My boost was shot from the hole in the pipe.
.......ctape as the temporary Braineack fix it. :gay:
Thanks Braineack!
Love,
LOLA
What pipe did you blow a hole in?
1991BRG is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Full_Tilt_Boogie
Build Threads
67
03-16-2019 08:07 PM
stoves
Suspension, Brakes, Drivetrain
5
04-21-2016 03:00 PM
Trent
WTB
2
10-01-2015 12:15 PM
shooterschmidty
Engine Performance
8
09-30-2015 10:28 PM


Thread Tools
Search this Thread
Quick Reply: ?Lowered Boost pressure-Shitty MPG's-Decreased Vac?


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.