O 2 sensor - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 03-31-2007, 07:04 PM   #1
Junior Member
Thread Starter
 
Join Date: Jan 2006
Location: West Palm Beach Fl
Posts: 242
Total Cats: -2
Default O 2 sensor

Last week I had a heater hose leak and when I replaced it I was pretty rough (****** clamp) and either pulled a splice loose from my O2 sensor or since i wasnt carefull how I rerouted the sensor wire after it burned insulation and grounded it. I did reroute it and am pretty sure I now have a good connection. Anyway after about 15 minutes of highway driving the CEL light is coming on, and the code is 1 5 which is either wiring or the sensor. The thing is the car is running better than ever, more responsive and more pull. If I didnt look down and see the light I wouldnt suspect anything. Being as we have no smog inspection in Florida what would be the consequences of leaving it like this? I bought a sensor and will replace it but Im still miffed as to why it is running better
gman3 is offline   Reply With Quote
Old 03-31-2007, 07:25 PM   #2
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,438
Total Cats: 84
Default

No signal from the O2 is like a lean signal. Maybe the extra fuel is just what you needed.
olderguy is offline   Reply With Quote
Old 03-31-2007, 07:40 PM   #3
Junior Member
Thread Starter
 
Join Date: Jan 2006
Location: West Palm Beach Fl
Posts: 242
Total Cats: -2
Default

Quote:
Originally Posted by olderguy View Post
No signal from the O2 is like a lean signal. Maybe the extra fuel is just what you needed.
Thanks I may leave it as is. The difference is very noticable. I guess if the mileage really goes to hell Ill need to replace it
gman3 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 02:11 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 11:44 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:49 PM.