Popping from turbo any thoughts - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 01-02-2008, 07:12 PM   #1
Junior Member
Thread Starter
 
Join Date: Dec 2007
Location: Atlanta, GA
Posts: 51
Total Cats: 0
Default Popping from turbo any thoughts

I went and drove my miata today and it was one of the coldest days we've had in georgia lately 15-20 degrees (cold for us southerners). When I hit 8-9 psi of boost in 3rd I heard this nasty popping and the boosts gauge was all over the place (but it didn't seem to go above 10 where i have it set) I don't know if my wastegate actuator is spazzing or what. I have a 93 with a greddy, intercooler, bipes, dual exhaust and I am running about 10psi. Thanks for your help.
pdt602 is offline   Reply With Quote
Old 01-02-2008, 07:24 PM   #2
Elite Member
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

Detonation maybe? The colder charge is more dense. Hows your fueling?
Saml01 is offline   Reply With Quote
Old 01-02-2008, 07:27 PM   #3
Elite Member
iTrader: (3)
 
Join Date: May 2006
Location: Houston, TX
Posts: 2,900
Total Cats: 0
Default

what are you running for fuel? stock injectors may not flow enough to handle the denser air charge at those temps.
Arkmage is offline   Reply With Quote
Old 01-02-2008, 09:43 PM   #4
Junior Member
Thread Starter
 
Join Date: Dec 2007
Location: Atlanta, GA
Posts: 51
Total Cats: 0
Default Running 1.8 injectors and Vortec FPR

I have it tuned for normal Georgia weather witht he vortec. Do you think detonation with cold weather cold be the problem. That was my first thought was that it had something to do with the temp.
pdt602 is offline   Reply With Quote
Old 01-02-2008, 09:47 PM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,787
Default

ba ba backfirez.
Braineack is online now   Reply With Quote
Old 01-02-2008, 10:09 PM   #6
Elite Member
iTrader: (22)
 
Join Date: Dec 2006
Location: Sunny Spanish speaking Non US Caribbean
Posts: 3,257
Total Cats: 3
Default

Quote:
Originally Posted by Braineack View Post
ba ba backfirez.
At least you haven't lost your sense of humor! Like half way to Mexico! lol.
Rafa is offline   Reply With Quote
Old 01-03-2008, 04:33 PM   #7
Junior Member
Thread Starter
 
Join Date: Dec 2007
Location: Atlanta, GA
Posts: 51
Total Cats: 0
Default I don't think it's backfiring

It's coming from the engine and the popping isn't like that it sounds more dangerous like a plunger.
pdt602 is offline   Reply With Quote
Old 01-03-2008, 05:02 PM   #8
Elite Member
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

Just wait for this to happen.

Saml01 is offline   Reply With Quote
Old 01-03-2008, 05:41 PM   #9
I'm Miserable!
iTrader: (1)
 
Join Date: Oct 2007
Location: Niagara Falls, On, CANADA
Posts: 979
Total Cats: 0
Default

^^^wtf!
miataz is offline   Reply With Quote
Old 01-03-2008, 05:54 PM   #10
Senior Member
iTrader: (4)
 
Join Date: May 2007
Location: Ontario
Posts: 790
Total Cats: 0
Default

What was in his exhaust tract?
reddroptop is offline   Reply With Quote
Old 01-03-2008, 06:14 PM   #11
Elite Member
iTrader: (24)
 
Join Date: Jul 2007
Location: Cypress, TX
Posts: 3,778
Total Cats: 35
Default

Quote:
Originally Posted by reddroptop View Post
What was in his exhaust tract?
Catalytic converters were gutting themselves lol... Why would that happen?
Bryce is offline   Reply With Quote
Old 01-03-2008, 06:15 PM   #12
Elite Member
iTrader: (3)
 
Mach929's Avatar
 
Join Date: Oct 2004
Location: lansdale PA
Posts: 2,500
Total Cats: 0
Default

ceramic catalytic converters
Mach929 is offline   Reply With Quote
Old 01-03-2008, 09:50 PM   #13
Senior Member
iTrader: (4)
 
Join Date: May 2007
Location: Ontario
Posts: 790
Total Cats: 0
Default

Quote:
Originally Posted by Bryceness View Post
Catalytic converters were gutting themselves lol... Why would that happen?
Makes sense, thanks! Couldn't figure it out.

Cats got OWNED.
reddroptop is offline   Reply With Quote
Old 01-08-2008, 10:29 PM   #14
Junior Member
Thread Starter
 
Join Date: Dec 2007
Location: Atlanta, GA
Posts: 51
Total Cats: 0
Default Do you think it will pass emissions?

I like it when he said, do you think it will pass emissions? I'd like to see some guy put that sensor in the the exhause and the cats hit him.
pdt602 is offline   Reply With Quote
Old 01-08-2008, 10:40 PM   #15
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,787
Default

well, you dont get into boost during emissions.... but i have a feeling the o2 sensor is dead.
Braineack is online now   Reply With Quote
Old 01-09-2008, 07:08 AM   #16
Junior Member
iTrader: (1)
 
Join Date: May 2007
Location: chilliwack, bc
Posts: 93
Total Cats: 0
Default

Quote:
Originally Posted by pdt602 View Post
I went and drove my miata today and it was one of the coldest days we've had in georgia lately 15-20 degrees (cold for us southerners). When I hit 8-9 psi of boost in 3rd I heard this nasty popping and the boosts gauge was all over the place (but it didn't seem to go above 10 where i have it set) I don't know if my wastegate actuator is spazzing or what. I have a 93 with a greddy, intercooler, bipes, dual exhaust and I am running about 10psi. Thanks for your help.


maybe your spark plugs are shitty? my car was popping a bit once. i changed the plugs, problem solved. they looked like they had been sandblasted.
reckless_abandon is offline   Reply With Quote
Old 01-11-2008, 04:55 PM   #17
Junior Member
Thread Starter
 
Join Date: Dec 2007
Location: Atlanta, GA
Posts: 51
Total Cats: 0
Default

Well now that it has warmed up a little it is running just fine. I guess I just won't take it out on cold days. Would it have been detonation if that is the case?
pdt602 is offline   Reply With Quote
Old 01-11-2008, 04:59 PM   #18
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,787
Default

still sounds like it may be an o2 sensor problem. what type of gas mileage you get?
Braineack is online now   Reply With Quote
Old 03-14-2008, 05:19 PM   #19
Junior Member
Thread Starter
 
Join Date: Dec 2007
Location: Atlanta, GA
Posts: 51
Total Cats: 0
Default Good point Braineack

I looked at some of my old posts and I'm digging this one up but my car has been running better and I haven't had the popping since then but my gas mileage has been a lot worse lately. Hmmm 02 goin out maybe
pdt602 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Another Cast Manifold Corky Bell Prefabbed Turbo Kits 18 11-22-2016 10:01 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:18 PM.