Splooging oil? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 04-14-2007, 02:10 AM   #1
Junior Member
Thread Starter
 
Join Date: Nov 2005
Location: PA/DC
Posts: 468
Total Cats: 0
Default Splooging oil?

Alrighty, why does oil come out of the breather filter on the valve cover?

You know, the one that is saposed to connect to the pipe right before the inlet-side of the turbo.

Did I add too much oil and this is it's way of getting rid of it?
How do I stop it?
Snowsurfer03 is offline   Reply With Quote
Old 04-14-2007, 02:25 AM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,892
Total Cats: 1,792
Default

bad pcv valve, bad rings.
Braineack is offline   Reply With Quote
Old 04-14-2007, 02:41 AM   #3
Senior Member
 
boostinsteve's Avatar
 
Join Date: Oct 2006
Location: Honolulu, HI
Posts: 563
Total Cats: 0
Default

There is pressure getting into the crankcase somehow. Just like brain said, those are the two ways for that to occur.
boostinsteve is offline   Reply With Quote
Old 04-14-2007, 02:59 AM   #4
Junior Member
Thread Starter
 
Join Date: Nov 2005
Location: PA/DC
Posts: 468
Total Cats: 0
Default

Hummm...ok. Thanks.
Snowsurfer03 is offline   Reply With Quote
Old 04-18-2007, 01:18 AM   #5
Junior Member
 
Join Date: Dec 2006
Posts: 78
Total Cats: 0
Default

Quote:
Originally Posted by Snowsurfer03 View Post
Alrighty, why does oil come out of the breather filter on the valve cover?

You know, the one that is saposed to connect to the pipe right before the inlet-side of the turbo.

Did I add too much oil and this is it's way of getting rid of it?
How do I stop it?
Put the vacuum line back in. That worked for me. I am not using the U pipe and tapped the AFM. Not a drop of oil since...
beasty555 is offline   Reply With Quote
Old 04-21-2007, 12:21 PM   #6
I'm Miserable!
 
Join Date: Jan 2005
Location: Buffalo, NY
Posts: 39
Total Cats: 0
Default

+1

When I did my custom IC piping, I thought it would be easier to just put a filter on there instead of plumbing a hose barb. It didn't work like I thought it would and you need to run a vac line to the intake.
xcsx is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Moroso Air Oil Separator Catch Can Aroundcorner Miata parts for sale/trade 2 10-01-2015 04:20 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:17 AM.