Sudden lean condition. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 12-22-2011, 07:47 PM   #1
Junior Member
Thread Starter
 
Join Date: Aug 2011
Location: Maryland
Posts: 48
Total Cats: 0
Default Sudden lean condition.

I finished the install of the BEGi Shanghai turbo system about 2 weeks ago. It went very well. I drove the car about 300 miles since then. Today, all of a sudden, the AFRs went to 18-20 (at idle, in traffic). Upon slight acceleration it would go down to 15 or so. Then, also suddenly, the AFRs returned to normal. Later in the evening I drove the car and it did the same thing. Except this time it stayed at 18-20. I drove it out of boost home.

Any ideas what could cause this?

Thanks
Florin
self is offline   Reply With Quote
Old 12-27-2011, 12:09 AM   #2
Junior Member
 
Join Date: Oct 2010
Posts: 163
Total Cats: -26
Default

Hows your charging system?

While setting up my Shanghai kit, I noticed that voltage had a difference in my fuel pressure.

Battery alone I was getting 60psi max, battery charger gave 73psi. Once the car was running at high idle due to cold engine I was getting over 80psi, once warm and idling low I was around 75psi.


I thought the FMU was adjustable.
misfit77 is offline   Reply With Quote
Old 01-06-2012, 07:55 PM   #3
Junior Member
 
Join Date: Oct 2010
Posts: 163
Total Cats: -26
Default

Alright...I have the Shanghai kit as well.
Been running around 6psi max.

When i first installed my A/F I was getting 20. Few days later I was getting 22.4 (max).

I replaced the Easyseal muffler clamp that Begi gave me with a nicer Torctite.....problem solved.

Idle is at 15...thats better than 22 right?
6 psi is at a A/F ratio of 13.5 or so.
misfit77 is offline   Reply With Quote
Old 01-06-2012, 08:20 PM   #4
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by misfit77 View Post
6 psi is at a A/F ratio of 13.5 or so.
That's way too lean, kaboom style. I won't tune an NA car that lean.
hustler is offline   Reply With Quote
Old 01-06-2012, 10:47 PM   #5
Junior Member
 
Join Date: Oct 2010
Posts: 163
Total Cats: -26
Default

fuel pump is on its way...as soon as I hear from Step at begi.
They forgot to charge/ship it to me when I got my turbo.
misfit77 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Momo Supercup seat jpreston Miata parts for sale/trade 2 05-17-2016 01:51 AM
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 11:44 AM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM
Rear finish panel white mint condition gdoehl Miata parts for sale/trade 1 09-21-2015 01:54 PM
black carpet (looped) $60 Joker Miata parts for sale/trade 0 09-17-2015 07:48 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:30 PM.