turbo miata revvs at full throttle and doesn't accel. - seems to hold boost thought?! - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 10-07-2007, 10:56 PM   #1
Newb
Thread Starter
 
Join Date: Oct 2007
Posts: 3
Total Cats: 0
Default turbo miata revvs at full throttle and doesn't accel. - seems to hold boost thought?!

I have a 91 greddy turbo1.6 with just what the kit comes with, also 1.8 injectors and a high flow fuel pump. Clutch is original - 52k, spark plugs were replaced a few years ago when turbo was installed. I had problems with boost leaking so I thought that was why it was revving and not accelerating when the turbo spooled, but I made sure the intake was sealed and it still revs. If I give it only 3/4 throttle, the turbo will spool up and hold boost and car will go pretty quick for the first couple of gears from a stop - but if I punch it any gear the engine will rev quickly and my boost gauge will show the regular 4-5 pounds of boost that the turbo gives, but the car won't move as if it's in neutral. The clutch seems fine and shows no problems (other than maybe this) so I don't think the clutch it bad, it could be the seal on the intake - but it wouldn't make sense for my gauge to show boost if it were leaking (I know what that looks like) - what could this be????
davechaletzky is offline   Reply With Quote
Old 10-07-2007, 11:09 PM   #2
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

detonation?
magnamx-5 is offline   Reply With Quote
Old 10-08-2007, 12:06 AM   #3
I'm Miserable!
iTrader: (-1)
 
Join Date: May 2007
Location: West Sacramento Ca
Posts: 948
Total Cats: 0
Default

Quote:
Originally Posted by magnamx-5 View Post
detonation?
I hope not
Slidin'Miata916 is offline   Reply With Quote
Old 10-08-2007, 12:51 AM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

sounds exactly like a slipping clutch...
Braineack is offline   Reply With Quote
Old 10-08-2007, 01:20 AM   #5
Elite Member
iTrader: (9)
 
Join Date: Aug 2006
Location: Concord, North Carolina
Posts: 4,172
Total Cats: 5
Default

Shouldn't one be able to smell that...real bad like?
miatamania is offline   Reply With Quote
Old 10-08-2007, 03:19 AM   #6
Elite Member
iTrader: (24)
 
Join Date: Jul 2007
Location: Cypress, TX
Posts: 3,778
Total Cats: 35
Default

Probably not if you're moving.
Bryce is offline   Reply With Quote
Old 10-08-2007, 04:14 AM   #7
I'm Miserable!
iTrader: (-1)
 
Join Date: May 2007
Location: West Sacramento Ca
Posts: 948
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
sounds exactly like a slipping clutch...
From how hes describing it, sounds like hes boosting, i mean, more then a couple pounds.
And you cant really boost if your not under load, and you cant be under load with a slipping clutch...Right?
Slidin'Miata916 is offline   Reply With Quote
Old 10-08-2007, 05:25 AM   #8
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,356
Total Cats: 1,322
Default

That is how I would describe a slipping clutch to someone. If it revs just like it's in neutral, while in gear, at WOT, the clutch is definitely slipping.

magna, you retard. Detonation? Don't you have some wiring to **** up?
Savington is offline   Reply With Quote
Old 10-08-2007, 07:41 AM   #9
Elite Member
iTrader: (1)
 
Join Date: Jun 2005
Location: Charleston, SC
Posts: 2,980
Total Cats: 14
Default

Wire your WG open, drive down the road and punch it while in 4th gear. If you hit redline and don't go any faster then you need a new clutch.
rmcelwee is offline   Reply With Quote
Old 10-08-2007, 07:47 AM   #10
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

Quote:
Originally Posted by Savington View Post
That is how I would describe a slipping clutch to someone. If it revs just like it's in neutral, while in gear, at WOT, the clutch is definitely slipping.

magna, you retard. Detonation? Don't you have some wiring to **** up?
Hey dumb *** if he is detonating he wont make any apredciable power and it will seem as is he stoped accelerating. Clutch could also be suspect though.
magnamx-5 is offline   Reply With Quote
Old 10-08-2007, 07:58 AM   #11
Senior Member
iTrader: (4)
 
Join Date: Aug 2007
Location: Guam (U.S Terr.)
Posts: 786
Total Cats: -2
Default

ima go with the slipping clutch
mike_671 is offline   Reply With Quote
Old 10-08-2007, 09:45 AM   #12
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

Quote:
Originally Posted by rmcelwee View Post
Wire your WG open, drive down the road and punch it while in 4th gear. If you hit redline and don't go any faster then you need a new clutch.
best test.

however, stock clutch + 5psi = slip and slide.
Braineack is offline   Reply With Quote
Old 10-08-2007, 03:32 PM   #13
Newb
 
Join Date: Jun 2007
Location: California
Posts: 36
Total Cats: 0
Default

at about 30mph, Try putting it in 5th gear, and just floor it, then you should beable to tell if its a slipping clutch
Wakaranai is offline   Reply With Quote
Old 10-08-2007, 10:38 PM   #14
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,356
Total Cats: 1,322
Default

Quote:
Originally Posted by magnamx-5 View Post
Hey dumb *** if he is detonating he wont make any apredciable power and it will seem as is he stoped accelerating.
Yeah, and it will still rev freely while not accelerating, right?

Savington is offline   Reply With Quote
Old 10-08-2007, 11:12 PM   #15
Junior Member
 
Join Date: Mar 2005
Location: high performance all year round california
Posts: 82
Total Cats: 0
Default

Dude slipping clutch....no doubt. get the ACT and be over with it....
Gloko is offline   Reply With Quote
Old 10-12-2007, 12:57 AM   #16
Newb
Thread Starter
 
Join Date: Oct 2007
Posts: 3
Total Cats: 0
Default

ya it must be the clutch. It was odd because it was doing the same thing when my intake was leaking boost and revving w/out putting power to the wheels (which was prob. what put the clutch over the edge). When I noticed that the car was finally holding about 5 pounds of boost and still revving was when I got kinda confused. If i'm at 3 grand in any gear and I give it more than a little gas it just flies through the rpms and doesn't put the power to the wheels - and I think I noticed the smell a bit once I put the top up - thanks for the responses. I think part of the reason I never noticed the clutch was because of the intake problem I haven't spooled the turbo up too much lately, also I live in FL so no hills!
davechaletzky is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
MS PNP requires reading and following directions??? satisfied MEGAsquirt 141 10-06-2015 11:44 AM
New here, saying hi, here's what I'm workin with. SuperSneakySecretSquirrel Meet and Greet 5 09-06-2015 09:30 PM
2009 Subaru WRX Hatchback - Pearl White - 83k miles - $16999 Braineack Cars for sale/trade 3 09-04-2015 03:12 PM
E-Manage Base Maps faviles5566 ECUs and Tuning 0 09-04-2015 12:50 PM
E-Manage Base Maps faviles5566 ECUs and Tuning 0 09-04-2015 12:50 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:15 PM.