Turbo timer question.. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 04-25-2007, 06:01 PM   #1
Junior Member
Thread Starter
 
Join Date: Mar 2007
Location: SoCal
Posts: 284
Total Cats: 1
Default Turbo timer question..

So I installed my 1980's HKS timer following instructions in my previous post (thanks Spike) as well as some searching. Here's what I did:

Edit: Actually, I wired it differently from what Spike posted, here's what he said:

Quote:
wires for turbo timer

red=12v
blue=acc
green=on
the gray wire you do not need for cars in USA

wires for the ignition harness for miata.

white=b+
blue=1g1
black/red=1g2
black/white=acc
And here the wiring I used:

https://www.miataturbo.net/forums/sh...o+timer+wiring


Timer Blue to harness black/red stripe

Timer Green to harness blue

Timer red to harness white.

Ground to hole on steering column (checked the ground it was good)

Started car, turned it off, car turned off :(

I noticed there's 2 all white wires, did I tap the wrong one? Thoughts?

*edit* I tried the other white wire also, no dice. And according to the above link, one of the white wires has blue diamonds on it?? I didnt see any. But regardless, timer powers on, but its still letting the car shut-off right away.

Last edited by Exhondaman; 04-25-2007 at 06:13 PM.
Exhondaman is offline   Reply With Quote
Old 04-25-2007, 06:16 PM   #2
Junior Member
Thread Starter
 
Join Date: Mar 2007
Location: SoCal
Posts: 284
Total Cats: 1
Default

Unless i'm reading it wrong, Spike's wiring doesn't seem to jive with the other one. Which one is right??
Exhondaman is offline   Reply With Quote
Old 04-25-2007, 06:36 PM   #3
Junior Member
Thread Starter
 
Join Date: Mar 2007
Location: SoCal
Posts: 284
Total Cats: 1
Default

Anyone? Help a brother out! It's my only day off this week and i want to get this sucker in.
Exhondaman is offline   Reply With Quote
Old 04-25-2007, 07:09 PM   #4
Elite Member
 
Join Date: Jan 2005
Location: vancouver canada
Posts: 1,618
Total Cats: 0
Default

I got the diagram from another member that wired up his turbo timer using those instructions.Those instructions worked for the Greddy,HKS & Blitz timers.

I guess your older turbo timer is different from the new models.
spike is offline   Reply With Quote
Old 04-25-2007, 07:15 PM   #5
Junior Member
Thread Starter
 
Join Date: Mar 2007
Location: SoCal
Posts: 284
Total Cats: 1
Default

Spike, what do you mean by "1g1 and 1g2"?

I actually haven't tried your method yet but going to once I figure everything out.

Correct me if I'm wrong.

Timer red to harness white

Timer blue to harness black/white

Timer green spliced to harness blue AND black/red?

I found this searching around:


There's only three wires from MY timer though No yellow.
Exhondaman is offline   Reply With Quote
Old 04-25-2007, 07:29 PM   #6
Elite Member
 
Join Date: Jan 2005
Location: vancouver canada
Posts: 1,618
Total Cats: 0
Default

1g1=ignition 1

1g2=ignition 2

green to 1g1(no need to splice green and 1g1 & 1g2 together).

On the M1 miata's we do not need the 1g2.

Last edited by spike; 04-25-2007 at 07:46 PM.
spike is offline   Reply With Quote
Old 04-26-2007, 04:31 PM   #7
Junior Member
Thread Starter
 
Join Date: Mar 2007
Location: SoCal
Posts: 284
Total Cats: 1
Default

Nice dice, looks like my old timer died. Off to the HKS museum it goes. Thanks for your help anyways.
Exhondaman is offline   Reply With Quote
Old 04-26-2007, 04:36 PM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,809
Total Cats: 1,780
Default

you dont need one anyways
Braineack is offline   Reply With Quote
Old 04-26-2007, 04:36 PM   #9
Elite Member
 
Join Date: Jan 2005
Location: vancouver canada
Posts: 1,618
Total Cats: 0
Default

^how did it die?
spike is offline   Reply With Quote
Old 04-26-2007, 05:03 PM   #10
Junior Member
Thread Starter
 
Join Date: Mar 2007
Location: SoCal
Posts: 284
Total Cats: 1
Default

Yeah, but it came with the used greddy kit, so id figured it'd tried to make it work. It powers on, but when I shut car off, it doesnt do it's job. Oh well, time to sit in my car with it running, looking like a drug dealer or child molester.
Exhondaman is offline   Reply With Quote
Old 04-26-2007, 05:03 PM   #11
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,809
Total Cats: 1,780
Default

turn the car off and walk away and you can look like a normal person (if possible, i dunno never seen your face)
Braineack is offline   Reply With Quote
Old 04-26-2007, 09:22 PM   #12
Senior Member
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

Just don't beat on it for a while when your ready to shut it off. When I get home I just pop the hood and then in the morning when I'm leaving for school or work I just push it down. I just feel bad leaving all that heat just sitting there.
miataspeed1point6 is offline   Reply With Quote
Old 04-26-2007, 10:43 PM   #13
Junior Member
Thread Starter
 
Join Date: Mar 2007
Location: SoCal
Posts: 284
Total Cats: 1
Default

I just rechecked some of the online install info and most call for the unit to spliced into the e-brake wire, so the car shuts down if the e-brake is released. Since I stripped my interior and got rid of the brake idiot light wire, do u think that could be an issue? It does have a grey wire coming out of timer. Thoughts?
Exhondaman is offline   Reply With Quote
Old 04-26-2007, 11:31 PM   #14
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Why waste your time messing with it?
cjernigan is offline   Reply With Quote
Old 04-27-2007, 12:18 AM   #15
Junior Member
Thread Starter
 
Join Date: Mar 2007
Location: SoCal
Posts: 284
Total Cats: 1
Default

Cause it's free and already hard-wired it up, I want to exhaust all resources before I rip it out.
Exhondaman is offline   Reply With Quote
Old 04-27-2007, 02:28 AM   #16
Senior Member
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

That could cause it to not function. It's like the auto starts where if you touch the brakes they shut off. I would imagine you need to connect that to make it work. I'm sure you could easily rig something up. Good luck, free stuff is fun to hook up.
miataspeed1point6 is offline   Reply With Quote
Old 04-27-2007, 04:28 PM   #17
Junior Member
 
Join Date: May 2005
Location: Boston, MA
Posts: 73
Total Cats: 0
Default

connect that wire to ground and see if it works.
cyee is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
ISO 1.6 turbo cast iron manifold cale saurage DIY Turbo Discussion 16 10-01-2015 12:25 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:51 AM.