Wastegate rod.... - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 10-06-2006, 09:41 PM   #1
Junior Member
Thread Starter
 
Join Date: Apr 2006
Posts: 457
Total Cats: 0
Default Wastegate rod....

so i got it runnin and it seems that I start boost around 3200 and have 3.5-4psi of boost by 4200ish. I have the sab 900 jim pipes and IC so i know there is a crap ton of pipes for the air to go through. My question is tho that i had to get a replacement wastegate acuator (sp) cus mine came fucked do i need to turn that down or anything or "should it have" come at the right setting. I say "should have" cus GReddy quality well you all know how it is. I know with the stock Fuel Pump and Vortech 12:1 I cant go above 5-6psi.
LunaticDriver is offline   Reply With Quote
Old 10-06-2006, 09:53 PM   #2
Junior Member
iTrader: (6)
 
Join Date: Apr 2006
Posts: 259
Total Cats: 0
Default

I think most ppl on the site run 5-6psi. I run 5psi w/the stock kit and greddy suggested timing and it does fine. When cool outside it will pull 6psi and still fine.
danscreations is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Another Cast Manifold Corky Bell Prefabbed Turbo Kits 18 11-22-2016 10:01 PM
elesjuan's mediocre 95 Miata adventure (google fiber edition) elesjuan Build Threads 8 02-16-2016 09:36 PM
Miata new person and a what's it worth! Model192 Meet and Greet 16 09-29-2015 09:50 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:03 PM.