.....wow..... - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 05-29-2007, 12:31 PM   #1
Junior Member
Thread Starter
 
Join Date: Dec 2005
Posts: 258
Total Cats: 0
Default .....wow.....

Hell yea!! I finished the turbo install and i'm lovng it already. I've got greddy turbo kit, with starion fmic, 1.8L injectors, and 2.5" enthuza exhaust. I'm keeping it at 4psi until i get my support tool to work for my emanage, but i'm loving this already. Low end torque sucks ***, but once i hit about 2k rpms, that little turbo starts getting louder and i start getting faster. I especially love it on the freeway now that I don't have to drop a gear to pass a car. I've just ordered my heat shield, and once I get my support tool working, then i'll install my boost controller and DO WI. then i'll really have fun!! I don't know how I ever lived without turbo.
BrillntBlk92 is offline   Reply With Quote
Old 05-29-2007, 12:43 PM   #2
Elite Member
iTrader: (5)
 
akaryrye's Avatar
 
Join Date: Jul 2006
Location: Central California
Posts: 2,526
Total Cats: 0
Default

hell ya, turbos are ******* cool man. They magically make your car faster
akaryrye is offline   Reply With Quote
Old 05-29-2007, 01:29 PM   #3
FHS
Senior Member
iTrader: (2)
 
Join Date: Oct 2004
Location: Los Angeles, Ca.
Posts: 502
Total Cats: 0
Default

What do you mean by getting the Support Tool to work?

You have a fairly standard set-up for a Greddy + Emanage. All you really need is an injector and timing map for a particular boost setting. I'd think 6-8 psi should be a safe range for your set-up.
FHS is offline   Reply With Quote
Old 05-29-2007, 02:00 PM   #4
Junior Member
Thread Starter
 
Join Date: Dec 2005
Posts: 258
Total Cats: 0
Default

my usb clone cable doesn't seem to work. the drivers are fine, and it sees the emanage there, but i get an error whenever i import or export. also, when i tried updating the firmware on the emanage i let it run for about an hour and a half and it only had 1 bar of progress. i have 1.8L injectors in there now with a begi afpr, so thats really the only thing holding me back other than having time to play with it.
BrillntBlk92 is offline   Reply With Quote
Old 05-29-2007, 02:39 PM   #5
FHS
Senior Member
iTrader: (2)
 
Join Date: Oct 2004
Location: Los Angeles, Ca.
Posts: 502
Total Cats: 0
Default

Ah, I see. Ouch.
FHS is offline   Reply With Quote
Old 05-31-2007, 09:51 AM   #6
Junior Member
 
Join Date: Sep 2006
Posts: 225
Total Cats: -4
Default

Here's a tuning map for a 1.6 running 1.8 injectors, about 8PSI and only a few minor tweaks left to iron out - no leaning out thus far, but I am running an Older Guy O2 clamp.

I'm also running an FMIC and custom exhaust (2.5 inch) but it will give you a starting point.

Cheers.
Attached Files
File Type: gsc NA16-9psi-18inj_MM-MOB_v3.GSC (5.3 KB, 16 views)
Uncle Arthur is offline   Reply With Quote
Old 06-01-2007, 12:49 PM   #7
Junior Member
Thread Starter
 
Join Date: Dec 2005
Posts: 258
Total Cats: 0
Default

hell yea!! awesome, thanks!!
BrillntBlk92 is offline   Reply With Quote
Old 06-01-2007, 04:42 PM   #8
Junior Member
 
Join Date: Oct 2004
Location: Windsor, Canada
Posts: 191
Total Cats: -2
Default

You should budget for a LC-1 wideband too.....my fav upgrades are: Turbo, DO WI, and LC-1 wideband.
MiataNuTca is offline   Reply With Quote
 
 
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:44 PM.