94 engine in 97 no spark or fuel - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Suspension, Brakes, Drivetrain discuss the wondrous effects of boost and your miata...

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 09-13-2013, 08:12 PM   #1
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2013
Location: Knoxville, TN
Posts: 182
Total Cats: 10
Default 94 engine in 97 no spark or fuel

I put a 94 engine in my 97. I swapped over the cas and ckp, ckp trigger wheel and egr. It cranks but no fuel and no spark. My obd2 reader is able to talk to the ecu. I made a boneheaded mistake and didn't mark the cas, so i know its off. I've tried the cas in multiple positions including center, no dice. I have done fp plus gnd diag pins and I can hear fuel flowing. I am 99.9% positive the fuel lines are straight, the front/upper hardline is connected to the rear soft line.

Thoughts?
jspadaro is offline   Reply With Quote
Old 09-13-2013, 10:05 PM   #2
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2013
Location: Knoxville, TN
Posts: 182
Total Cats: 10
Default

If I plug in a timing light it lights once when I crank it.
jspadaro is offline   Reply With Quote
Old 09-14-2013, 08:29 AM   #3
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2013
Location: Knoxville, TN
Posts: 182
Total Cats: 10
Default

Bump
jspadaro is offline   Reply With Quote
Old 09-23-2013, 01:58 PM   #4
Junior Member
 
Join Date: Apr 2013
Location: Va
Posts: 87
Total Cats: -4
Default

Did you also swap the 97 coils onto the 94 engine?

The 94 uses a 4 wire coil while the 97 iirc uses a 3 wire coil
Togeneral99 is offline   Reply With Quote
Old 09-23-2013, 02:15 PM   #5
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2013
Location: Knoxville, TN
Posts: 182
Total Cats: 10
Default

I did, coil pack, TB, crank pulley and trigger wheel, CAS, etc were all swapped from the 97 and known working when they were pulled. I got some responses on that other miata website, went through a bunch of diagnosis, and am still stumped.

I trailered the car to a good mechanic around the corner, it should be being looked at today, because I don't know what I did wrong.
jspadaro is offline   Reply With Quote
Old 09-23-2013, 10:45 PM   #6
Junior Member
 
Join Date: Apr 2013
Location: Va
Posts: 87
Total Cats: -4
Default

Have you verified that you get fuel flow by removing the soft line at the passenger side frame rail that comes from the regulator iirc this should be the one to the front of the car.

Do you have any pictures of the plug wire configuration?

Also iirc the CASE and coil pack plugs are interchangeable so might want to double check that.
Togeneral99 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:52 AM.