Clutch Slave cylinder leaking? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Suspension, Brakes, Drivetrain discuss the wondrous effects of boost and your miata...

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 07-05-2009, 03:04 PM   #1
Newb
Thread Starter
 
Join Date: Feb 2009
Location: Cape Coral, Florida
Posts: 15
Total Cats: 0
Question Clutch Slave cylinder leaking?

My slave cylinder is leaking from the hard line coming from the master not the boot.
My question is has anybody ever had this happen and does anybody know of a fix that doesn't require me to take it apart/rebuild it? and i did use the search function but i didn't find anyone who has had this particular problem.

Also it's leaking from inside the nut that the hard line goes into not from around it.

Last edited by proudaztec07; 07-05-2009 at 03:28 PM.
proudaztec07 is offline   Reply With Quote
Old 07-05-2009, 03:47 PM   #2
Junior Member
 
Join Date: Mar 2008
Location: Charleston, S.C.
Posts: 159
Total Cats: 0
Default

Have you checked to make sure it's tight?? The only reason it should leak there is if the hardline isn't seated into the slave completely and the nut isn't tightened. Other than that your solution is likely to be remove the slave and check the seat area and even replace the hardline itself.
04 Miata is offline   Reply With Quote
Old 07-05-2009, 04:07 PM   #3
Newb
Thread Starter
 
Join Date: Feb 2009
Location: Cape Coral, Florida
Posts: 15
Total Cats: 0
Default

well the first thing i did was make sure it was tightened down but it still seems to leak from where the hard line goes into the nut. i was wondering if maybe there's supposed to be an o-ring in there or if maybe its just something I'll have to replace or live with till i can scrounge up the money to buy replacement. i just replaced the whole slave cylinder about 2 months ago and this is the first problem since then.
proudaztec07 is offline   Reply With Quote
Old 07-05-2009, 04:29 PM   #4
Junior Member
 
Join Date: Mar 2008
Location: Charleston, S.C.
Posts: 159
Total Cats: 0
Default

No o-ring, it's a pipe fitting. Remove it from the slave, check to make sure it's all clean especially on the inside of the flared end. Clean in the slave cylinder, maybe a small rag on the end of a screwdriver. Then reinstall it. Make sure the pipe sits all the way down into the slave as you tighten the nut so it sits on the seat.
04 Miata is offline   Reply With Quote
Old 07-05-2009, 06:41 PM   #5
Newb
Thread Starter
 
Join Date: Feb 2009
Location: Cape Coral, Florida
Posts: 15
Total Cats: 0
Default

well I will try that tonight and see if that works, hopefully i don't have to replace anything since I'm currently unemployed.
proudaztec07 is offline   Reply With Quote
Old 07-05-2009, 07:22 PM   #6
Junior Member
 
Join Date: Mar 2008
Location: Charleston, S.C.
Posts: 159
Total Cats: 0
Default

I would suspect the hard line and not the slave but it could be either.
04 Miata is offline   Reply With Quote
Old 07-06-2009, 01:19 PM   #7
Newb
Thread Starter
 
Join Date: Feb 2009
Location: Cape Coral, Florida
Posts: 15
Total Cats: 0
Default

ok so i cleaned it and tightened it down and it still leaks from inside the nut around the hard line and the hard line has some rubber coating on it but its worn off now so idk if thats it or not? is there a replacement clutch line the curly loop part? like a braided stainless line?
proudaztec07 is offline   Reply With Quote
Old 07-06-2009, 02:53 PM   #8
Elite Member
iTrader: (1)
 
NA6C-Guy's Avatar
 
Join Date: Feb 2008
Location: Birmingham Alabama
Posts: 8,038
Total Cats: 43
Default

Factory one is $25, so not too bad on an unemployed wallet.

Finish Line / Rosenthal Mazda Parts & Accessories :: Miata / MX-5 :: Drive Train :: Clutch Hydraulic Pipe

I'm about to have to tear into my clutch hydraulics myself as I have to pump my pedal 20 times every time I have to shift after driving for more than a minute or two. Slave is probably gone.
NA6C-Guy is offline   Reply With Quote
Old 07-06-2009, 03:06 PM   #9
Newb
Thread Starter
 
Join Date: Feb 2009
Location: Cape Coral, Florida
Posts: 15
Total Cats: 0
Default

well i figured it out! the replacement slave i bought from auto zone was to blame! i guess the guy at auto zone was wrong or the factory was because when i put the hard line in and tightened the bolt it didn't bottom out because the hole for the hard line was about 2xs deeper than the factory hole. so i used the guts from the auto zone one and they work perfectly in the factory one, problem fixed!! but i should have just gone with a rebuild kit instead of buying aftermarket. lesson learned inspect all parts before install.
proudaztec07 is offline   Reply With Quote
Old 07-06-2009, 03:16 PM   #10
Junior Member
 
Join Date: Mar 2008
Location: Charleston, S.C.
Posts: 159
Total Cats: 0
Default

Seems I mentioned that above.

Glad you got it to work.

I'm not a fan of using rebuild kits, some people swear by them. That said the only aftermarket slave I bought didn't fit since it was actually completely backwards in design.

It is one part I only use OEM.
04 Miata is offline   Reply With Quote
Old 07-06-2009, 03:58 PM   #11
Elite Member
iTrader: (46)
 
Stein's Avatar
 
Join Date: Dec 2007
Location: Nebraska
Posts: 4,812
Total Cats: 138
Default

Quote:
Originally Posted by 04 Miata View Post
It is one part I only use OEM.
Hmmm, it is one part that (four times now on four Miatas) that I had to rebuild the slave. I always used the Advance Auto rebuild kit without issue. $12 and I'm rolling.

I did pick up a 90 Miata cheap last year because the "clutch was out of it". It needed a slave cylinder.
Stein is offline   Reply With Quote
Old 07-06-2009, 05:54 PM   #12
Newb
Thread Starter
 
Join Date: Feb 2009
Location: Cape Coral, Florida
Posts: 15
Total Cats: 0
Default

Yea thanks for the info, help, and stuff. I love this Site!! If I wasn't broke I would subscribe!!
proudaztec07 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
ACT race clutch and AASCO 7lb. aluminum flywheel graexodus Miata parts for sale/trade 5 10-26-2015 02:48 PM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:35 AM.