just did brakes - what is this awful noise? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Suspension, Brakes, Drivetrain discuss the wondrous effects of boost and your miata...

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 06-24-2013, 01:16 AM   #1
Senior Member
Thread Starter
iTrader: (8)
 
Join Date: Sep 2010
Location: misery
Posts: 1,130
Total Cats: 9
Default just did brakes - what is this awful noise?

...aside from taking apart and re-assembling, does anyone know off the top of their head what is making this awful sound?
na6 rear hub.
generic rotor.
generic pads.
spacers.
extended studs.
all clips were taken off of the original pads/calipers and reused.
this is the driver's side rear wheel/brake



don't mind the missing lug...
phillyb is offline   Reply With Quote
Old 06-24-2013, 03:17 AM   #2
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,372
Total Cats: 1,339
Default

You didn't install something right. Probably one of the clips that the pads ride on.
Savington is offline   Reply With Quote
Old 06-24-2013, 03:37 AM   #3
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,133
Total Cats: 599
Default

are you sure the clips are installed right. From memory you could flip thema nd they could contact the rotor.
triple88a is offline   Reply With Quote
Old 06-24-2013, 03:57 AM   #4
Senior Member
iTrader: (5)
 
Join Date: Jul 2011
Location: Sonora, Ca
Posts: 623
Total Cats: 73
Default

New guy at my work installed a pad backwards the other day. Different sound, but regardless, take it all apart and double check everything.
bikersam717 is offline   Reply With Quote
Old 06-24-2013, 04:25 AM   #5
Senior Member
Thread Starter
iTrader: (8)
 
Join Date: Sep 2010
Location: misery
Posts: 1,130
Total Cats: 9
Default

i guess it probably is the clips. ty ty
phillyb is offline   Reply With Quote
Old 06-24-2013, 11:49 AM   #6
Senior Member
Thread Starter
iTrader: (8)
 
Join Date: Sep 2010
Location: misery
Posts: 1,130
Total Cats: 9
Default

it was the dust shield up against the rotor
phillyb is offline   Reply With Quote
Old 06-24-2013, 12:06 PM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,909
Total Cats: 1,793
Default

dammit, i was just about to suggest that also might be rubbing...
Braineack is online now   Reply With Quote
Old 06-24-2013, 12:08 PM   #8
Senior Member
Thread Starter
iTrader: (8)
 
Join Date: Sep 2010
Location: misery
Posts: 1,130
Total Cats: 9
Default

i got under there with a hammer and hammered it back into place as best i could without a jack or stands...or taking the wheel off.

we grinded and banged it a ton yesterday to get the extended studs in...
completely neglecting how that may impact fitment of other things. whoops.
phillyb is offline   Reply With Quote
Old 06-24-2013, 12:08 PM   #9
Senior Member
 
Join Date: May 2011
Location: Pennsylvania
Posts: 1,119
Total Cats: 33
Default

thats what i was thinking... my RR brake is making a chirping noise, annoying the **** out of me... pads and rotors are good.. thinking it may be a dust shield as well
supercooper is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
Another Alternator thread ihiryu General Miata Chat 9 09-28-2015 11:22 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:59 PM.