My new motor mounts ... wtf - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Suspension, Brakes, Drivetrain discuss the wondrous effects of boost and your miata...

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 02-06-2009, 02:55 AM   #1
Elite Member
Thread Starter
iTrader: (2)
 
Mobius's Avatar
 
Join Date: May 2008
Location: Portland, Oregon
Posts: 3,178
Total Cats: 267
Default My new motor mounts ... wtf

So ... I'm confused. The existing stock motor mounts have a stud through them. On one side, the cradle that mounts to the engine is bolted. The other side is bolted through the cup frame support. Thus, the engine is tied to the frame through a rubber damper.

My new mazdaspeed motor mounts (obtained from corksport) have rubber nipples on each side instead of a stud sticking through them. Now, normally I'm all for rubber nipples. But in this case, wtf do I do with them?

At this point, looking at them, the only thing I can think is that I need to cut them off, then drill the motor mounts for the stud. I can do that if I have to. But, come on. Seriously? None of the motor mount threads I've been able to find either here or m.net have mentioned having to do that.

In this pic, at the top is the passenger side motor mount, still bolted to the engine cradle as it came out of the car. Below is one of the new motor mounts.
Attached Thumbnails
My new motor mounts ... wtf-motor_mount.jpg  
Mobius is offline   Reply With Quote
Old 02-06-2009, 02:57 AM   #2
Elite Member
iTrader: (12)
 
Join Date: Jan 2007
Location: Hermosa Beach, CA
Posts: 2,575
Total Cats: 11
Default

oh boy....


They are plastic caps that cover the threads... you can pull them off...
cardriverx is offline   Reply With Quote
Old 02-06-2009, 02:58 AM   #3
Elite Member
iTrader: (5)
 
akaryrye's Avatar
 
Join Date: Jul 2006
Location: Central California
Posts: 2,526
Total Cats: 0
Default

those are caps to keep the studs from rusting you dork. try pulling them off

edit ... just read your sig "never underestimate stupid"

edit 2 ... damn your cardriverx, beat me to it
akaryrye is offline   Reply With Quote
Old 02-06-2009, 03:03 AM   #4
Elite Member
Thread Starter
iTrader: (2)
 
Mobius's Avatar
 
Join Date: May 2008
Location: Portland, Oregon
Posts: 3,178
Total Cats: 267
Default

For the love of god. Been too long of a day ... the rubber "nipples" are actually just sleeves covering the studs molded into the mount.

I am now going to have a beer.
Mobius is offline   Reply With Quote
Old 02-06-2009, 03:08 AM   #5
Elite Member
iTrader: (5)
 
akaryrye's Avatar
 
Join Date: Jul 2006
Location: Central California
Posts: 2,526
Total Cats: 0
Default

Quote:
Originally Posted by Mobius View Post
I am now going to have another beer.
fixed
akaryrye is offline   Reply With Quote
Old 02-06-2009, 03:31 AM   #6
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,372
Total Cats: 1,339
Default

best thread.
Savington is offline   Reply With Quote
Old 02-06-2009, 03:43 AM   #7
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,207
Total Cats: 2,587
Default

hey at least it didnt take a whole thread to figure it out
18psi is offline   Reply With Quote
Old 02-06-2009, 10:13 AM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,910
Total Cats: 1,793
Default

Braineack is offline   Reply With Quote
Old 02-06-2009, 10:21 AM   #9
Elite Member
iTrader: (30)
 
Join Date: Aug 2007
Location: Va Beach
Posts: 7,282
Total Cats: 0
Default


Last edited by levnubhin; 10-07-2009 at 04:02 PM.
levnubhin is offline   Reply With Quote
Old 02-06-2009, 11:30 AM   #10
Senior Member
iTrader: (3)
 
Join Date: Jan 2008
Location: Plano,TX
Posts: 674
Total Cats: 3
Default

hahahaha. Who would expect condoms on the threads?

johnwag is offline   Reply With Quote
Old 02-06-2009, 11:46 AM   #11
Elite Member
iTrader: (10)
 
IcantDo55's Avatar
 
Join Date: Apr 2007
Location: VA Beach
Posts: 1,772
Total Cats: 18
Default

PUT DOWN THE WRENCHES!



lol wait will someone posts this on miata.net lol for a change
IcantDo55 is offline   Reply With Quote
Old 02-06-2009, 12:11 PM   #12
Elite Member
iTrader: (9)
 
Join Date: Aug 2006
Location: Concord, North Carolina
Posts: 4,173
Total Cats: 5
Default

Lol.


I've had these days before.
miatamania is offline   Reply With Quote
Old 02-06-2009, 01:20 PM   #13
Elite Member
iTrader: (13)
 
Join Date: Nov 2006
Location: Tigard, Oregon
Posts: 3,908
Total Cats: 0
Default

Mobius, mobius, mobius....

Sigh....

Let me know what you think of those mounts when they are in. I'm thinking about them myself. Bitch to do though I guess. Particularly when you are drunk and high at the same time apparently.

Rubber sleeves. Sheesh. Thanks for the chuckle this morning. Genuinely laughed and smiled. I needed that.
cueball1 is offline   Reply With Quote
Old 02-06-2009, 01:39 PM   #14
Elite Member
iTrader: (1)
 
NA6C-Guy's Avatar
 
Join Date: Feb 2008
Location: Birmingham Alabama
Posts: 8,038
Total Cats: 43
Default



I cant lie, I was confused for about 10 seconds when I got my RX7 Mazdaspeed competition mounts. I thought "How in the hell do you mount these bastards, no threads!" But then I pulled them off... ooohhhhh... I see. Yes, go have another beer, drink one for me.
NA6C-Guy is offline   Reply With Quote
Old 02-06-2009, 02:04 PM   #15
Elite Member
 
Join Date: Jan 2005
Location: vancouver canada
Posts: 1,618
Total Cats: 0
Default

Quote:
Originally Posted by cueball1 View Post

Let me know what you think of those mounts when they are in. I'm thinking about them myself. Bitch to do though I guess.
You will love them once you put them in and wonder why you did not do it sooner.

They are not that hard to put in,it took me around 1 hour to install them.

Just don't drink too much or do too much drugs before hand,then you should be good to go.
spike is offline   Reply With Quote
Old 02-06-2009, 02:21 PM   #16
Elite Member
iTrader: (1)
 
NA6C-Guy's Avatar
 
Join Date: Feb 2008
Location: Birmingham Alabama
Posts: 8,038
Total Cats: 43
Default

I dunno, I dont love mine. I saw a pretty large improvement with my RX7's with them, but never noticed a thing in my Miata, even with my old mounts being torn. Idle might be a little bit smoother, but I think thats just going from torn mounts to new mounts. I guess its ok though, since these are only a little more than regular OEM's.
NA6C-Guy is offline   Reply With Quote
Old 02-06-2009, 02:24 PM   #17
Senior Member
iTrader: (7)
 
nicacus's Avatar
 
Join Date: Jul 2006
Location: SLC UT
Posts: 1,133
Total Cats: 0
Default

I like mine... other than all the extra rattles you get from the engine bay.
And honestly I thought WTF for a couple seconds when I first saw them
Then I pulled the caps off
only took me about 30-45 minutes to put them in.
nicacus is offline   Reply With Quote
Old 02-06-2009, 02:26 PM   #18
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Quote:
Originally Posted by akaryrye View Post
those are caps to keep the studs from rusting you dork. try pulling them off

edit ... just read your sig "never underestimate stupid"

edit 2 ... damn your cardriverx, beat me to it
Took the words out of my mouth.

patsmx5 is offline   Reply With Quote
Old 02-06-2009, 03:01 PM   #19
Elite Member
Thread Starter
iTrader: (2)
 
Mobius's Avatar
 
Join Date: May 2008
Location: Portland, Oregon
Posts: 3,178
Total Cats: 267
Default

Yes, last night Mobius = Mental Fail

It only took about 15 minutes to get the passenger side out. I have my transmission jack under the oil pan with a piece of 2x6 for cushioning. Took off the 4 bolts that hold that cradle onto the engine and was able to maneuver it out the front pretty easily. Since my car's already on jackstands with the engine undertray off that time's not included.

Fortunately, when I'm ready for a beer, I have several choices. Young's Double Chocolate Stout (nitro), Rogue Honey Wheat, Laurelwood's Piston Pale Ale, and Laurelwood's Workhorse IPA on the other nitro tap.

The piston is from the V4 gasoline starter motor of a 1958 John Deer 730 diesel. Interesting sequence of operations to start that sucker. It's difficult to see, but the side skirt of that piston is mostly gone on the backside. The starter motor was running fine despite that; it was only discovered when my father-in-law found the extra pieces in the oil pan. Wasn't even any vibration since that little starter motor is solidly bolted to 7000 lbs of steel.
Attached Thumbnails
My new motor mounts ... wtf-beerfridge1.jpg   My new motor mounts ... wtf-beerfridge2.jpg   My new motor mounts ... wtf-beerfridge3.jpg  
Mobius is offline   Reply With Quote
Old 02-06-2009, 03:05 PM   #20
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Epic.
cjernigan is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
01-05 Fab9 PNP COPs (used) FrankB Miata parts for sale/trade 6 09-30-2015 12:48 PM
WTB HPDE miata - Texas Voltwings Cars for sale/trade 0 09-27-2015 07:40 PM


Tags
motor mounts

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:46 PM.