NB and NA ECM connectors same? - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members

ECUs and Tuning Discuss Engine Management, Tuning, & Programming

LinkBack Thread Tools Search this Thread
Old 02-26-2009, 12:58 AM   #1
Junior Member
Thread Starter
Join Date: Apr 2008
Posts: 350
Total Cats: 1
Default NB and NA ECM connectors same?

I'm looking at Brain's "How to DIY MS" post in Beginner's Luck. He doesn't explicitly say the ECM connectors, etc. apply to NBs. I have a '99. Will the parts he calls out work to build my adapter/"boomslang" harness? I don't have NAs sitting around to compare.
SolarYellow510 is offline   Reply With Quote
Old 02-26-2009, 01:07 AM   #2
Elite Member
iTrader: (14)
patsmx5's Avatar
Join Date: Aug 2007
Location: Houston, TX
Posts: 7,803
Total Cats: 117

Yeah, all the connectors for the ECU are the same. Pinout is different of course, but the physical connectors are the same.
patsmx5 is offline   Reply With Quote
Old 02-26-2009, 09:58 AM   #3
2 Props,3 Dildos,& 1 Cat
iTrader: (8)
y8s's Avatar
Join Date: Jun 2005
Location: Fake Virginia
Posts: 18,746
Total Cats: 316

are they? Here's the p/n for the 2001:

AMP p/n:
353027-1 (17 pos)
353029-1 (24 pos)
353031-1 (31 pos)

316836-1 (72 minimum required)
y8s is offline   Reply With Quote
Old 02-26-2009, 12:26 PM   #4
Elite Member
iTrader: (8)
Join Date: Sep 2006
Location: Severn, MD
Posts: 1,927
Total Cats: 5

Absolutely not. At least not an '01 NB compared to an NA. As y8s pointed out the '01 has 3 smaller plugs. IIRC, the NA has 2 bigger plugs.

fmowry is offline   Reply With Quote
Old 02-26-2009, 12:34 PM   #5
Elite Member
iTrader: (13)
cjernigan's Avatar
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 5

Yes the parts Brain calls out will work. When making parallel harnesses we use the same set of connectors for '89-00. The earlier miatas don't use the middle connector is all.
You'll need to use all three for your car though.
cjernigan is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
CAS weirdness Asx MEGAsquirt 5 12-15-2015 11:14 AM
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 01:11 PM
Pull idle solenoid connector and idle goes UP?! JasonC SBB ECUs and Tuning 4 09-23-2015 11:51 AM
mm0105 Will not Power Up slomiata MEGAsquirt 1 09-15-2015 06:28 PM
Disconnect Coils when Updating FW DNMakinson MEGAsquirt 8 09-12-2015 08:26 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:22 AM.