Am I running rich or is my WB off? - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

MEGAsquirt A place to collectively sort out this megasquirt gizmo

LinkBack Thread Tools
Old 09-21-2010, 11:37 AM   #1
Senior Member
Thread Starter
Join Date: Nov 2007
Location: Belgium
Posts: 873
Total Cats: 52
Default Am I running rich or is my WB off?

MSM turbo on a 00, with WB in the factory location, right behind the turbo.
My afr's are going rich at high rpm, yet my fuel table seems to be right.
They gradually drop to about 10.6 at 7K
Do you guys think I should lower my fuel more >6K or is my WB off because of the high temperature? This is an older DIY Techedge with the NTK L1H1 sensor.

WestfieldMX5 is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 52 08-28-2016 04:18 AM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 03:23 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 09:39 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 09:30 AM
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 10:44 AM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:40 AM.