mslabs MS2 - Idle control issue - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

MEGAsquirt A place to collectively sort out this megasquirt gizmo

LinkBack Thread Tools
Old 09-20-2015, 10:28 PM   #1
Thread Starter
Join Date: Sep 2015
Posts: 1
Total Cats: 0
Default mslabs MS2 - Idle control issue

Hi all,

I'm submitting this question here as I'm aware Reverent is a member, and I have an mslabs MS2. I'd have emailed this instead, but unfortunately I've sent a few emails over the past few months with the odd question, and have gotten no reply.

Hopefully someone can help.

I'll try and keep this brief. I have an ITB'd 94 MX5 - I'm currently trying to add an idle control valve and have the MS2 control it. I've not been very successful.
The idle control valve is from an NB.

Wiring is all testing fine, the valve is testing fine. In TunerStudio I can use the Output Test Mode - I/O to send a signal to the valve via the FIDLE output - and I can see the valve plunger move - appears to be a good sign.

I set up PWM valve in the software using closed loop - and nothing at all happens, valve doesn't appear to respond at all, and nothing changes. I've used various settings to no avail (I can provide those settings, but for the purposes of this post left out the clutter). I then go to Output Test Mode - Idle Valve and attempt to adjust the valve there - nothing happens.

Then it gets weird.

I go back to the basic Idle Control Settings, and select an "open-loop (warmup)" algorithm, burn and then recycle everything and start the car.

Now, the tacho needle jumps all over the place (???) but again nothing changes as far as idle is concerned.

Apologies - I know this is a bit long winded. Hopefully there are some thoughts out there.

Any additional info supplied on request... just trying to keep this brief to begin with to get to the root of the issue.
ndragun is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 12:25 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 09:39 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 09:30 AM
Bizarre connection issue? nick470 MEGAsquirt 1 09-30-2015 10:32 PM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 01:42 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:31 PM.