MT Boost Gauge - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

MEGAsquirt A place to collectively sort out this megasquirt gizmo

LinkBack Thread Tools
Old 09-29-2008, 12:55 PM   #1
Hear me Meow
Thread Starter
iTrader: (3)
skidude's Avatar
Join Date: Apr 2008
Location: Outside Portland Maine
Posts: 1,967
Total Cats: 11
Default MT Boost Gauge

I traded one of my gauges in MegaTune for a boost gauge, that goes from 0 to 20psig. For some reason it shows about twice the boost I'm actually running. The mechnical boost gauge in the dash and the MAP gauge (when converted to psig) both say about 7psi but this one says 13 or 14.

Any ideas what's wrong with it? I don't really care as I have plenty of other ways to find out my boost, and plenty of other gauges to fill that spot with but I was just wondering about it.
skidude is offline   Reply With Quote
Old 09-29-2008, 01:08 PM   #2
Boost Czar

iTrader: (60)
Braineack's Avatar
Join Date: May 2005
Location: Chantilly, VA
Posts: 69,662
Total Cats: 1,362

is you configurator setup correctly for which MAP sensor you have? does the vac/boost gauge read correctly?
Braineack is offline   Reply With Quote
Old 09-29-2008, 01:12 PM   #3
Elite Member
iTrader: (21)
paul's Avatar
Join Date: Jun 2006
Location: Point Pleasant, NJ
Posts: 2,957
Total Cats: 2

no baro right? did you put that normal atmospheric pressure was (whatever it is in bangor, me)? At sea level it's 101. MT calculates based on what your normal atmospheric pressure is. something like Absolute pressure - barometric pressure.

I know with an MS without baro correction it reads baro when you first turn on the car(ms) if there is a reset at any time while the car is running(ie burning a new msq) it reads the MAP as baro pressure and then calculates boost completely wrong based on that if the car was running at the time. Reason, you are in vacuum when car is running. Typically around 30kpa if at idle. So now it sees 100kpa as 70 over baro which is ~10psi.

Also check the baro sensor you have selected in config and in Basic Settings -> Costants page
paul is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 52 08-28-2016 04:18 AM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 09:39 AM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 12:15 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 10:28 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:34 AM.