Need Your Suggestions Please - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 10-19-2010, 05:40 PM   #1
Junior Member
Thread Starter
iTrader: (13)
 
Join Date: Jul 2007
Location: San Antonio, TX
Posts: 498
Total Cats: 6
Default Need Your Suggestions Please

Mods are on my signature, I need help with my idling, etc. My injectors are from a Mitsubishi EVO8 which are low imp injectors which was cleaned and flow tested at 600cc by Deatschworks. My problem is my initial startup, I have to press the gas pedal WOT and start it a couple of times. It would start and it would not hold the idle, car would die a few times and finally hold idling. When driving and let go off the pedal, rpm drops to 600 rpm and engine dies, I have to heel-toe so my engine won't die. I tried MAP prediction but my car won't even start with MAP prediction. I would appreciate if anybody can take a look at my MAP and see what I can change to make this drivable without heel-toeing. Or if somebody out there with a 600cc low-z injectors, if you could post your map so I can compare. TIA.
Attached Files
File Type: ecu lsc224 tune 101310.ecu (8.0 KB, 100 views)
lsc224 is offline   Reply With Quote
Old 10-20-2010, 04:26 AM   #2
Elite Member
iTrader: (9)
 
Join Date: Jun 2008
Location: Houston, TX
Posts: 1,583
Total Cats: 8
Default

Hrrrrmmmmm, welll I see a couple things here.

Try messing around with the minimum idle air control valve duration under the idle tab to get things happy. Your cranking fuel map is like nothing I've ever seen to work, usually they are smooth curves downward. That could need some adjustment.

The main problem I see is that the car is not getting any extra air after cranking. I have corrected that in this map, it may really surge on you after startup. If it does you can reduce the amount of extra effort after cranking in the idle tab to correct the problem.

One more thing, your injectors look really unhappy about idling that low. You may have to increase your idle injector duration by a little bit to get things working properly. Let me know if this helps.
TravisR is offline   Reply With Quote
Old 10-20-2010, 07:55 AM   #3
Junior Member
Thread Starter
iTrader: (13)
 
Join Date: Jul 2007
Location: San Antonio, TX
Posts: 498
Total Cats: 6
Default

Quote:
Originally Posted by TravisR View Post
Hrrrrmmmmm, welll I see a couple things here.

Try messing around with the minimum idle air control valve duration under the idle tab to get things happy. Your cranking fuel map is like nothing I've ever seen to work, usually they are smooth curves downward. That could need some adjustment.

The main problem I see is that the car is not getting any extra air after cranking. I have corrected that in this map, it may really surge on you after startup. If it does you can reduce the amount of extra effort after cranking in the idle tab to correct the problem.

One more thing, your injectors look really unhappy about idling that low. You may have to increase your idle injector duration by a little bit to get things working properly. Let me know if this helps.
Thanks Travis, I appreciate. I'll try those today and let you know.

Last edited by lsc224; 10-20-2010 at 08:18 AM.
lsc224 is offline   Reply With Quote
Old 10-20-2010, 03:00 PM   #4
Junior Member
Thread Starter
iTrader: (13)
 
Join Date: Jul 2007
Location: San Antonio, TX
Posts: 498
Total Cats: 6
Default

Quote:
Originally Posted by TravisR View Post
One more thing, your injectors look really unhappy about idling that low. You may have to increase your idle injector duration by a little bit to get things working properly. Let me know if this helps.
Okay I admit, I am a dummy, I can't find it. I've clicked everything on WARI and searched the manual. Where do you increase idle injector duration?
lsc224 is offline   Reply With Quote
Old 10-20-2010, 07:34 PM   #5
Elite Member
iTrader: (9)
 
Join Date: Jun 2008
Location: Houston, TX
Posts: 1,583
Total Cats: 8
Default

SORRY! Here it is. Cranking injection is done on the cranking fuel tab under corrections. Idle fuel is done on the fuel tuning tab from 20kpa to 50kpa... rougly.

Best,
Travis
Attached Files
File Type: ecu lsc224idleresolve.ecu (8.0 KB, 148 views)
TravisR is offline   Reply With Quote
Old 10-20-2010, 09:31 PM   #6
Junior Member
Thread Starter
iTrader: (13)
 
Join Date: Jul 2007
Location: San Antonio, TX
Posts: 498
Total Cats: 6
Default

Quote:
Originally Posted by TravisR View Post
SORRY! Here it is. Cranking injection is done on the cranking fuel tab under corrections. Idle fuel is done on the fuel tuning tab from 20kpa to 50kpa... rougly.

Best,
Travis
Thanks Travis! I'll let you know how it goes.
lsc224 is offline   Reply With Quote
Old 10-20-2010, 10:55 PM   #7
Junior Member
Thread Starter
iTrader: (13)
 
Join Date: Jul 2007
Location: San Antonio, TX
Posts: 498
Total Cats: 6
Default

Whooohoooo, now it idles fine, it's a little high but at least my engine does not die anymore. Thanks Travis! Now I need to work on the cranking fuel and the Idle Fuel.

UPDATE: On my way to work it idles high, 2k rpm, so I parked and lowered the idle air control valve duration to about 66, now it idles about 1200 - 1300 rpm. Much much better. Now it feels like I am driving a normal car. But still idles a bit high, I think I am going to lower it later today to about 64. Car is much more fun to drive now.

Last edited by lsc224; 10-21-2010 at 11:57 AM.
lsc224 is offline   Reply With Quote
Old 10-24-2010, 09:05 PM   #8
Junior Member
Thread Starter
iTrader: (13)
 
Join Date: Jul 2007
Location: San Antonio, TX
Posts: 498
Total Cats: 6
Default

UPDATE:

I played around with the cranking fuel, and fixed it. Car still hard starts, but it's alot better now, I don't have to press WOT on the pedal. I can live with it, but I still want to fix this. Can anybody post their map to show their cranking fuel?

On the idle tab I fixed the Target Idle speed and also Base Idle Value. I also enabled the Extra Effort Off Throtthle and set it to 1. Car is close to running like stock.

Attach is my latest map. I would appreciate if anybody with a low-z 600 injectors post their map so I can compare. TIA
Attached Files
File Type: ecu lsc224_102410.ecu (8.0 KB, 87 views)
lsc224 is offline   Reply With Quote
Old 10-25-2010, 06:59 AM   #9
Newb
 
Join Date: Oct 2009
Location: Avondale, AZ
Posts: 29
Total Cats: 0
Default

Quote:
Originally Posted by lsc224 View Post
UPDATE:

I played around with the cranking fuel, and fixed it. Car still hard starts, but it's alot better now, I don't have to press WOT on the pedal. I can live with it, but I still want to fix this. Can anybody post their map to show their cranking fuel?

On the idle tab I fixed the Target Idle speed and also Base Idle Value. I also enabled the Extra Effort Off Throtthle and set it to 1. Car is close to running like stock.

Attach is my latest map. I would appreciate if anybody with a low-z 600 injectors post their map so I can compare. TIA
Dude you are running almost the same setup as me man minus the injectors, mine are 750 RC's and my idle is still jacked up after a year of trying to mess with it but, reading on what Travis told you I know what I have to do to stabilize it
Snake333 is offline   Reply With Quote
Old 10-26-2010, 11:45 PM   #10
Junior Member
Thread Starter
iTrader: (13)
 
Join Date: Jul 2007
Location: San Antonio, TX
Posts: 498
Total Cats: 6
Default

Quote:
Originally Posted by Snake333 View Post
Dude you are running almost the same setup as me man minus the injectors, mine are 750 RC's and my idle is still jacked up after a year of trying to mess with it but, reading on what Travis told you I know what I have to do to stabilize it

Can you load your map here? I want to see your cranking fuel map, thanks.
lsc224 is offline   Reply With Quote
Old 10-27-2010, 03:42 AM   #11
Newb
 
Join Date: Oct 2009
Location: Avondale, AZ
Posts: 29
Total Cats: 0
Default

Quote:
Originally Posted by lsc224 View Post
Can you load your map here? I want to see your cranking fuel map, thanks.
I actually fixed my idle pretty good the next day lol. My map is attached check it out, and if you could u look at my fuel and ignition maps to see if they look ok. thanks
Attached Files
File Type: ecu Idle and tps has been perfected.ecu (8.0 KB, 90 views)
Snake333 is offline   Reply With Quote
Old 10-27-2010, 05:12 PM   #12
Junior Member
Thread Starter
iTrader: (13)
 
Join Date: Jul 2007
Location: San Antonio, TX
Posts: 498
Total Cats: 6
Default

Quote:
Originally Posted by Snake333 View Post
I actually fixed my idle pretty good the next day lol. My map is attached check it out, and if you could u look at my fuel and ignition maps to see if they look ok. thanks
Good to hear you got your idle fixed. Mine for the most part is okay, but sometimes it would idle rought, stumble and die. My main problem is my cold start. Looking at your Cranking Fuel Map, it looks like you got high impedance injectors? Am I right?
lsc224 is offline   Reply With Quote
Old 10-28-2010, 04:12 AM   #13
Newb
 
Join Date: Oct 2009
Location: Avondale, AZ
Posts: 29
Total Cats: 0
Default

Yes i do have high impedance fuel injectors RC's. Dont get me wrong my idle is not perfect yet, but its way better than it was before, i still have idle dips coming out of gear at lights about 20 percent of the time. Did the map help?
Snake333 is offline   Reply With Quote
Old 10-28-2010, 02:37 PM   #14
Junior Member
Thread Starter
iTrader: (13)
 
Join Date: Jul 2007
Location: San Antonio, TX
Posts: 498
Total Cats: 6
Default

Quote:
Originally Posted by Snake333 View Post
Yes i do have high impedance fuel injectors RC's. Dont get me wrong my idle is not perfect yet, but its way better than it was before, i still have idle dips coming out of gear at lights about 20 percent of the time. Did the map help?
Yes it did help, gave me a few ideas to try. Thanks!
lsc224 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Cannot set Base Timing to 10* Elfering MEGAsquirt 50 10-05-2015 09:04 AM
1996 Turbo Build Goldwar DIY Turbo Discussion 2 09-29-2015 10:20 AM
The "other" spool question stefanst DIY Turbo Discussion 44 09-28-2015 08:16 PM
Software/IT types/Joe P, step inside please z31maniac Insert BS here 13 09-22-2015 03:59 PM
Reasonable source for NB coils. mx5-kiwi Race Prep 10 09-20-2015 08:31 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:37 PM.