F/IC will not connect to my computer HELP!!!! - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 04-01-2011, 09:15 PM   #1
Elite Member
Thread Starter
iTrader: (12)
 
Join Date: Nov 2009
Location: Harpers Ferry WV
Posts: 1,521
Total Cats: 20
Default F/IC will not connect to my computer HELP!!!!

Ok so for those of you that do not know I have a 92 miata with a 2jz I am running a AEM F/IC-2. I have tried to get this thing to connect to my computer, my laptop, and my buddies laptop. He is still working on his laptop right now. I have uploaded the software as well as the software update from AEM forums. All the computers are not able to find the driver for the FIC. Does anyone know if this is because I am runinng Windows Vista. Do I need to get something like XP or older? Any help would be great I would love to try and start my car but currently cannot due to too much fuel.
Sean is offline   Reply With Quote
Old 04-02-2011, 12:04 AM   #2
Elite Member
 
Join Date: Feb 2008
Location: Victoria, BC
Posts: 2,322
Total Cats: 12
Default

I ran mine on vista. It could be your f/ic is just screwed. It was ridiculous easy to get it to install on my system. Plugged it in, told it where the drive was, profit.
dustinb is offline   Reply With Quote
Old 04-06-2011, 01:16 PM   #3
Elite Member
Thread Starter
iTrader: (12)
 
Join Date: Nov 2009
Location: Harpers Ferry WV
Posts: 1,521
Total Cats: 20
Default

Maybe my F/IC is done. I am gonna try and do a few other things and if nothing else I will have to send it back to AEM for them to take a look at it. This sucks so bad I wanted to start my car!!!!!!!!!!!!!!!!!!!!!1
Sean is offline   Reply With Quote
Old 05-05-2011, 12:22 PM   #4
Junior Member
iTrader: (2)
 
Join Date: Aug 2008
Location: Richmond
Posts: 117
Total Cats: 0
Default

I think you should read this post.
http://forum.aempower.com/forum/inde...c,20462.0.html

Download the driver installer
Mikeymx5 is offline   Reply With Quote
Old 05-05-2011, 12:59 PM   #5
Elite Member
Thread Starter
iTrader: (12)
 
Join Date: Nov 2009
Location: Harpers Ferry WV
Posts: 1,521
Total Cats: 20
Default

Thanks I will use this on my next one. I sent mine back to the people I bought it from and according to them "I fried two resistors inside the unit so it would not connect". I did not fry anything because I never hooked it to the car. All I did was take it out of the box and try to get it to link to the computer. The unit never saw more than the voltage from the usb cord. This is ok though because they are sending me a new one free of charge.

I will download this on my laptop and try it on the new one. Thanks a lot.
Sean is offline   Reply With Quote
Old 05-05-2011, 04:08 PM   #6
Junior Member
iTrader: (2)
 
Join Date: Aug 2008
Location: Richmond
Posts: 117
Total Cats: 0
Default

Good Luck! I currently have a Love/Hate relationship with the FIC only because they have not fixed the IRT settings.
Mikeymx5 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 58 12-13-2017 10:04 PM
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Bizarre connection issue? nick470 MEGAsquirt 1 09-30-2015 11:32 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:45 AM.