Chiburbian's 01' Lots of potential, no follow-through build - Page 17 - Miata Turbo Forum - Boost cars, acquire cats.

Go Back  Miata Turbo Forum - Boost cars, acquire cats. > General Discussion > Media > Build Threads
Reload this Page >

Chiburbian's 01' Lots of potential, no follow-through build

Build Threads Building a motor? Post the progress here.

Chiburbian's 01' Lots of potential, no follow-through build

Old 03-24-2015, 10:18 PM
  #321  
Senior Member
 
Join Date: Mar 2011
Location: South Chicago
Posts: 697
Total Cats: 26
Default

Just FYI You can save yourself about $50-$100. I refreshed my rotors from Rockauto for about $150. Hawk HP+ pads were about $200. Steel braided lines were line $95. That was all through Fab9. If you keep the rotors, most Pepboys or Midas will resurface them for $50-$60.

With it being a street car for the most part, i think it's sort of overkill to opt for wilwoods or something. Since you're ona budget save your money and put it toward that ewg.
Mazduh is offline  
Old 03-27-2015, 04:48 PM
  #322  
Elite Member
Thread Starter
iTrader: (1)
 
Chiburbian's Avatar
 
Join Date: Feb 2008
Location: Gilberts, IL
Posts: 2,296
Total Cats: 175
Default

I pulled the Turbo today to look at my options. One thing that stuck out at me was my wastegate flapper was moving all over the place.



So first things first, the turbo goes back to precision to see what they say. They might as well check out the seals and stuff while it's out.
Chiburbian is offline  
Old 03-27-2015, 06:31 PM
  #323  
Senior Member
iTrader: (3)
 
Join Date: Dec 2007
Location: Brownsburg,IN
Posts: 825
Total Cats: 61
Default

Originally Posted by Chiburbian View Post
I pulled the Turbo today to look at my options. One thing that stuck out at me was my wastegate flapper was moving all over the place.



So first things first, the turbo goes back to precision to see what they say. They might as well check out the seals and stuff while it's out.
That play does not look good but it most lokley does not contribute your boost creep unless it prevent the wastegate from opening all the way, it most likley does not seal Very well so it will move your boost onset to a little higer rpm.
HHammerly is offline  
Old 03-27-2015, 06:43 PM
  #324  
VladiTuned
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 35,023
Total Cats: 3,085
Default

that flapper is broken/defective.
it should never do that
18psi is offline  
Old 03-27-2015, 08:33 PM
  #325  
Design Engineer
iTrader: (1)
 
DNMakinson's Avatar
 
Join Date: Jan 2013
Location: Seneca, SC
Posts: 3,092
Total Cats: 368
Default

Looks like you found the problem. How long do you think you'll be down?
DNMakinson is offline  
Old 03-28-2015, 02:31 AM
  #326  
Elite Member
Thread Starter
iTrader: (1)
 
Chiburbian's Avatar
 
Join Date: Feb 2008
Location: Gilberts, IL
Posts: 2,296
Total Cats: 175
Default

I doubt that was my problem really. It might explain me taking longer to get to my target boost but I can't see how that would cause my boost to spike or over shoot.

It all depends on what happens once it gets to Precision, and I wasn't able to get it out of the house today. I am hoping to ship it on Monday. I am guessing the car is down for a minimum two weeks, because even when it gets back it needs to be ported.
Chiburbian is offline  
Old 03-31-2015, 05:20 PM
  #327  
Elite Member
Thread Starter
iTrader: (1)
 
Chiburbian's Avatar
 
Join Date: Feb 2008
Location: Gilberts, IL
Posts: 2,296
Total Cats: 175
Default

Progress, just not the really interesting to read kind. My RS3s shipped from TireRack today. My 6ULs should arrive sometime in April.

And I sent the turbo to Precision today. After getting back to my shop I realize that it was only a 67 mile drive from my job to them. I could have left work early and been there and back and saved money on shipping once you figured insurance... Oh well.
Chiburbian is offline  
Old 04-08-2015, 05:09 PM
  #328  
Elite Member
Thread Starter
iTrader: (1)
 
Chiburbian's Avatar
 
Join Date: Feb 2008
Location: Gilberts, IL
Posts: 2,296
Total Cats: 175
Default

Talked to precision today... They say that there is a three week timeframe for turbos to hit the bench to be looked at. ****.

It's possible that it's done earlier, but still - to be without my car for a month? That's just not right. I am half tempted to buy a GT2560 and just sell the precision when it comes back.

EDIT: I am REALLY close to a part-out thread right now. But that's just me being really impatient. I think.

Last edited by Chiburbian; 04-08-2015 at 05:34 PM.
Chiburbian is offline  
Old 04-21-2015, 01:23 PM
  #329  
Elite Member
Thread Starter
iTrader: (1)
 
Chiburbian's Avatar
 
Join Date: Feb 2008
Location: Gilberts, IL
Posts: 2,296
Total Cats: 175
Default

Part-out threat was just me venting by the way. Everything is cool...

Except that I am still terribly disappointed at the customer service at Precision Turbo. I never got a call or email telling me that the turbo even arrived safely and what to expect. Tomorrow is three weeks of them having the turbo. We will see if/when I get a call. I'll update this thread when I have more info.
Chiburbian is offline  
Old 04-21-2015, 01:34 PM
  #330  
Senior Member
 
Join Date: Mar 2011
Location: South Chicago
Posts: 697
Total Cats: 26
Default

Yeah precision is a 35min drive from my house. :-D

I'm just about to ship my turbo to BNR so I know how you feel. Luckily BNR said they don't have much going on and turn around time should be like 2 weeks.

If you part I will hate your forever because I don't have any money to give you.
Mazduh is offline  
Old 04-21-2015, 01:45 PM
  #331  
Elite Member
Thread Starter
iTrader: (1)
 
Chiburbian's Avatar
 
Join Date: Feb 2008
Location: Gilberts, IL
Posts: 2,296
Total Cats: 175
Default

Originally Posted by Mazduh View Post
Yeah precision is a 35min drive from my house. :-D
When I get the call that it's done I plan on picking it up in person. When I realized how close they were I wanted to kick myself. I would have paid less in gas than it cost to ship + insurance.
Chiburbian is offline  
Old 04-23-2015, 04:53 PM
  #332  
Elite Member
Thread Starter
iTrader: (1)
 
Chiburbian's Avatar
 
Join Date: Feb 2008
Location: Gilberts, IL
Posts: 2,296
Total Cats: 175
Default

Didn't receive a phone call yesterday. Emailed Precision today. Tick-tock.
50% of Miatas with precision turbos have failed (ok the ones we know of on MT.net). Your clock is ticking precision...

EDIT: noon on Friday: Still haven't received an email or call so I called them. They said that turbo arrived, was sent to service dept on the 7th (a week to get into the service dept from shipping?), and I should be receiving a call early next week. Still unimpressed.

EDIT #2: So, it's been a month that Precision has had my turbo. Calling them tomorrow morning if I don't hear from them by end of day today.

Last edited by Chiburbian; 04-29-2015 at 12:42 PM.
Chiburbian is offline  
Old 05-07-2015, 01:23 AM
  #333  
Elite Member
Thread Starter
iTrader: (1)
 
Chiburbian's Avatar
 
Join Date: Feb 2008
Location: Gilberts, IL
Posts: 2,296
Total Cats: 175
Default

So a quick update. I talked to Justin at precision last Friday. He apologized and assured me that the service manager would be calling me this week.

As far as I am concerned their time is up. Unless they say something supremely compelling tomorrow I am just going to order a new turbine housing and go pick up my turbo and forever stop specifying what kind of turbo I'm running. They have not proven to me that they care about me as a customer so why should I champion their brand.

They have had my turbo for 28 WEEK days. Beyond ******* ridiculous.

EDIT: talked to them today. Still not looked at. I am going to pick it up tomorrow and figure out a way to fix it myself.

Last edited by Chiburbian; 05-07-2015 at 03:53 PM.
Chiburbian is offline  
Old 05-08-2015, 10:00 PM
  #334  
Elite Member
Thread Starter
iTrader: (1)
 
Chiburbian's Avatar
 
Join Date: Feb 2008
Location: Gilberts, IL
Posts: 2,296
Total Cats: 175
Default

Quick update... Precision came through in the end. Turbo was ready today when I picked it up. It had been tested and the turbine housing replaced at no charge. Now I just need to get it ported.
Chiburbian is offline  
Old 05-08-2015, 10:14 PM
  #335  
Elite Member
iTrader: (1)
 
Join Date: Jun 2014
Location: Austin, TX
Posts: 3,013
Total Cats: 315
Default

Good to hear !
Girz0r is offline  
Old 05-10-2015, 12:25 AM
  #336  
Elite Member
Thread Starter
iTrader: (1)
 
Chiburbian's Avatar
 
Join Date: Feb 2008
Location: Gilberts, IL
Posts: 2,296
Total Cats: 175
Default

Turbine housing has been dropped off at the shop to be ported. We are going to try opening up the wastegate discharge as big as we can safely go as well.

6ULs are mounted and waiting to be put on the car. Brake hardware has been ordered. I'll take pictures tomorrow of the wheels and the brake stuff when it arrives.
Chiburbian is offline  
Old 05-10-2015, 12:58 AM
  #337  
VladiTuned
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 35,023
Total Cats: 3,085
Default

Porting the pathway to the hole is actually more important than enlarging the hole.
(I just realized what I typed )
18psi is offline  
Old 05-10-2015, 12:59 AM
  #338  
Elite Member
Thread Starter
iTrader: (1)
 
Chiburbian's Avatar
 
Join Date: Feb 2008
Location: Gilberts, IL
Posts: 2,296
Total Cats: 175
Default

Originally Posted by 18psi View Post
Porting the pathway to the hole is actually more important than enlarging the hole.
(I just realized what I typed )
Well, right. But if we are there, we might as well do all we can.
Chiburbian is offline  
Old 05-11-2015, 01:48 AM
  #339  
Elite Member
iTrader: (6)
 
blaen99's Avatar
 
Join Date: Sep 2010
Location: Seattle, WA
Posts: 4,093
Total Cats: 27
Default

Originally Posted by Chiburbian View Post
Turbine housing has been dropped off at the shop to be ported. We are going to try opening up the wastegate discharge as big as we can safely go as well.

6ULs are mounted and waiting to be put on the car. Brake hardware has been ordered. I'll take pictures tomorrow of the wheels and the brake stuff when it arrives.
How much -bleeping- power are you planning on running on it? My housing is unported, I'm pushing ~350rwhp with no mentionable creep issues as per the dyno charts.
blaen99 is offline  
Old 05-11-2015, 06:31 AM
  #340  
Elite Member
Thread Starter
iTrader: (1)
 
Chiburbian's Avatar
 
Join Date: Feb 2008
Location: Gilberts, IL
Posts: 2,296
Total Cats: 175
Default

Try running wastegate pressure and see what it creeps to. I was targeting 12-13psi max and had boost cut enabled and was hitting it constantly.

The long and short of it is, I'm going to do everything I possibly can within my budget to fix or illuminate the problem before I reassemble.

Last edited by Chiburbian; 05-11-2015 at 07:41 AM.
Chiburbian is offline  

Thread Tools
Search this Thread
Quick Reply: Chiburbian's 01' Lots of potential, no follow-through build


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.