BEGI Kit Pics - Page 4 - Miata Turbo Forum - Boost cars, acquire cats.

DIY Turbo Discussion greddy on a 1.8? homebrew kit?
Sponsored by:
Sponsored by:

BEGI Kit Pics

Old 12-25-2007, 09:08 PM
  #61  
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,140
Total Cats: 6
Default

Originally Posted by sv650_ck View Post
Mine runs like stock with the bypass harness installed. Doesn't matter how much you shake, twist, etc., it doesn't miss a beat. I was hoping to have the fueling stuff working before installing the turbo but not gonna happen. May have to pick up a used voodoo card to get me going.
Noooooo not a voodoo card. j/k w/e you have to do to get running.
If you end up wanting to go megasquirt, you'll gain EBC, Launch, and knock sensing as well as a few other great options. You'd just need a CAS to install and the MS. Let me know if you end up wanting an upgrade from the FIC
Sounds like you might have luck with a firmware downgrade as well. Hope that works for you guys.
cjernigan is offline  
Old 12-25-2007, 10:17 PM
  #62  
Junior Member
 
Join Date: Nov 2007
Posts: 98
Total Cats: 0
Default

Originally Posted by emmi View Post
okay well i regretted doing this but the problem is in v2 which i recall u do having frm the video...

i just updated mine right now and my car got hella fucked up... im trying right now to downgrade back to V1 damn....

it idled, then it threw a CEL and it started bogging and drastically changing idle...
okay, so an hour later... i couldnt find a way to downgrade my firmware. so i decided to **** with what i have. persistance and curiousity paid off as my car is gunning nice again. it was annoying though...

my CEL was caused by improper voltage in the TPS during calibration. it was at 0% (foot off) when the key was at acc, but allova sudden it would be at 189% when the key is on the ON position. that turned the sucker off...

in version 1, my maf was set to 11% all across the field. and that wasnt doing it for me so i raised up the field to 14%. i'd actually like to throw this out in the air because i have NOOO idea on setting the MAF, and this setting works for me... so can anyone tell me what i can do w/ messing with the settings? and if the percent is supposed to rise up along w/ the revs or what???


anyways, yeaup i really hope this helps you... as of right now i cant find anything else wrong w/ my f/ic but it was experiancing the same things when i upgraded... now i can get my car out of the grass and go drink!!! merry Xmas!
emmi is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
StratoBlue1109
Miata parts for sale/trade
20
09-30-2018 02:09 PM
Full_Tilt_Boogie
Build Threads
63
08-09-2018 07:54 PM
tazswing
Race Prep
20
10-03-2015 12:04 PM
JxPhan
Meet and Greet
3
10-02-2015 03:17 AM
lsc224
Miata parts for sale/trade
2
10-01-2015 10:17 AM


Thread Tools
Search this Thread
Quick Reply: BEGI Kit Pics


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.