DIY Turbo Discussion greddy on a 1.8? homebrew kit?
Sponsored by:
Sponsored by:

Car won't start after turbo install

 
Old 03-06-2018, 06:21 PM
  #1  
Newb
Thread Starter
 
Join Date: Jan 2018
Location: Como Italy
Posts: 4
Total Cats: 1
Default Car won't start after turbo install

Hi guys.. I'm a new entry in the forum and I'm just here for an issue that I can't solve!
I've just finished my turbo setup:
Td04 with custom manifold and downpipe managed by an emanage ultimate
From three days I'm trying to start the car without success.
There is spark and the fuel arrives in the rail but I think there is something wrong with the injectors. Two time it seems to start (the first with yellow rx8 injectors and the second time with stock blue injectors) but after a trip on 3k rpm it died.
​​​​​​Every time I unplug and plug the injectors it seems to start but then it won't.
Any ideas on what to do? Tomorrow I will try to unplug the emanage and try to start with the standard ecu.
Carlo Joll Negri is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
swimomatic
Engine Performance
16
01-13-2018 05:19 AM
estephens13
AEM
2
02-07-2016 11:06 PM
2cheap
DIY Turbo Discussion
2
07-17-2011 12:20 PM
DocStruthers
Engine Performance
3
05-02-2011 01:36 AM
boileralum
Engine Performance
5
05-18-2009 04:01 PM


Thread Tools
Search this Thread
Quick Reply: Car won't start after turbo install


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.