clocking turbo potential issue... - Page 2 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 03-31-2011, 01:19 AM   #21
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Posts: 107
Total Cats: 0
Default

Just put in a rivet restrictor. Hopefully tomorrow will be less smoky. We'll see how long it takes me to get ticketed on campus tomorrow filling the parking garage with oily smoke!
TheMcCoy14 is offline   Reply With Quote
Old 03-31-2011, 03:15 AM   #22
Junior Member
 
Golferluke's Avatar
 
Join Date: Oct 2009
Location: Springfield, MO
Posts: 497
Total Cats: 3
Default

First off were in missouri are you located? Have you taken your dp off to see if it's leaking in the turbo? Could just take a long time to burn out that oil. Then again I don't know why it wouldn't be spoiling. Do the blades spin freely? Also, stupid question I know but are you sure you didn't blow an ic piping coupler? Even if the turbo was hosed, if the blades are spinning I'd imagine it would make atleast some kind of boost.
Golferluke is offline   Reply With Quote
Old 03-31-2011, 10:27 AM   #23
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Posts: 107
Total Cats: 0
Default

I plan on checking to see if the blades are spinning soon. Between school and work it's hard to find daylight to work on the car. I'm in Springfield, mo btw. I went over all the couplers and all seem to be attached correctly. I even went so far as to tighten my new bov almost all the way in case it was leaking. We'll see how it runs today with the restrictor in place. I haven't gotten on it too hard yet just because the smoking prevented me from doing so. Thanks for all the input so far guys.
Ben
TheMcCoy14 is offline   Reply With Quote
Old 03-31-2011, 04:58 PM   #24
Newb
 
Join Date: Sep 2010
Location: Everett, Washington
Posts: 8
Total Cats: 0
Default

well if youre blow off valve was leaking, couldnt that be the reason youre not boosting? boost leak. it should be boosting no matter what, unless theres a leak, becuase if its a brand new turbo even if it is cxracing, it should spin freely..and if its spinning youll get boost. technically.

i had a cxracing turbo on my old toyota cressida, i didnt have a restrictor and the seals blew almost instantly, but i was still making 8 lbs of boost.
idylan123 is offline   Reply With Quote
Old 03-31-2011, 05:14 PM   #25
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Posts: 107
Total Cats: 0
Default

Back from school today. Still smokes and I can't hear the turbo in the exhaust...
TheMcCoy14 is offline   Reply With Quote
Old 03-31-2011, 05:29 PM   #26
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Posts: 107
Total Cats: 0
Default

Don't know what it could be. There is just an ungodly amount of smoke when I put my foot down and my boost gauge looks like there isn't a turbo at all. I don't make more than -8psi ever... I've contacted CXRacing and hopefully I'll at least get a free rebuild kit after all this nonsense.
TheMcCoy14 is offline   Reply With Quote
Old 03-31-2011, 05:47 PM   #27
Antisaint
iTrader: (17)
 
Vashthestampede's Avatar
 
Join Date: Feb 2007
Location: Danbury, CT
Posts: 4,659
Total Cats: 54
Default

Something doesnt sound right. Post some pictures of your setup and let everyone have a look at what your working with.
Vashthestampede is offline   Reply With Quote
Old 03-31-2011, 06:05 PM   #28
Senior Member
iTrader: (5)
 
Join Date: Jan 2008
Location: Central, TX / Bay area, CA
Posts: 1,272
Total Cats: 3
Default

There web site says restrictors are required on there turbos
Gotpsi? is offline   Reply With Quote
Old 03-31-2011, 06:10 PM   #29
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Posts: 107
Total Cats: 0
Default

The only thing that I can think is that when I clocked my turbo to line up the wastegate properly I left the oil feed slightly off top dead center. It's off by maybe a few degrees but I can't imagine that it would instantly destroy a turbo...
TheMcCoy14 is offline   Reply With Quote
Old 03-31-2011, 07:45 PM   #30
Senior Member
iTrader: (14)
 
Join Date: Oct 2006
Location: South East Florida
Posts: 690
Total Cats: 6
Default

I think my issue might be a little too dissimilar to yours, but check out my recent thread: https://www.miataturbo.net/showthrea...t=turbo+ruined

Restrictor solved my problem. Took a little bit of driving before it stopped smoking.

My turbo was making boost perfectly fine while smoking.
94mx5red is offline   Reply With Quote
Old 04-01-2011, 03:02 PM   #31
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Posts: 107
Total Cats: 0
Default

Still no boost but I can hear the turbo in the exhaust... Somethings seriously eff'd up... Still reading boost levels like an NA car...
TheMcCoy14 is offline   Reply With Quote
Old 04-03-2011, 03:58 PM   #32
Newb
 
Join Date: Sep 2010
Location: Everett, Washington
Posts: 8
Total Cats: 0
Default

maybe your turbos too big and you just cant make boost. lol
idylan123 is offline   Reply With Quote
Old 04-07-2011, 12:06 PM   #33
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Posts: 107
Total Cats: 0
Default

Soo thought about this yesterday. I saw a small crack a while back on the back side of my manifold. I'm running straight pipes so I'm not sure if I'd be able to hear an exhaust leak up front. Could my cheapo manifold be leaking so badly that the turbo wouldn't spool? I'll be investigating soon but school and work have made this repair pretty lengthy.
TheMcCoy14 is offline   Reply With Quote
Old 04-07-2011, 12:25 PM   #34
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,892
Total Cats: 1,792
Default



I made 160rwhp on this.
Braineack is online now   Reply With Quote
Old 04-14-2011, 02:56 PM   #35
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Posts: 107
Total Cats: 0
Default

So yeah... My air filter was soo gross that it wasn't allowing enough air in to spool the turbo. Didn't think that was possible... Turns out my room mate washed it when we swapped turbos and it's not washable; resulting in the filter material becoming one solid mass. My retardation knows no bounds!
TheMcCoy14 is offline   Reply With Quote
Old 04-14-2011, 03:16 PM   #36
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Posts: 107
Total Cats: 0
Default

turbo still needs a rebuild being that it's smoking under full boost pretty badly but at least the problem's been found
TheMcCoy14 is offline   Reply With Quote
Old 04-14-2011, 04:18 PM   #37
Senior Member
iTrader: (5)
 
Join Date: Jan 2008
Location: Central, TX / Bay area, CA
Posts: 1,272
Total Cats: 3
Default

Get that mani fixed or get a new one, a leak there will cause problems
Gotpsi? is offline   Reply With Quote
Old 04-14-2011, 07:45 PM   #38
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Posts: 107
Total Cats: 0
Default

Probably converting to T3 with a cast mani. No more cracks!
TheMcCoy14 is offline   Reply With Quote
Old 05-26-2011, 04:55 PM   #39
Junior Member
iTrader: (2)
 
Join Date: May 2009
Posts: 68
Total Cats: 0
Default

I had the same problem with a godspeed t28, wouldn't build boost...I have no idea why. I even closed the wastegate completly and no boosts...leak tested all my pipes and **** no leaks...turbo just sucked I guess.
Weaver is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 Yesterday 09:00 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Noob to Miataturbo from MA JxPhan Meet and Greet 3 10-02-2015 03:17 AM
ISO 1.6 turbo cast iron manifold cale saurage DIY Turbo Discussion 16 10-01-2015 12:25 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:48 AM.