Does this BOV sound right? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 04-23-2012, 06:11 PM   #1
Senior Member
Thread Starter
iTrader: (4)
 
mr_hyde's Avatar
 
Join Date: Jul 2009
Location: Seattle
Posts: 799
Total Cats: 25
Default Does this BOV sound right?

I've got an HKS I got from a forum member that's not supposed to be a knock-off. I'll deal with the ricey sound if I'm not beating on my turbo. Please take a peek at the 10 second youtube video and let me know what you think. It sounds like its surging a bit to me. The video is my first weekend on the new build so I'm on wastegate pressure ~10psi.







Attached Thumbnails
Does this BOV sound right?-p4237744.sized.jpg   Does this BOV sound right?-p4237745.sized.jpg  

Last edited by Braineack; 04-24-2012 at 10:20 AM.
mr_hyde is offline   Reply With Quote
Old 04-23-2012, 06:16 PM   #2
Elite Member
iTrader: (3)
 
Join Date: Mar 2008
Location: Granbury, TX
Posts: 6,009
Total Cats: 583
Default

I agree. That chirping sound is what I normally associate with surge, not venting.
hornetball is offline   Reply With Quote
Old 04-24-2012, 03:45 AM   #3
Senior Member
Thread Starter
iTrader: (4)
 
mr_hyde's Avatar
 
Join Date: Jul 2009
Location: Seattle
Posts: 799
Total Cats: 25
Default

Reading around for suggestions taught me that sharing the signal line is bad so I moved the BOV to its own source. Now it seems to make a more concise 'sneeze' without the extra pulse so problem solved for now beside the obnoxious ricer mating call. Every time I shift, I expect to see a horny civic in the mirror wanting to frisky.

I'm trying to go to the track on Friday and this test drive showed me my fuel has gone crazy (AFRs swinging wildly). It's too late tonight to troubleshoot but I'm glad I found this out now instead of on grid Friday morning.
mr_hyde is offline   Reply With Quote
Old 04-24-2012, 10:26 AM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,838
Total Cats: 1,787
Default

it sounds like it's sprung too tightly.

is they any sort of adjustment screw on that device? there should be, and if so, loosen it out.

if not, you may need to open up the 8 bolts on the back, and see if there's dual springs in the device and maybe remove one (probably remove the light spring first and see).


also, that front piece (the tri-blade thing) is designed to make it "squeal"

Braineack is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:37 PM.